1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Icon aal anybody running these

Discussion in 'Suspension' started by The1youluv2hate, Jan 28, 2011.

  1. Jan 28, 2011 at 12:58 PM
    #1
    The1youluv2hate

    The1youluv2hate [OP] Well-Known Member

    Joined:
    Sep 14, 2010
    Member:
    #43233
    Messages:
    2,715
    Gender:
    Male
    First Name:
    Peps
    SP... CaL
    Vehicle:
    11 TRD sPort
    5100's@1.75 Horns (Andres) Satoshi TRD cat back BHLM
  2. Jan 28, 2011 at 1:30 PM
    #2
    The1youluv2hate

    The1youluv2hate [OP] Well-Known Member

    Joined:
    Sep 14, 2010
    Member:
    #43233
    Messages:
    2,715
    Gender:
    Male
    First Name:
    Peps
    SP... CaL
    Vehicle:
    11 TRD sPort
    5100's@1.75 Horns (Andres) Satoshi TRD cat back BHLM
    Cool thanks on the info
     
  3. Jan 28, 2011 at 1:37 PM
    #3
    The1youluv2hate

    The1youluv2hate [OP] Well-Known Member

    Joined:
    Sep 14, 2010
    Member:
    #43233
    Messages:
    2,715
    Gender:
    Male
    First Name:
    Peps
    SP... CaL
    Vehicle:
    11 TRD sPort
    5100's@1.75 Horns (Andres) Satoshi TRD cat back BHLM
    That's a bad ass truck
     
  4. Jan 28, 2011 at 1:49 PM
    #4
    Bama_TACO

    Bama_TACO ROLL TIDE!!!!!!!

    Joined:
    Aug 3, 2010
    Member:
    #41157
    Messages:
    1,017
    Gender:
    Male
    Winfield, AL
    Vehicle:
    2006 PreRunner Double Cab TRD SPORT
    I just put them in a few weeks ago. I really like them. I had ordered 5100s to install at the same time but they got put on backorder. So I installed the Icons with the factory Sport Bilsteins. I was expecting a rough ride but it's not much different than stock. You can tell it is a little more firm, but it is not bouncy at all. I have since cancelled by 5100s for the back and will run the factory Bilsteins for a while longer. My axle wrap is completely gone. It was supposed to be a 1.5" lift, but mine turned out to be a little over 2 1/4". I'm guessing because the factory springs had 88,000 miles on them. The haven't settle any yet. I really like these springs. I haven't hauled a load yet, so I can't comment on how they handle a load.

    By the way, my front 5100s are set at 2.5" and I have about 1 1/4" of rake (back higher).

    [​IMG]
     
  5. Jan 28, 2011 at 9:39 PM
    #5
    rzimm001

    rzimm001 Tearmytaco

    Joined:
    Mar 16, 2009
    Member:
    #14812
    Messages:
    1,023
    Gender:
    Male
    First Name:
    Bobby
    Wildomar
    Vehicle:
    08 PreRunner SR5 Long-Travel
    King 10" coilovers w/ resi. 3.5" over long travel kit. Factory spindles w/ ALLPRO gussets. Total Chaos tower gussets. Energy Poly cab mounts and steering rack mounts. Glassworks fenders and bedsides. Home fabbed bed cage. King 2.5x16 bypass shocks in the rear. DMZ long travel rear end. Race radio (2meter). Removed secondary carbon air filter. Exhaust dumped before the axle / no muffler. Phram fresh air cabin filter. K&N replacement filter, After market stereo, Grillcraft grill, custom fabled roof rack with 7" HID's, PRP race seats.
    Do it! They're awesome. It's like running an expedition pack from allpro. That's the closes analogy I can make. I love mine.
     
To Top