1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Idle Issues

Discussion in '4 Cylinder' started by TC95, Mar 22, 2013.

  1. Mar 22, 2013 at 9:52 AM
    #1
    TC95

    TC95 [OP] New Member

    Joined:
    Mar 22, 2013
    Member:
    #100288
    Messages:
    2
    Gender:
    Male
    I have a 2.7L 1995 Tacoma with 470, 000 miles on it ( bought it brand new ). I've been having idle issues for months now. Starts up fine and idles smooth. Then, I drive a short distance and when I stop the engine starts to sputter and sometimes stop. Other times it starts to sputter and them smooths out. Any ideas on what could be wrong?
     
  2. Mar 22, 2013 at 12:39 PM
    #2
    oldblue1968chevy

    oldblue1968chevy Well-Known Member

    Joined:
    Nov 26, 2012
    Member:
    #91916
    Messages:
    1,540
    Gender:
    Male
    First Name:
    John
    Spokane WA/Viola TN
    Vehicle:
    2000 Toyota Tacoma V6 TRD
    Stock
    Pix or it didnt happen?!!?!!?!!?

    Thats bookooo miles lol
     
  3. Mar 22, 2013 at 5:09 PM
    #3
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    1,846
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, stock gears, stock-size tires, Michelin LTX AT2, Tranny skidplate, sliders, UltraGauge, PowerTank, CB
    Explain how a photo of his truck will help you diagnose his problem :confused: :D
     
  4. Mar 22, 2013 at 5:12 PM
    #4
    Dark_Taco

    Dark_Taco Feed him a hammer, he'd crap out nails.

    Joined:
    Jun 26, 2008
    Member:
    #7576
    Messages:
    724
    Gender:
    Male
    Vehicle:
    08' TRD Rugged Trail Edition
    It has 1/2 a million miles on it! :D:D:D:D:D

    Thats awesome by the way!
     
  5. Mar 22, 2013 at 5:12 PM
    #5
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    1,846
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, stock gears, stock-size tires, Michelin LTX AT2, Tranny skidplate, sliders, UltraGauge, PowerTank, CB
    Some likely culprits are the TPS, IACV, and coolant temp sensor. Get a decent repair manual and check those out.
     
  6. Mar 22, 2013 at 5:14 PM
    #6
    Steves104x4

    Steves104x4 Well-Known Member

    Joined:
    Apr 17, 2010
    Member:
    #35468
    Messages:
    6,156
    Gender:
    Male
    First Name:
    Steve
    Buffalo NY
    Vehicle:
    2010 RC 2.7 4x4
    BUCKLE UP! It makes it harder for Aliens to pull you out of your Truck.
    I'm gonna guess EGR valve; I think you got your monies worth out of that one. Check for dry rotted or broken vacuum lines, too. Clean the MAF sensor. If the O2 sensor has more than say 150k might be an idea to change that, too. 480k; nice.
     
  7. Mar 23, 2013 at 11:12 AM
    #7
    TC95

    TC95 [OP] New Member

    Joined:
    Mar 22, 2013
    Member:
    #100288
    Messages:
    2
    Gender:
    Male
    Thanks everyone! I'll follow your suggestions. Love my Tacoma. Just trying to reach that 500,000 mile mark. Then send it to retirement....maybe.
     
  8. Mar 24, 2013 at 12:36 PM
    #8
    oldblue1968chevy

    oldblue1968chevy Well-Known Member

    Joined:
    Nov 26, 2012
    Member:
    #91916
    Messages:
    1,540
    Gender:
    Male
    First Name:
    John
    Spokane WA/Viola TN
    Vehicle:
    2000 Toyota Tacoma V6 TRD
    Stock
    I just want to see the odometer, thats amazing lol
     
  9. Apr 19, 2013 at 11:01 PM
    #9
    scootn2nature

    scootn2nature ttora member since 2001

    Joined:
    Apr 1, 2013
    Member:
    #101084
    Messages:
    22
    Gender:
    Male
    orinda
    Vehicle:
    2000 2.7l sr5
    bentup sliders, tjm t17, badland rear,custom leafsprings, fabtech performance co's,
    IAC valve is plugged up remove and clean...............
     
To Top