1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Idle Problems

Discussion in '1st Gen. Tacomas' started by Street, Aug 23, 2011.

  1. Aug 23, 2011 at 5:21 AM
    #1
    Street

    Street [OP] Well-Known Member

    Joined:
    Aug 23, 2011
    Member:
    #62173
    Messages:
    105
    Gender:
    Male
    First Name:
    jon
    Brevard
    Vehicle:
    Tacoma
    Hi, My truck is a 99 2wd reg 2.4 or (2rz?) my idle shifts high and low at red lights etc... mainly when the A/C is on and you can sometimes here the relays flipping out.

    things I've done
    IAC cleaned
    temp senor
    plugs wires
    new bat.

    The truck now has 307k and I got her for 750 with 296k the miles are all highway and mostly what I put on. I went over a little bit on the oil change I just did and the oil was cleaner that any motor I have ever done. SOLD on Toyota!!!!!!

    So any help? thx Jon Street
     
  2. Aug 23, 2011 at 6:34 PM
    #2
    96Taco

    96Taco Well-Known Member

    Joined:
    Jan 6, 2011
    Member:
    #48827
    Messages:
    766
    Gender:
    Male
    Alberta
    Vehicle:
    '04 V8 4Runner
    ..stay tuned
    Is your truck a manual? Does it just idle surge when putting your foot on the clutch when slowing down? If so, mine did that and I replaced the TPS and problem solved.
     
  3. Aug 25, 2011 at 8:13 PM
    #3
    Street

    Street [OP] Well-Known Member

    Joined:
    Aug 23, 2011
    Member:
    #62173
    Messages:
    105
    Gender:
    Male
    First Name:
    jon
    Brevard
    Vehicle:
    Tacoma
    na never noticed that as a problem and i don't really have a cold start prob either, just got an idle drop and increase when the ac cycles
     
  4. Aug 26, 2011 at 10:01 AM
    #4
    96Taco

    96Taco Well-Known Member

    Joined:
    Jan 6, 2011
    Member:
    #48827
    Messages:
    766
    Gender:
    Male
    Alberta
    Vehicle:
    '04 V8 4Runner
    ..stay tuned
    thats normal.
     
  5. Aug 27, 2011 at 4:21 AM
    #5
    Street

    Street [OP] Well-Known Member

    Joined:
    Aug 23, 2011
    Member:
    #62173
    Messages:
    105
    Gender:
    Male
    First Name:
    jon
    Brevard
    Vehicle:
    Tacoma
    its not come drive my truck....if Toyota could think for a min. a 5spd truck or car would be better with a Tech.

    My idle is not a little drop and increase its a damn spike that can sometimes cause it to die but not often:confused:
     
  6. Aug 27, 2011 at 4:58 AM
    #6
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,248
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    When's the last time the injectors were cleaner? Fuel filter changed? MAF cleaned?

    If you want to rule the AC out, just unplug the clutch.
     
  7. Aug 28, 2011 at 2:52 PM
    #7
    Street

    Street [OP] Well-Known Member

    Joined:
    Aug 23, 2011
    Member:
    #62173
    Messages:
    105
    Gender:
    Male
    First Name:
    jon
    Brevard
    Vehicle:
    Tacoma
    I ll do that...the fuel system gets Lucas and I did the fuel filter around 5k ago
     
  8. Aug 28, 2011 at 2:59 PM
    #8
    VirginiaBound

    VirginiaBound Whyareyoureadingthis?

    Joined:
    Jun 22, 2009
    Member:
    #18755
    Messages:
    7,213
    Gender:
    Male
    First Name:
    Sam I am, green eggs and ham
    North of Maine, South of Spain
    Mine does this, many that I've talked too experience the same thing.

    It's normal. ;)
     
  9. Aug 28, 2011 at 11:19 PM
    #9
    Street

    Street [OP] Well-Known Member

    Joined:
    Aug 23, 2011
    Member:
    #62173
    Messages:
    105
    Gender:
    Male
    First Name:
    jon
    Brevard
    Vehicle:
    Tacoma
    I'm telling you its not I don't know much about tacoma's but I'm 100% on the fact that my idle spike is not what came from the factory...I'll go buy a Tech on Monday and i'll report the rpm's after 10pm:cool:
     
  10. Aug 29, 2011 at 12:07 AM
    #10
    VirginiaBound

    VirginiaBound Whyareyoureadingthis?

    Joined:
    Jun 22, 2009
    Member:
    #18755
    Messages:
    7,213
    Gender:
    Male
    First Name:
    Sam I am, green eggs and ham
    North of Maine, South of Spain
To Top