1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Im hearing a clunking sound after install

Discussion in 'Suspension' started by t.hornstra, Jan 27, 2009.

  1. Jan 27, 2009 at 1:02 PM
    #1
    t.hornstra

    t.hornstra [OP] Keep on Keepin' on.

    Joined:
    Oct 14, 2008
    Member:
    #9957
    Messages:
    2,376
    Gender:
    Male
    First Name:
    Ted
    Sacramento
    Vehicle:
    2008 TRD Off-Road Rugged Trail
    In Progress... since '08
    so i installed my rough country 2.5/1.5 Lift recently and now whenever i go over speed bumps the front clunks when the springs kick back up. i think its the arm hitting the spring. the lift looked like it brought the spindle closer to the spring/strut assembly. is there any way to fix this? im getting an alignment later today..

    im going to be mad if this is what normally comes with a non- drop bracket lift. :(

    anyone out there know what to do? i really dont want any problems down the road

    thanks
     
  2. Jan 27, 2009 at 1:45 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,154
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    It could be hitting the Upper Control Arm, or the sway bar. Look to see if you see some wear in and around those areas. If its hitting the UCA's, you need to get aftermarket ones that will give the clearance. If hitting the Sway bar, get a sway bar spacer.
     
  3. Jan 27, 2009 at 1:51 PM
    #3
    Delmarva

    Delmarva Mayor of TW

    Joined:
    Oct 22, 2008
    Member:
    #10148
    Messages:
    35,853
    Gender:
    Male
    First Name:
    Mike
    Tucson, AZ
    Vehicle:
    12 Tundra TRDRW
    Nada, Zip, Zilch, Nothing
    ^^
    What he said... :thumbsup:
     
  4. Jan 27, 2009 at 2:18 PM
    #4
    ETaco23

    ETaco23 Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    I had the same thing, I never did find out what it was. I even took it to a shop and they didnt figure it out... I looked and looked, never found the problem! the noise slowely went away, and I dont hear it anymore. But I will look again soon and see If I see anything. But most likely Chris is right. :)
     
  5. Jan 27, 2009 at 3:12 PM
    #5
    t.hornstra

    t.hornstra [OP] Keep on Keepin' on.

    Joined:
    Oct 14, 2008
    Member:
    #9957
    Messages:
    2,376
    Gender:
    Male
    First Name:
    Ted
    Sacramento
    Vehicle:
    2008 TRD Off-Road Rugged Trail
    In Progress... since '08
    thanks for the help. i just got back from an alignment and they have no idea what it is. lol same as ^^^
    ill give it time and see what happens.
     
  6. Jan 27, 2009 at 3:27 PM
    #6
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    check your steering stops..................they have a tendency to hit a good bit. you can put a small amout of grease on the ends and it'll help.
     
  7. Jan 28, 2009 at 6:14 PM
    #7
    t.hornstra

    t.hornstra [OP] Keep on Keepin' on.

    Joined:
    Oct 14, 2008
    Member:
    #9957
    Messages:
    2,376
    Gender:
    Male
    First Name:
    Ted
    Sacramento
    Vehicle:
    2008 TRD Off-Road Rugged Trail
    In Progress... since '08
    steering ends?
     
  8. Jan 28, 2009 at 7:26 PM
    #8
    Trackmaster

    Trackmaster Active Member

    Joined:
    Dec 27, 2007
    Member:
    #3997
    Messages:
    30
    Vehicle:
    TRD 4X4
    Lose brake caliper ?? Lost on of those clips maybe. I had that experience once.
     
To Top