1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Installed 5100 @ 2.5" with 2" AAL with Pics!

Discussion in 'Suspension' started by 1stacoma, Aug 16, 2012.

  1. Aug 16, 2012 at 7:43 PM
    #1
    1stacoma

    1stacoma [OP] Well-Known Member

    Joined:
    Jun 14, 2012
    Member:
    #80656
    Messages:
    513
    Gender:
    Male
    Austin
    Vehicle:
    2012 MGM SR5 DCSB 4.0
    5100's front and rear, front 2.5" rear 2" AAL, 18% tint front and rear, color matched grill. SCS wheels 275/70/17 BFG AT KO's. DTRL toggle switch.
    I ordered 5100's front and rear from Wheelers last week with the 2" AAL. Started working on it in my garage last night and finished this afternoon. It was not a fun job in this hot Texas heat but the end result was worth it. I set the 5100 on the top giving 2.5" of lift.

    Something to note is that I have the drive line shutter under medium to hard acceleration from a stop and it is now gone> :D

    I measured this evening and it already was dark so I will double check my numbers tomorrow.

    Before
    LF 20.5 RF 20.5

    LR 21 3/4 RR 21 9/16

    After
    LF 22 7/8 RF 23

    LR 23 5/8 23 5/8

    I was worried that the lift was going to make the truck drive poorly but actually it drives really well. It also doesn't look as bad as I thought it would with stock wheels and tires. I still need to get an alignment, overall I am var happy with how it turned out.


    Befoe
    [​IMG]

    After the picture does it no justice
    [​IMG]
     
  2. Aug 16, 2012 at 9:04 PM
    #2
    Rickshaw

    Rickshaw Active Member

    Joined:
    Jul 27, 2012
    Member:
    #83563
    Messages:
    35
    Gender:
    Male
    Maryland
    Brush Gaurd, side rails, front bilstein's at 1.75, wheelers 1.5 aal, udercover toneau cap
    Damn it! I tried to look at your pics but couldn't see them. I get this alot on here. It just shows a "Red" X where the picture should be. Any suggestions?
     
  3. Aug 16, 2012 at 9:08 PM
    #3
    1stacoma

    1stacoma [OP] Well-Known Member

    Joined:
    Jun 14, 2012
    Member:
    #80656
    Messages:
    513
    Gender:
    Male
    Austin
    Vehicle:
    2012 MGM SR5 DCSB 4.0
    5100's front and rear, front 2.5" rear 2" AAL, 18% tint front and rear, color matched grill. SCS wheels 275/70/17 BFG AT KO's. DTRL toggle switch.
    PM me your email and I will email them to you.
     
To Top