1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Installed my Trd intake but...

Discussion in '2nd Gen. Tacomas (2005-2015)' started by rberumen2, May 3, 2011.

  1. May 3, 2011 at 1:09 PM
    #1
    rberumen2

    rberumen2 [OP] Well-Known Member

    Joined:
    Oct 28, 2009
    Member:
    #25084
    Messages:
    283
    Gender:
    Male
    First Name:
    Ralphie
    California
    Vehicle:
    2006 PreRunner
    Eibach coils, billies all around, Camburg Spindles, Debadged, flow master, 5% tint all around, Alpine sound system, Kenwood DVD player, mesh grille, blue dome light bulbs, Red Paint calipers, debadged tailgate, blackened lower bumper, black headlight mod, tinted taillights, painted engine cover, BFG 285 75 R16, Moto Metal 951, TRD CAI, Helix Throttle body spacer, 8000K HID headlights, 3000K HID foglights, Ultra-gauge, prestige pager alarm, anytime fog light and daytime lights, LED gauge MOD, Escort 9500i radar detector, 09 taillights, tacoma bedmat, Stubby antenna, Pop N Lock, Back-up camera, URD Short Shifter
    I just had a question to see If it was installed correctly. Compared to my stock, it's a little more looser and not as stiff. Is it suppose to be like that? Just hoping I didn't lose a bolt or something in the process
     
  2. May 3, 2011 at 1:10 PM
    #2
    crf69

    crf69 scraping my emblems off my plasti-dip

    Joined:
    May 18, 2010
    Member:
    #37348
    Messages:
    3,575
    Gender:
    Male
    First Name:
    Ryan
    Ohio
    Vehicle:
    06 TRD OR BSP cab'n 1/2
    ummm yeah
    double check your work........
     
To Top