1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

installing jl cleansweep just to add amp and subwoofer??? How TO?

Discussion in 'Audio & Video' started by xtirtzt, Apr 15, 2011.

  1. Apr 15, 2011 at 4:40 PM
    #1
    xtirtzt

    xtirtzt [OP] Addict.

    Joined:
    Dec 6, 2008
    Member:
    #11344
    Messages:
    138
    Gender:
    Male
    Connecticut
    Vehicle:
    08 trd sport 4x4
    afe pro-dry S, flowmaster 40 series, ipod interface, black headlights, yellow fogs
    how do i install the jl cleansweep just so i can add a subwoofer and amp... i dont want to clean the signal going to the stock speakers cause i heard it will make them sound worse... i read something about t-connecting it or something on the jl website... just wondered how to go about/ what have you guys done?
     
  2. Apr 15, 2011 at 5:09 PM
    #2
    Nightfury

    Nightfury Well-Known Member

    Joined:
    May 9, 2010
    Member:
    #36792
    Messages:
    80
    Gender:
    Male
    First Name:
    Evan
    Bismarck, North Dakota
    Vehicle:
    2012
    Factory running boards, Toyota (DeeZee built) toolbox, Code Alarm 5152 remote starter, Bronze TRD rims, more to come....
    For the love of all that is good, please do not use T-taps. They are the sweat stain on the armpit of the car electrical world t-shirt.


    And what Whippersnapper02 said. Shouldn't bother your factory speakers if you don't wire them in series.
     
To Top