1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

is this timing chain cover leaking!? or just grudge...

Discussion in '2nd Gen. Tacomas (2005-2015)' started by kinkrider101, Jan 8, 2012.

  1. Jan 8, 2012 at 5:45 PM
    #1
    kinkrider101

    kinkrider101 [OP] Well-Known Member

    Joined:
    Sep 29, 2009
    Member:
    #23497
    Messages:
    2,693
    Gender:
    Male
    santa barbara
    Vehicle:
    2007 cummins/2007 tacoma
    wheels and tires
    The truck has about 55.5k miles on it, is this a leak? Or just buildup?

    [​IMG]

    [​IMG]
     
  2. Jan 9, 2012 at 3:36 PM
    #2
    kinkrider101

    kinkrider101 [OP] Well-Known Member

    Joined:
    Sep 29, 2009
    Member:
    #23497
    Messages:
    2,693
    Gender:
    Male
    santa barbara
    Vehicle:
    2007 cummins/2007 tacoma
    wheels and tires
  3. Feb 28, 2012 at 6:08 PM
    #3
    adanfon

    adanfon YNWA

    Joined:
    Dec 3, 2011
    Member:
    #68101
    Messages:
    1,142
    Gender:
    Male
    First Name:
    Adán
    Visalia, CA
    Vehicle:
    '11 Tacoma DCLB 4x4
    grillcraft, debadged, bilstein 5100's @ 0 w/ OME 886 coils and a 1/4" top plate spacer, rear has tsb springs and Wheelers HD progressive add a leaf. 1.25" spidertrax wheel spacers. Powder coated stock wheels. Tinted tails. Sport headlights. 20" led bar behind grille...
    looks like its leaking
     
  4. Feb 28, 2012 at 6:20 PM
    #4
    seric007

    seric007 Well-Known Member

    Joined:
    Feb 15, 2012
    Member:
    #72895
    Messages:
    444
    Gender:
    Male
    i purchased a 2010 recently that had a similar buildup in the same place. it was a "dry" film, not oily as typical valve-covers oil leakage. I Wiped it off, 2+ weeks later its not returned i can only assume road grime.
     
  5. Feb 28, 2012 at 6:23 PM
    #5
    TrdSurgie

    TrdSurgie revised

    Joined:
    Feb 19, 2012
    Member:
    #73132
    Messages:
    3,529
    Gender:
    Male
    SoCal
    Clean it and recheck a couple weeks later
     
To Top