1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Is your suspension still squeaky even after getting the TSB done??

Discussion in '2nd Gen. Tacomas (2005-2015)' started by keithlandrum, May 14, 2010.

  1. May 14, 2010 at 8:09 AM
    #1
    keithlandrum

    keithlandrum [OP] Well-Known Member

    Joined:
    Oct 12, 2009
    Member:
    #24178
    Messages:
    100
    Gender:
    Male
    First Name:
    Keith
    Saraland Alabama
    Vehicle:
    2010 chevrolet Z71 4x4
    tint, hid headlights,
    Is anybody still having problems with the suspension squeaking even after getting the TSB done? I haul my boat alot with my truck and my truck sounds like a 1989 S-10 lol and im tired of the squeaking i plan on getting the TSB done im just wondering if that will fix the squeaking??
    thanks for the help!
     
  2. May 14, 2010 at 8:25 AM
    #2
    Chris(NJ)

    Chris(NJ) Well-Known Member

    Joined:
    Jan 21, 2010
    Member:
    #29777
    Messages:
    2,884
    Gender:
    Male
    First Name:
    Chris
    Usually in Central Jersey
    Vehicle:
    08 Indigo 4x4 DC OR
    Debadged, GC Mesh Grill, Yellow Fogs, Color Matched Headlights w/ Retros, Diff Breather Mod; mickey thompson classic IIs, 5100s, toytec springs, Dakar Leaf pack, ss brake lines, Lots more...just check the build page.
  3. May 14, 2010 at 8:31 AM
    #3
    BlueXenon

    BlueXenon Well-Known Member

    Joined:
    Oct 29, 2008
    Member:
    #10366
    Messages:
    389
    Gender:
    Male
    Los Angeles and Newport Coast
    Vehicle:
    Magnetic gray TRD sport (SOLD)
    Pro Comp 6" Stage 2 lift, N-Fab nerf bars, tinted windows, debadged, 6000k xenon headlights, 18" ProComp 7089 Wheels in black with BFG AT KO 33's, SnugLid tonneau cover, Line X'ed TRD skid plate. SOLD! Waiting for the 3rd Gen!
    Did have a slight squeak when it was done, after I installed the AAL the squeak was no longer present.
     
  4. May 14, 2010 at 10:07 AM
    #4
    keithlandrum

    keithlandrum [OP] Well-Known Member

    Joined:
    Oct 12, 2009
    Member:
    #24178
    Messages:
    100
    Gender:
    Male
    First Name:
    Keith
    Saraland Alabama
    Vehicle:
    2010 chevrolet Z71 4x4
    tint, hid headlights,
  5. May 14, 2010 at 10:12 AM
    #5
    lembowski

    lembowski Rompin Around

    Joined:
    Jul 29, 2009
    Member:
    #20347
    Messages:
    7,058
    Gender:
    Male
    First Name:
    Matt
    Rolando, CA
    Vehicle:
    09 LT, Caged, 4WD
    Squeaks whenever I get in or out....before and after the TSB.
     
  6. May 14, 2010 at 10:25 AM
    #6
    wilsonpj

    wilsonpj Well-Known Member

    Joined:
    Apr 13, 2009
    Member:
    #15922
    Messages:
    491
    Gender:
    Male
    First Name:
    Pete
    Boulder, CO
    Vehicle:
    2006 DC, SB, Off Road Package
    TRD Cat back exhaust. TRD CAI. All-Pro armor, Brush Guard, LR UCA's, OME 3in lift, 16x8 KMC Enduros and 285x75x16 Goodyear Dura Tracs
    Squeaks all the time!
     
  7. May 14, 2010 at 11:30 AM
    #7
    keithlandrum

    keithlandrum [OP] Well-Known Member

    Joined:
    Oct 12, 2009
    Member:
    #24178
    Messages:
    100
    Gender:
    Male
    First Name:
    Keith
    Saraland Alabama
    Vehicle:
    2010 chevrolet Z71 4x4
    tint, hid headlights,
    anybody know of a way to stop it from squeaking
     
  8. May 14, 2010 at 11:35 AM
    #8
    GA_TACO4x4

    GA_TACO4x4 Well-Known Member

    Joined:
    Dec 3, 2008
    Member:
    #11259
    Messages:
    1,138
    Gender:
    Male
    here 'n there
    Vehicle:
    07 DCSB 4x4
    marathon superhide max-4 seat covers, weathertechs, maglite mod, 20% tint, 2" leveling kit, leaf spring tsb.
    my squeaks like hell before and after. ive tried everything from white lithium grease to wd40...buddy of mine suggest pb blaster but i aint tried it yet.
     
  9. May 14, 2010 at 11:41 AM
    #9
    keithlandrum

    keithlandrum [OP] Well-Known Member

    Joined:
    Oct 12, 2009
    Member:
    #24178
    Messages:
    100
    Gender:
    Male
    First Name:
    Keith
    Saraland Alabama
    Vehicle:
    2010 chevrolet Z71 4x4
    tint, hid headlights,
    yeah i tried some wd40 it seemed to help a little
     
  10. May 14, 2010 at 11:42 AM
    #10
    keithlandrum

    keithlandrum [OP] Well-Known Member

    Joined:
    Oct 12, 2009
    Member:
    #24178
    Messages:
    100
    Gender:
    Male
    First Name:
    Keith
    Saraland Alabama
    Vehicle:
    2010 chevrolet Z71 4x4
    tint, hid headlights,
    its crazy i have a new truck and it sounds like its 20 years old LOL
     
  11. May 14, 2010 at 11:55 AM
    #11
    wilsonpj

    wilsonpj Well-Known Member

    Joined:
    Apr 13, 2009
    Member:
    #15922
    Messages:
    491
    Gender:
    Male
    First Name:
    Pete
    Boulder, CO
    Vehicle:
    2006 DC, SB, Off Road Package
    TRD Cat back exhaust. TRD CAI. All-Pro armor, Brush Guard, LR UCA's, OME 3in lift, 16x8 KMC Enduros and 285x75x16 Goodyear Dura Tracs
    Everything I've read says to take them off, lube em up, but most people i've talked to says that the squeek comes back.
     
  12. May 14, 2010 at 11:56 AM
    #12
    ShiftGear

    ShiftGear Well-Known Member

    Joined:
    Feb 7, 2010
    Member:
    #30905
    Messages:
    67
    Gender:
    Male
    BC
    Vehicle:
    TRD Sport
    Severe squeeking for me too!!!
     
  13. May 14, 2010 at 12:05 PM
    #13
    GA_TACO4x4

    GA_TACO4x4 Well-Known Member

    Joined:
    Dec 3, 2008
    Member:
    #11259
    Messages:
    1,138
    Gender:
    Male
    here 'n there
    Vehicle:
    07 DCSB 4x4
    marathon superhide max-4 seat covers, weathertechs, maglite mod, 20% tint, 2" leveling kit, leaf spring tsb.
    when i get plenty of time off, id like to take them out, disassemble everything, re-paint, re-lube everything and most of all put some kinda anti-friction pads on the leafs. like on the toytec aal's.
     
  14. May 14, 2010 at 12:09 PM
    #14
    tiresmokintacoma

    tiresmokintacoma Bean&Cheese Taco

    Joined:
    Jul 7, 2009
    Member:
    #19408
    Messages:
    435
    Gender:
    Male
    First Name:
    VIC
    Texas
    Vehicle:
    1794 4WD FUNDRA/01TACO DCOR/05TACO DCOR/97 LX450/91 4R 4WD
    Ballin on a Budget
    Mine Squeeks and its annoying!!! :(
     
  15. May 14, 2010 at 12:10 PM
    #15
    keithlandrum

    keithlandrum [OP] Well-Known Member

    Joined:
    Oct 12, 2009
    Member:
    #24178
    Messages:
    100
    Gender:
    Male
    First Name:
    Keith
    Saraland Alabama
    Vehicle:
    2010 chevrolet Z71 4x4
    tint, hid headlights,
    yeah im sure some kind anti friction pads would fix it
     
  16. May 14, 2010 at 12:13 PM
    #16
    Kyouto42

    Kyouto42 Iron Beard

    Joined:
    Aug 18, 2008
    Member:
    #8614
    Messages:
    9,243
    Gender:
    Male
    First Name:
    Jake
    Ahwatukee, AZ
    Vehicle:
    BSP '10 4x4 TRD Off-Road DC
    See build thread in signature
    Did you try spraying inside the leaf springs? Typically that's what it is.... mine did it once... washed the truck and hit the leafs... gone. Same with my dad's 05 4x4.
     
  17. May 14, 2010 at 12:14 PM
    #17
    jrobson

    jrobson Well-Known Member

    Joined:
    Jan 4, 2009
    Member:
    #12211
    Messages:
    1,094
    Gender:
    Male
    Mobile, Alabama
    Vehicle:
    09 DC 4x4
    Ultimate lift kit, LR UCA's, Bi-xenon 8000K headlights, Xenon 8000K foglites, (4) KC slimlites on N-Fab light bar, Extang trifecta toneau cover
    X2
     
  18. May 14, 2010 at 6:57 PM
    #18
    MarineTacoDriver

    MarineTacoDriver Well-Known Member

    Joined:
    Jan 22, 2010
    Member:
    #29836
    Messages:
    343
    Gender:
    Male
    First Name:
    Brian
    Cherry Point
    Vehicle:
    09 SR5 4x4
    ARB front bumper, Warn M8000, ATO front/transmission/transfer case skids, Icon ext travel coilovers, Total Chaos UCA's, OME Dakar leaf springs, Bilstein/RCD 5100 3-4" lift shock, extended stainless brake lines, DrewFab shackle flip, rear ARB Airlocker, ARB air compressor
    Agreed, it's kind of embarrassing :rolleyes:
     
  19. May 25, 2010 at 11:16 PM
    #19
    BucShot7

    BucShot7 New Member

    Joined:
    May 25, 2010
    Member:
    #37840
    Messages:
    2
    Gender:
    Male
    First Name:
    Jason
    Seattle
    Vehicle:
    09 TRD Sport 4x4
    I have a 2009 DBL Caband it squeaks a lot. I spray down my leaf springs 2x a week with either PB Blaster, WD-40, or lithium grease. I haven't noticed a big difference but the PB Blaster seems to last longer. After a rainy day its like all the lube gets washed off because the truck starts squeaking right away. Is there anything I can do to fix this???
     
  20. May 25, 2010 at 11:19 PM
    #20
    dgalleon

    dgalleon Well-Known Member

    Joined:
    Dec 6, 2009
    Member:
    #27081
    Messages:
    334
    Gender:
    Male
    Central Florida
    Vehicle:
    09 TRD Sport 4x4 Dbl Cab LB
    TRD CAI, Flowmaster 40 series, 6" Fabtech Lift, Dirt Logic rear shocks
    yea... i got the silencer pad Tsb for the leafs and still squeaks... been using Chain lube from my motorcycle and seems to fix it temporarily.... but its still there and gets louder if i dont lube it every week or so
     
To Top