1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

issues and headaches with toughone brand from advance auto

Discussion in 'General Automotive' started by anotherreject, Jun 10, 2013.

  1. anotherreject

    anotherreject [OP] Well-Known Member

    Joined:
    Nov 1, 2011
    Member:
    #66236
    Messages:
    1,228
    Gender:
    Male
    I needed a new cv axel for my car, bought a toughone brand from advance auto. They are supposed to be brand new. It fit fine and installed with no problems. I drove on it for 2 days and then it started vibrating bad. Took out the first one and installed another. Drove it for a few days and it started vibrating again. Just to make sure it was the axel i put the original back in (has a torn cv boot) and it drives fine with no vibrating.
    The employees at advance auto have been cool, they give the refunds with no problems. Just a pain in the ass that i have now done the same job 3 times and still need to put a new one in from napa.
     
  2. WHPLSH3

    WHPLSH3 Fortified with horsepower-adding goodness...

    Joined:
    Mar 8, 2013
    Member:
    #99302
    Messages:
    688
    Gender:
    Male
    First Name:
    Vance
    Alberta
    Vehicle:
    Supercharged Spruce Mica 6spd 4x4
    Build thread coming soon!
    That's a common issue with bottom-rung offshore parts. OEM may be expensive, but you get what you pay for in most cases. In China or Taiwan or wherever they're sourcing that stuff, all those manufacturers care about is if the part looks correct, they don't give a hoot if it will perform properly
     
  3. anotherreject

    anotherreject [OP] Well-Known Member

    Joined:
    Nov 1, 2011
    Member:
    #66236
    Messages:
    1,228
    Gender:
    Male
    Yea i only got it because it was faster and easier to swap the whole thing rather then use one of the glue on "qwik boot" for the torn cv boot.
     
  4. 2TRunner

    2TRunner Don't give up here just yet

    Joined:
    Jul 30, 2010
    Member:
    #40980
    Messages:
    3,076
    Gender:
    Male
    First Name:
    Chris
    Around To Many People
    Vehicle:
    1, 2, 3, 4, 5 Lugs
    Brute Force Bumpers: rear & custom front tube, Saw-A-Way Racerunner 2.5 Coilovers with Total Chaos UCAs. Icon AAL.
    Praying I have a "cheap axle" issue as well. Find out tomorrow.
     
To Top