1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Isuzu Rodeo

Discussion in 'General Automotive' started by Trusso24, May 28, 2013.

  1. May 28, 2013 at 9:38 AM
    #1
    Trusso24

    Trusso24 [OP] Well-Known Member

    Joined:
    Feb 2, 2013
    Member:
    #96649
    Messages:
    672
    Gender:
    Male
    First Name:
    Tony
    San Luis Obispo
    Vehicle:
    99 Prerunner XCab
    Fox Coilovers Blacked Out Debadged
    Note that I wasn't there but once I'm done with my errands, I offered to help with her car. Just wanted to hear what it COULD be so the mechanic doesn't give us the run around. I know none of you can diagnose over a keyboard, but I'm stuck in Social Security office and this is where I'm at.

    This chick is having problems with her 1999 Rodeo. It was driving fine until the other day when it wouldn't turn over. It sounded like the fuel filter/pump was dirty/bad because it would start but it wouldn't give it gas to keep it running. They filled it up with gas, but now it sounds like the battery because it won't even click now. Like I said, what are the possible causes of her inability to start?
     
  2. May 28, 2013 at 2:32 PM
    #2
    aficianado

    aficianado Well-Known Member

    Joined:
    Oct 27, 2009
    Member:
    #25015
    Messages:
    5,105
    Gender:
    Male
    bay area, california
    Vehicle:
    2006 access cab. 4x4, TRD-OR
    OME lift. 884 coils, 1.5" AAL's installed on nonTSB leafs. front diff drop kit.
    wouldnt turn over, but it starts?

    i dont get it. "wouldnt turn over" or "it wouldnt fire up"

    you killed the battery turning it over is my guess. charge battery up and take a new crack at it.

    was it out of fuel? was it even close to empty? not enough info to even guess.
     
  3. May 28, 2013 at 5:47 PM
    #3
    Trusso24

    Trusso24 [OP] Well-Known Member

    Joined:
    Feb 2, 2013
    Member:
    #96649
    Messages:
    672
    Gender:
    Male
    First Name:
    Tony
    San Luis Obispo
    Vehicle:
    99 Prerunner XCab
    Fox Coilovers Blacked Out Debadged
    Got it figured out. Thanks
     
  4. May 28, 2013 at 8:00 PM
    #4
    aficianado

    aficianado Well-Known Member

    Joined:
    Oct 27, 2009
    Member:
    #25015
    Messages:
    5,105
    Gender:
    Male
    bay area, california
    Vehicle:
    2006 access cab. 4x4, TRD-OR
    OME lift. 884 coils, 1.5" AAL's installed on nonTSB leafs. front diff drop kit.
    come on..dont tickle my ass with a feather..tell me! what was it?
     
To Top