1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

JBL Sub ?

Discussion in 'Audio & Video' started by FATaco, Dec 6, 2010.

  1. Dec 6, 2010 at 6:04 AM
    #1
    FATaco

    FATaco [OP] Meh

    Joined:
    Dec 6, 2010
    Member:
    #47239
    Messages:
    295
    Gender:
    Male
    First Name:
    Friends call me Ginger
    Fairbanks
    Vehicle:
    07' TRD DCSB
    Dakars w/AAL, OME/886's, All Pro Front Bumper, Rear bumper, IFS skid, and UCA's. Superwinch Tigershark. Magnaflow muffler... vrooom
    Hey guys,
    I've done some searches but haven't found an answer to my question. I've just purchased an 07' Double cab with the JBL sound system. The rear speakers and sub sound muffled and aren't putting out much sound. Just curious where to start searching before I tear everything apart? Does the factory amp have any adjustments that can be made? Thanks ahead of time!
     
  2. Dec 6, 2010 at 6:18 AM
    #2
    Hunter500ky

    Hunter500ky Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
To Top