1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Jeep Cherokee

Discussion in 'Technical Chat' started by SMG26, Aug 5, 2009.

  1. Aug 5, 2009 at 9:35 AM
    #1
    SMG26

    SMG26 [OP] Well-Known Member

    Joined:
    Aug 26, 2008
    Member:
    #8786
    Messages:
    186
    Gender:
    Male
    First Name:
    Steve
    Woodstock,GA
    Vehicle:
    06 Prerunner TRD Offroad
    Injen CAI, JBA exhaust pipes 2.5" w/magnaflow muffler, Doug Thorley Long tube headers, URD MAF CAL and O2 sim,Access roll up cover, AVS Wind deflectors, coverking seatcovers, grillcraft upper/lower grille, Halo projectors w/6000k HID and pop lock on tailgate.
    I know this is off topic but need a little help. My wife has a 99' Jeep grand cherokee v6. On her way too work today the jeep would stall out every time she would pull up to a red light. Right after it would stall she would start it up again but this would happen every time she would stop and sit. Was wondering what might cause this. There is no check engine light showing either.
     
  2. Aug 5, 2009 at 9:38 AM
    #2
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    5,745
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road
    None
  3. Aug 5, 2009 at 9:39 AM
    #3
    imsikotic

    imsikotic If u cant stand behind our troops. Stand in front

    Joined:
    Apr 22, 2009
    Member:
    #16278
    Messages:
    5,112
    Gender:
    Male
    First Name:
    Randy
    Temecula, Ca
    Vehicle:
    06 TRD Sport DesertRunner
    4" Camburg Race Spindles and Icon 2.5" ext travel Coilovers in the front for about 5"of lift and for the rear All-Pro 3" leaf pack and Fox 2.0 Resi's converted to piggyback and custom valved by DownSouth Motorsports. 17x9" KMC XD Addicts w/ 4.5 inch Backspacing and -12 Offset. Wrangler Duratracs 285/70/17. K&N CAI, Exhaust, Carriage Works Billet Grill, Custom Bed bar with ProComp fog lights,DirtKing Fabrication front bumper w/ 3 HID converted Hellas, Demello rear PreRunner bumper, Tinted windows, Full System w/ 2 10s, Garmin 265WT, ClearHLM. Theres more I just cant think of it right now.
    Check to make sure the intake manifold does not have a hole in it. I had that problem with my minitruck back in the day.
     
  4. Aug 5, 2009 at 9:40 AM
    #4
    Richman21

    Richman21 I think therefore I'm a Democrat

    Joined:
    Jan 15, 2009
    Member:
    #12603
    Messages:
    442
    Gender:
    Male
    First Name:
    Jeff
    Albuquerque, NM
    Vehicle:
    09 DC Sport PreRunner
    Hardwire radar detector. Tube steps.
    Sounds like an old Porsche that I had. My issue in the Porsche was the fuel pump and fuel filter. Might be that.
     
  5. Aug 5, 2009 at 9:40 AM
    #5
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    5,745
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road
    None
  6. Aug 5, 2009 at 11:15 AM
    #6
    SMG26

    SMG26 [OP] Well-Known Member

    Joined:
    Aug 26, 2008
    Member:
    #8786
    Messages:
    186
    Gender:
    Male
    First Name:
    Steve
    Woodstock,GA
    Vehicle:
    06 Prerunner TRD Offroad
    Injen CAI, JBA exhaust pipes 2.5" w/magnaflow muffler, Doug Thorley Long tube headers, URD MAF CAL and O2 sim,Access roll up cover, AVS Wind deflectors, coverking seatcovers, grillcraft upper/lower grille, Halo projectors w/6000k HID and pop lock on tailgate.
    Thanks I will look into all of those.
     
  7. Aug 5, 2009 at 11:24 AM
    #7
    A_Ninja_Racer

    A_Ninja_Racer Well-Known Member

    Joined:
    Oct 7, 2008
    Member:
    #9789
    Messages:
    760
    Tampa, FL
    Vehicle:
    08 PreRunner TRD Debadged
    Start the motor and pump your breaks if you here tho motor sputer like its going to stall then you have a vacume leak in your break booster.
     
  8. Aug 5, 2009 at 11:26 AM
    #8
    DriverSound

    DriverSound Señor Member

    Joined:
    Mar 29, 2009
    Member:
    #15329
    Messages:
    2,586
    Gender:
    Male
    SoCal
    Vehicle:
    15 TRD-OR DCSB
    Just enough! Other vehicles: 2015 Mustang GTPP 2014 Prius 2010 4runner SR5 4x4 2009 TRD-OR AC
    Also check your spark plug wires for damage after you check for intake/vacuum leak.
     
  9. Aug 5, 2009 at 11:39 AM
    #9
    nad

    nad mmmm tacos!

    Joined:
    May 18, 2009
    Member:
    #17388
    Messages:
    3,079
    Gender:
    Male
    First Name:
    Jordan
    Canada
    Vehicle:
    2014 Sierra All Terrain
    im willing to bet its a sensor
     
  10. Aug 5, 2009 at 11:42 AM
    #10
    NAAC3TACO

    NAAC3TACO Well-Known Member

    Joined:
    Aug 5, 2008
    Member:
    #8350
    Messages:
    2,567
    Gender:
    Male
    Vehicle:
    2014 SR5 DCLB 4x4
    Color matched door handles, Weathertech mats, rubber bed mat.
    Sounds like a fuel pressure problem to me. Could be a regulator, pump, clogged filter or any number of items. I think you are probably going to need a professional mechanic look at this one. Sorry, I'm not much help.
     
  11. Aug 5, 2009 at 11:47 AM
    #11
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,108
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    X2.
     
  12. Aug 7, 2009 at 10:10 AM
    #12
    Rocketball

    Rocketball If The World Didn't Suck, We'd All Fall Off

    Joined:
    Mar 18, 2009
    Member:
    #14869
    Messages:
    1,519
    Gender:
    Male
    First Name:
    Scott
    Westminster, MD
    Vehicle:
    08 Speedway Blue DC Sport 4x4
    Pioneer head unit, PAC steering wheel control modual, Hard wired Sirius radio, Hard wired radar detector, Hella Supertone horns, Blacked out badges, Smoked Tails, BHLM (color matched Speedway Blue), T-Rex Eyelids, Black Powder Coated Billet Grill, Color Matched Engine Cover, Lund in channel vent visors, FJ Cruiser wheels, Leer 100XQ shell, OEM bed mat, Piezo beeper for locking doors, Tinted front side windows, Black Westin bull bar, Aires tube steps, Mini Maglite Mod, D-Cell Maglite Mod, Weathertech Digifit Floor Mats
    Check your battery.

    If the charge is low that will happen.

    I have a 97 Grand Cherokee and when the battery is getting close to needing replacement, the same thing happens to me. The jeep runs fine at high rpm's, but stalls at idle.
     
To Top