1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Just installed my true flow CAI

Discussion in '2nd Gen. Tacomas' started by RDAY, Jul 29, 2009.

  1. Jul 29, 2009 at 5:06 PM
    #1
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    Can someone help me with this intake I remove the whole stock airbox air filter and air tubing right?
    Because i just took it down the road and when i step on it it gets too loud like it doesnt sound good i can hear it vibrating and feel it vibrating in my foot what could this be?

    Also when the truck is running and I put my hand underneath the engine cover should i be able to feel air blowing right around there with my hand?
    And when i parked it smelled like something was burning I am nervous i want to be better safe than sorry.
     
  2. Jul 29, 2009 at 5:36 PM
    #2
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    its only when i step on it that it does it?
    and idk if u guys were able to get urs real sturdy but using the hardware that came with it I can still move the whole big end of the intake around quit a bit with ease does ur guys have that much movement?
     
  3. Jul 29, 2009 at 5:51 PM
    #3
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    anyone???
    I dont wanna drive my truck to work 2moro until i get this figured out.
     
  4. Jul 29, 2009 at 5:54 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Thor

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,839
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Installation is pretty straight forward. Can you post a pic of it, so we can see if anything is wrong?

    FWIW, Most intakes are loud, and you will feel the vibrations/resonance from them.
     
  5. Jul 29, 2009 at 5:55 PM
    #5
    Slypted

    Slypted Well-Known Member

    Joined:
    Jul 7, 2009
    Member:
    #19366
    Messages:
    228
    Gender:
    Male
    First Name:
    Frank
    NJ
    Vehicle:
    08 Tacoma SR5 4x4
    Smiitybuilt nerf bars, Hunter bull bar w/ KC hilights/ Toy-tec 3" spacer, AAL lift, LR UCAs, Helo he842 16x8 Wheels, BFG KM2 285x75x16
    Sounds like something isnt right. I would think it should be sealed up to direct the airflow properly. Are you sure you put it together right? I dont have CAI yet so sorry I cant be of much help.
     
  6. Jul 29, 2009 at 6:03 PM
    #6
    TexasIslandBoy

    TexasIslandBoy THE RED DRAGON!!

    Joined:
    Jun 10, 2009
    Member:
    #18262
    Messages:
    3,207
    Gender:
    Male
    First Name:
    Andrew
    South Texas. SPI
    Vehicle:
    07' trd offroad 4X4 (For Sale)
    pro comp 6inch lift 35'' tires moto 950's radfo coilovers magnaflow exhaust 5/16" front skidplate usa spec ipod interface tree pin strip mod dry drop in filter full size BFG KM2 spare
    yea these cai can be loud in the cab
     
  7. Jul 29, 2009 at 6:08 PM
    #7
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    so should i feel air moving around right at the intake manifold is this normal? and from the other pics it seems I do have it installed correctly. But when I step on it the whole inside of my cab starts vibrating the dash the mirror the gas pedal ect???

    It seems like there shouldnt be ne movement on the intake when its installed and I have everything tight and theres still quit a bit of play.
     
  8. Jul 29, 2009 at 6:09 PM
    #8
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    do u have a true flow chris?
     
  9. Jul 29, 2009 at 6:11 PM
    #9
    TRDKenE

    TRDKenE DAMN GOOD DEAL!!

    Joined:
    Jul 6, 2009
    Member:
    #19348
    Messages:
    706
    Gender:
    Male
    First Name:
    Kenny
    Richmond, Virginia
    Vehicle:
    '10 D-CAB OFF-ROAD 4X4
    TRD CAI, GrillCraft.
    i just pu one of these on...pretty easy and straight foward...i think the hardest part (which really wasnt hard..just a bit time consuming( was extending the MAF harness. Yes you take out all of the airbox...if it looks like ya have a suite case..then ya got it all. sure you didnt drop something on the manifold that might have burned a bit and created the smell? I mean dirt grease a little piece of plastic can make a big smell...even running through rain water....also make sure the intake is not laying on the p/s resivoir or the hole in the radiator support you had to cut...if so you will need to adjust it...but its going to be loud..nature of the beast bro...My TRD intake rattles the windows when im full throttle...you seriously could not talk to anybody b/c they would not hear you...like i said normal..\

    edit: also the air you may be feeling is probably the air created by the trucks fan..NORMAL..you just don't have as much blocking it now...your truck probably would barely run if it did not see air across the MAF..
     
  10. Jul 29, 2009 at 6:15 PM
    #10
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Thor

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,839
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    No, but I ran one on a dyno.
     
  11. Jul 29, 2009 at 6:16 PM
    #11
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    TRDKENE- is urs a second edition? I didnt even have to extend the MAF sensor?
    But the main thing I think I am having issues with is getting the hardware that came with it to actually hold the intake down tight so it won't move much the thing bounces all over does urs have alot of movement?
     
  12. Jul 29, 2009 at 6:19 PM
    #12
    TRDKenE

    TRDKenE DAMN GOOD DEAL!!

    Joined:
    Jul 6, 2009
    Member:
    #19348
    Messages:
    706
    Gender:
    Male
    First Name:
    Kenny
    Richmond, Virginia
    Vehicle:
    '10 D-CAB OFF-ROAD 4X4
    TRD CAI, GrillCraft.
  13. Jul 29, 2009 at 6:22 PM
    #13
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    nope def. not man.
    [​IMG]
     
  14. Jul 29, 2009 at 6:26 PM
    #14
    TRDKenE

    TRDKenE DAMN GOOD DEAL!!

    Joined:
    Jul 6, 2009
    Member:
    #19348
    Messages:
    706
    Gender:
    Male
    First Name:
    Kenny
    Richmond, Virginia
    Vehicle:
    '10 D-CAB OFF-ROAD 4X4
    TRD CAI, GrillCraft.
    yep...Im a retard..my fault bro...that looks pretty simple doesnt look like much to it...Maybe your just overreacting to something that your not used to? I thought you were talking about the URD True Cold Air.
     
  15. Jul 29, 2009 at 6:32 PM
    #15
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    i just don't like the hardware they give u its hard to get it tight so theres no movement/vibrations.
     
  16. Jul 29, 2009 at 6:32 PM
    #16
    DriverSound

    DriverSound Señor Member

    Joined:
    Mar 29, 2009
    Member:
    #15329
    Messages:
    2,256
    Gender:
    Male
    SoCal
    Vehicle:
    TRD Gen2 DCLB-S 4x4
    2011 TRD CAI 1.0, URD maf Calibrator, AFE Pro Dry-S, Spintech Muffler, Magnaflow resonator, 5100's, Toytech 1/4" spacer, Dakar 1.5" AAL, TSB Springs, SPC UCA's, OME 885X, Yellow Wire Mod, VSC/ABS switch mod, Fog Light Mod~~~ Also in the HH. 2006 FJ 4x4 2009 Tacoma AC-OR 2010 4Runner 4x4 SR5
    Looks like from the pic, that thing is only supported by a single bracket and rest of it is supported by the urethane boots? If so, keep in mind that your engine does vibrate a lot and that vibration is even more extended to the tube and air filter housing.
     
  17. Jul 29, 2009 at 9:35 PM
    #17
    TacoTurd

    TacoTurd Defying Alliances since 2007

    Joined:
    Jul 19, 2007
    Member:
    #2160
    Messages:
    317
    Central Texas
    Vehicle:
    07 PreRunner TRD Sport
    TRD Exhaust, TRD CAI, Bull Bar, PIAA lights, Passport, Bed Mat, UWS Toolbox, Hood Struts, Rear TSB, TRD/Okole Seat Covers, Hellwig Rear Sway Bar, Burned Carpet, Nasty Dent in Roof
    Sorry, but that is one butt ugly CAI. The MAS is mounted on the side?? :confused:
     
To Top