1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Just installed the OEM roof rack and have one concern.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Chronism, Nov 9, 2010.

  1. Nov 9, 2010 at 4:47 PM
    #1
    Chronism

    Chronism [OP] Well-Known Member

    Joined:
    Nov 5, 2010
    Member:
    #45755
    Messages:
    152
    Gender:
    Male
    First Name:
    Michael
    Richmond, Virginia
    Vehicle:
    2011 Tacoma TRD OR/DC
    In my haste to install the OEM roof rack and looking back now, the one thing I didn't do that I normally would have with this type of install, is I did not wipe down the roof or underside of the rack before fastening it down.

    There was probably very little dirt on the body, maybe just a light film as I washed the truck a couple of days ago, but my concern is whether that light film of dirt will cause any harm over time?

    Taking the rack back off would mean having to get some new hardware, especially the yellow clips that are one time use and new double sided tape. Is it worth removing it to clean the area or should it be ok? I would think it would be no different than the dirt that collects between the cab and bed...
     
  2. Nov 9, 2010 at 4:55 PM
    #2
    Sideways

    Sideways Well-Known Member

    Joined:
    Sep 7, 2008
    Member:
    #9057
    Messages:
    566
    Maryland
    Vehicle:
    05 TRD dbl cab
    If it's a light film you should be fine.
    If you don't mind my asking where did you get the rack?
    I am looking for one for my 05 dbl cab
     
  3. Nov 9, 2010 at 4:57 PM
    #3
    Chronism

    Chronism [OP] Well-Known Member

    Joined:
    Nov 5, 2010
    Member:
    #45755
    Messages:
    152
    Gender:
    Male
    First Name:
    Michael
    Richmond, Virginia
    Vehicle:
    2011 Tacoma TRD OR/DC
    I purchased mine through my dealership. They gave me a decent discount since I bought the truck there and have been going there for my past 3 Toyota's. It was something like $265, about what I've seen them for online and didn't have to pay any shipping and had it the next day.

    Guess I am overly concern and upset with myself at the same time. I'm usually pretty particular when doing installs and for whatever reason, it just got past me until it was too late.
     
  4. Nov 9, 2010 at 4:57 PM
    #4
    thainess

    thainess Well-Known Member

    Joined:
    Dec 27, 2009
    Member:
    #28266
    Messages:
    84
    Gender:
    Male
    Sugar Land, tx
    Vehicle:
    10 prerunner trd offroad
    Plasti-dip emblems
    yea im also looking for one but not trying to spend a fortune at the dealership
     
  5. Nov 9, 2010 at 5:35 PM
    #5
    Chronism

    Chronism [OP] Well-Known Member

    Joined:
    Nov 5, 2010
    Member:
    #45755
    Messages:
    152
    Gender:
    Male
    First Name:
    Michael
    Richmond, Virginia
    Vehicle:
    2011 Tacoma TRD OR/DC
    So the general consensus is that I should be ok, or is there any reason whatsoever I should take it back off?
     
  6. Nov 9, 2010 at 5:47 PM
    #6
    brutalguyracing

    brutalguyracing BIG DADDY

    Joined:
    Jun 28, 2009
    Member:
    #19000
    Messages:
    24,038
    Gender:
    Male
    F.U> GUYZ
    broken mods
    no your fine
     
To Top