1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

just picked up my new lift.

Discussion in 'Suspension' started by TRD Daddy, Jun 30, 2011.

  1. Jun 30, 2011 at 4:14 PM
    #1
    TRD Daddy

    TRD Daddy [OP] Well-Known Member

    Joined:
    May 1, 2010
    Member:
    #36334
    Messages:
    49
    Gender:
    Male
    Hayden , Alabama
    Vehicle:
    05 TRD Prerunner
    5100's front & rear, Fabtec AAL ,HID headlights and foglights, Painted lower valence, Painted engine cover, Undercover bed cover, MagnaFlow exhaust, Tinted windows & 3rd brake light, K&N filter, Bed lights, Debadged, LED interior lights, Anytime fog light mod,
    Just picked up my 5100's and Fabtec AAL. Ready to get them on this weekend then start look'n for bigger tires.
     
  2. Jun 30, 2011 at 4:44 PM
    #2
    toyo freak

    toyo freak Another Toyota Enthusiast

    Joined:
    Mar 7, 2010
    Member:
    #32745
    Messages:
    1,510
    Gender:
    Male
    First Name:
    David
    Mobile, Alabama
    Vehicle:
    2010 V6 D-Cab 4x4
    5100s at 2.5, Wheeler 3 leaf progressive AAL, Weathertech liners, yellow wire mod, toyota OEM bed mat, cup holder mod, afe pro dry s air filter, UWS low pro toolbox, Escort radar detector
    Cool should be nice!
     
To Top