1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

k and n air filter

Discussion in '2nd Gen. Tacomas (2005-2015)' started by avelino, Apr 20, 2011.

  1. Apr 20, 2011 at 5:59 PM
    #1
    avelino

    avelino [OP] Member

    Joined:
    Apr 23, 2008
    Member:
    #6154
    Messages:
    14
    Whats up guys. Just a quick question.

    About a month ago i replaced my air filter with the k and n air filter. After I installed it the only thing I noticed was the sound of the engine was slightly deeper which was kind of annoying after awhile. Since I didnt really notice any performance increases and the engine sound is annoying me, I decided to replace the k and n with a regular air filter. Now even with the normal air filter in, the engine now still sounds like I have the K and N filter in.

    Was wondering if anyone had any idea why this is happenning? By the way, I have a 2005 access cab v6 off road.

    Thank you in advance
     
  2. Apr 20, 2011 at 6:00 PM
    #2
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    Did you put the box back on right?
     
  3. Apr 20, 2011 at 6:07 PM
    #3
    avelino

    avelino [OP] Member

    Joined:
    Apr 23, 2008
    Member:
    #6154
    Messages:
    14
    Yea its back on right. Thats the first thing I thought of too. I actually checked it again today cuz thats the only thing I can think it could be.
     
  4. Apr 20, 2011 at 9:13 PM
    #4
    jrdbrn

    jrdbrn .

    Joined:
    Aug 10, 2009
    Member:
    #20973
    Messages:
    1,395
    Gender:
    Male
    First Name:
    Jared
    Louisiana
    Vehicle:
    11 TRD Off Road
    It's in your head
     
  5. Apr 20, 2011 at 9:14 PM
    #5
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    X2. If the box is closed right and the hoses are attached then don't worry about it.
     
To Top