1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Kenwood rant

Discussion in 'Audio & Video' started by Pre08, Dec 11, 2008.

  1. Dec 11, 2008 at 2:46 PM
    #1
    Pre08

    Pre08 [OP] Well-Known Member

    Joined:
    Apr 7, 2008
    Member:
    #5794
    Messages:
    85
    Gender:
    Male
    Alpharetta, GA
    Vehicle:
    SR5, 4X4, V6, 6Sp, DC
    I knew I should have bought an Alpine. But i let my stereo guy who is now out of business talk me into the POS Kenwood. He said the Excelons are great. Well now the AUX doesn't show up so i can't plug in my MP3!

    I HATE Kenwood!
     
  2. Dec 11, 2008 at 5:54 PM
    #2
    Addicted

    Addicted Well-Known Member

    Joined:
    Jun 22, 2008
    Member:
    #7476
    Messages:
    271
    Greenville, SC
    Vehicle:
    07 DC 4x4 - TRD Off Road - Black
    Why not use the Kenwood warranty, or did you buy it from a non-legit store?
     
  3. Dec 11, 2008 at 6:56 PM
    #3
    81shark

    81shark Well-Known Member

    Joined:
    Nov 7, 2008
    Member:
    #10567
    Messages:
    1,681
    Gender:
    Male
    Vehicle:
    2006 Base Access CP1
    i bought an alpine....works great :)

    seriously, every model is going to have lemons.
     
  4. Dec 11, 2008 at 7:18 PM
    #4
    stevigee

    stevigee It's a MOD, MOD World

    Joined:
    Jul 13, 2008
    Member:
    #7913
    Messages:
    713
    Gender:
    Male
    First Name:
    Stevigee
    Amarillo Texas
    Vehicle:
    2010 TRAIL TEAMS FJ CRUISER
    TRADED FOR 2010 FJ CRUISER TRAIL TEAM Kenwood KDC x792 deck and SW1 pwr sub,cruise,intermittent wipers,hidden hitch, tint, debadge,Nitto Grapplers 265/75-16,Black Powder Coated Toyota Steelies, black steel Toyota wheel center caps, Vent Visors, front guard, leather seat covers, black front badge, shortie antenna, tow hook, seat maglite mod, shock & leaf spring TSB, Extang Trifecta tonneau cover, custom black Fabwright rock sliders 1 3/4" DOM tubing w/ kickout, skid plate, Pop-A-Lock, Bilsten 5100 shocks, BLHM, Azela black tail lights, LEER topper w/rack, tent
    Bummer, what model of Excelon, I hope mine doesnt mess up!! My last Kenwood lasted forever thats why I bought another. Could it be a cable?
     
  5. Dec 11, 2008 at 7:21 PM
    #5
    JJ Customs

    JJ Customs Supreme Leader!

    Joined:
    Feb 24, 2008
    Member:
    #4935
    Messages:
    1,149
    Gender:
    Male
    First Name:
    Jay
    Sparks, NV
    Vehicle:
    2011 TX TRD 4x4 DC
    OME Lift W/886 Coils LR UCA's Daker Leaf Packs 265/75/16 Duratracs N-Fab Steps UWS low pro box Carhartt Seat Covers/Door Inserts/Console Cover Relentless Fab Rear Bumper/Tailgate Skin Bed Mat DB Fab Grille Insert with Baja Designs Cube LED's Bulletproof Fab Engine Tray/Lower Grille Insert .50 Cal Antenna/Valve Stem Covers Custom Fab Console Lock Box Custom Shift Knob Dash Mat Window Tint Rugged Ridge Floor Mats Blacked Out Emblems Color Matched Grill Surround OEM Front Aluminum Skid Plate G-Tek Door Sill Protectors Wheelskins Steering Wheel Cover EGR In Channel Vent Visors FJ emblem on the tailgate Fab Fours front bumper Northstar battery TRD battery tie down
    Yeah I have the Excelon and I love it. It has a 3 year warranty so it should be covered.

    PB100333.jpg
    8.jpg
     
  6. Dec 11, 2008 at 7:44 PM
    #6
    vtragweed

    vtragweed Beef Slut

    Joined:
    Aug 10, 2008
    Member:
    #8454
    Messages:
    1,621
    Gender:
    Male
    First Name:
    Willie
    VA
    Vehicle:
    08 2.7 SR5 Debadged
    afe pro-dry s filter, LCE headers, painted black steelies,color matched grill surround, URD short shifter, UWS black tool box
    kenwoods are nice man, i had 2 and both my brother and dad have one now. never had any problem out of them
     
  7. Dec 12, 2008 at 5:56 AM
    #7
    Pre08

    Pre08 [OP] Well-Known Member

    Joined:
    Apr 7, 2008
    Member:
    #5794
    Messages:
    85
    Gender:
    Male
    Alpharetta, GA
    Vehicle:
    SR5, 4X4, V6, 6Sp, DC
    It's a KDCX-591 I sent an email to customer service. We'll see what they say. The unit is in my Saleen. I'll keep you posted.
     
  8. Dec 12, 2008 at 8:11 AM
    #8
    sooner07

    sooner07 1/2 man 1/2 amazing

    Joined:
    Feb 17, 2008
    Member:
    #4783
    Messages:
    1,400
    Gender:
    Male
    First Name:
    A A Ron
    DFW, Texas
    Vehicle:
    Debadged 2008 Rugged Trail
    Always working on the stereo, painted the front skid plate black to match the truck, debadged , toy tech ultimate lift kit, light racing UCAs, ARB bumper Looking into a supercharger and new exhaust.
    I've never had issues with Kenwoods, expecially the excelon line. Think you just have a lemon or some bad karma.
     
  9. Dec 13, 2008 at 5:58 AM
    #9
    Pre08

    Pre08 [OP] Well-Known Member

    Joined:
    Apr 7, 2008
    Member:
    #5794
    Messages:
    85
    Gender:
    Male
    Alpharetta, GA
    Vehicle:
    SR5, 4X4, V6, 6Sp, DC
    I think it was a ID 10 T error on my part!:p

    May the Aux was turned off by accident!

    Now i feel stupid!:frusty:
     
To Top