1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Knock Sensor

Discussion in 'Toyota Trucks & SUVs' started by 2001toyota, Apr 27, 2014.

  1. Apr 27, 2014 at 9:35 PM
    #1
    2001toyota

    2001toyota [OP] New Member

    Joined:
    Apr 27, 2014
    Member:
    #128612
    Messages:
    3
    Gender:
    Male
    I recently bought a 2001 Toyota Tacoma 3.4l when I bought it, it had catalytic converter codes and knock sensor codes but it seems to run strong . I immediately hollowed out both cats. After I hollowed out the cats I noticed when I would climb a hill and put a load on the motor at about 2500-3000 rpms it would bog down sort of like its in a limp mode. So I did some research and it sounded like it was the knock sensor codes so I changed both knock sensor and wiring harness going into the knock sensors. Put it back together and still has codes and still acts like its in limp mode. but it doesn't seem to have any noticeable knocks. I also change the spark plugs, injectors, and fuel filter and no change. My questions is can it be from no back pressure from the cats being hollowed or is it still something to do with my knock sensors.
     
To Top