1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Latest Generation Tacoma's. Reset Of "Maint Reqd" light

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 4x4Runner, Oct 27, 2006.

  1. Dec 8, 2011 at 10:45 AM
    #101
    puckstopper55

    puckstopper55 Well-Known Member

    Joined:
    May 18, 2011
    Member:
    #56857
    Messages:
    616
    Gender:
    Male
    Long Island
    Vehicle:
    '11 Double Cab TRD Sport, Mag Grey
    tailgate anti-theft Map Light LED's Dome Light LED LP LED Halogen Bed Light Extra D-Rings in bed Anytime Fog Lights Tri-Fold tonnau cover Wet Ok's

    Yup. Not in the manual either
     
  2. Mar 22, 2012 at 3:07 AM
    #102
    mtnbkr

    mtnbkr New Member

    Joined:
    Mar 21, 2012
    Member:
    #75317
    Messages:
    4
    Gender:
    Male
    First Name:
    Mike
    California
    Vehicle:
    '06 PreRunner
    Predator side rails textured black
    Thanks for the info on the reset. I just reached 95,000m and the dealer reset it recently and I sure didn't want to take it back just to reset the light.

    MT
     
  3. Jun 7, 2012 at 3:40 PM
    #103
    Corndawg

    Corndawg Well-Known Member

    Joined:
    Mar 31, 2012
    Member:
    #76018
    Messages:
    1,051
    Gender:
    Male
    First Name:
    Corey
    Utah
    Vehicle:
    2007 double cab TRD off road Radiant Red
    2.5 inch pro comp lift Cobra XRS 9745 Detector 15 band scanner Pioneer DEH-P6900UB Python 991 remote start/ security. Tinted license plate covers Fog Light Mod PIAA Extreme White 4000K Replacement bulbs Red LED Dome and Map lights LED replacement tail light bulbs Black Weather Tech Floor Liners front and rear
    thanks man great thread , helped me out!
     
  4. Jul 17, 2012 at 11:14 AM
    #104
    YOTA LOVER

    YOTA LOVER Stay Calm, and Fire For Effect

    Joined:
    Jul 17, 2012
    Member:
    #82814
    Messages:
    4,093
    Gender:
    Male
    First Name:
    Chris
    NH
    Vehicle:
    2011 MGM Tacoma DCLB SR5
    A slew of pricey stuff my wife hates me for.
    Awesome tip! I got so used to ignoring the light on my 95 Taco (headers, full custom exhaust) that I easily ignore the light on my 2011. The dealer serviced it a little early (under 4,500 miles) and then the light came on.

    As far as using synth- I gladly did on my 95 (2.7L) and it ran like a champ forever, but I was either told (or read) not to use synth in my 2011 (4.0L). It might even be printed on the fill cap.
     
  5. Jul 24, 2012 at 3:45 PM
    #105
    Jughead

    Jughead Well-Known Member

    Joined:
    Jul 18, 2012
    Member:
    #82909
    Messages:
    45
    Gender:
    Male
    First Name:
    Aaron
    Moreno Valley, CA
    Vehicle:
    07 Taco access cab
    AEM bruteforce cold air intake. doug thorley headers. flowmaster exhaust. HID kit heads and fogs. "Taco" badges. black vinyl roof. plastidipped grill and rear bumper and 3rd brakelight. headlight mod. 7" alpine touchscreen head unit. JL audio door components. 10" L7 kicker. custom interior. limo tint all the way around. 50% tint on whole windshield plus 5% sunstrip. pro comp leveling kit in front
    just gave it a shot and it worked perfectly!! glad to see that stupid light gone!
     
  6. Jul 24, 2012 at 3:55 PM
    #106
    JKD

    JKD Well-Known Member

    Joined:
    Jun 9, 2009
    Member:
    #18207
    Messages:
    2,017
    Gender:
    Male
    I can not imagine any reason you wouldn't be able to use synthetic in that (or any) engine.

    I've never seen any warning (credible or not) against using synthetic.
     
  7. Jul 25, 2012 at 6:11 AM
    #107
    YOTA LOVER

    YOTA LOVER Stay Calm, and Fire For Effect

    Joined:
    Jul 17, 2012
    Member:
    #82814
    Messages:
    4,093
    Gender:
    Male
    First Name:
    Chris
    NH
    Vehicle:
    2011 MGM Tacoma DCLB SR5
    A slew of pricey stuff my wife hates me for.
    Thanks! I'd love to run synth. I'm going to ask the dealer and check the manual. I'll repost what I find.
     
  8. Jul 26, 2012 at 1:04 AM
    #108
    slacker

    slacker New Member

    Joined:
    Jul 26, 2012
    Member:
    #83452
    Messages:
    1
    Gender:
    Male
    Vehicle:
    tacoma 4x4
    so, to reset the whole computer you just disconnect the battery for 15 minutes?
     
  9. Jul 26, 2012 at 8:27 AM
    #109
    Jughead

    Jughead Well-Known Member

    Joined:
    Jul 18, 2012
    Member:
    #82909
    Messages:
    45
    Gender:
    Male
    First Name:
    Aaron
    Moreno Valley, CA
    Vehicle:
    07 Taco access cab
    AEM bruteforce cold air intake. doug thorley headers. flowmaster exhaust. HID kit heads and fogs. "Taco" badges. black vinyl roof. plastidipped grill and rear bumper and 3rd brakelight. headlight mod. 7" alpine touchscreen head unit. JL audio door components. 10" L7 kicker. custom interior. limo tint all the way around. 50% tint on whole windshield plus 5% sunstrip. pro comp leveling kit in front
    ive been using full synthetic oil since my first oil change on my truck and it runs just fine.
     
  10. Aug 24, 2012 at 4:34 PM
    #110
    hatuey

    hatuey New Member

    Joined:
    Aug 24, 2012
    Member:
    #85452
    Messages:
    1
    Gender:
    Male
    First Name:
    Jay
    jacksonville,fl
    Vehicle:
    09-PreRunner
    i have an 09 prerunner that has always made an annoying sound from tran when the ac is engaged. the toy mech says unfortunatly there's nothing that can be done,they all do it, have to learn to live with it.the noise only comes when ac is on.answers anyone ? fix?
     
  11. Aug 27, 2012 at 11:38 AM
    #111
    big sky

    big sky Well-Known Member

    Joined:
    Feb 22, 2012
    Member:
    #73387
    Messages:
    515
    Gender:
    Male
    First Name:
    Mike
    Montana
    Vehicle:
    2012 TRD Sport DCSB 4x4
    confirmed that the trip A sequence (like the 2011) works for the 2012 :)
     
  12. Aug 27, 2012 at 1:18 PM
    #112
    Sandman614

    Sandman614 LRGRNR

    Joined:
    Oct 26, 2010
    Member:
    #45273
    Messages:
    23,035
    Gender:
    Male
    Boone, NC\Garner, NC
    Vehicle:
    '06 SR5 Off Road
    ARB Front Bumper, Projector Headlights w/Slimcubby 4300K HID's, Oznium LED's, LED taillights, DIY Washable Cabin Moose Filter, Sockmonkey SR5 Off Road, Aux Audio plug, OME 886x, OME Nitrochargers, Wheelers 3 Leaf Progressive AAL, ImMrYo Rear-View Mirror Lift Bracket, Dodge D-Rings
    wrong thread.
     
  13. Sep 1, 2012 at 8:39 AM
    #113
    PaulPhotographer

    PaulPhotographer Active Member

    Joined:
    Jan 12, 2011
    Member:
    #49169
    Messages:
    30
    Gender:
    Male
    Tampa Bay Area
    Vehicle:
    2012 Tacoma 4x4 & 2007 FJ Cruiser
    Want to say thanks for the update for the 2011 and 2012 models!

    The "Trip A" worked for my 2012, 4x4, AC. And would NOT work using the "Standard Odometer" reset procedure!

    I confirmed it on this thread here!

    -----

    One other extra caveat, that I read here on this thread about using a plastic tube to permanently attach to the hole in the "Oil Catch Basin" of the oil filter. If you go wheeling a lot, there is a good chance that small hole will get plugged up with mud, dirt and stuff. Many times on my FJC, I had to use a small hole punch to open that little hole. So if you have a tube always attached there, it could get clogged up.

    PaulThePhotographer

    ---
     
  14. Sep 5, 2012 at 3:39 PM
    #114
    walawn

    walawn New Member

    Joined:
    Sep 5, 2012
    Member:
    #86305
    Messages:
    4
    Gender:
    Male
    First Name:
    William
    Hampton, VA
    Vehicle:
    2012 5-speed 2.7L 4x4 black regular cab
    K&N drop-in air filter Magnaflow generic muffler Secondary air filter removed
    Does anyone know what kind of oil and filter the dealer uses on the 2.7L?
     
  15. Sep 8, 2012 at 4:11 AM
    #115
    Zoot

    Zoot Well-Known Member

    Joined:
    Feb 18, 2011
    Member:
    #51396
    Messages:
    544
    Gender:
    Male
    Vehicle:
    2011 DC/SB TRD O/R 4X4
    Toyota bed mat, Wet Okole's F&R, Window Tint, custom trail-stripes, Cooper A/T3 265/75R16, MedlinAround interior LEDs, Leer 100r, aFe air filter, K&n cabin filter
    My 2011 would not work on ODO, had to use TRIP. Manual instructions are wrong, I was cussing up a storm until I tried TRIP for the hell of it and it worked first try. Should have came on here first and searched.

     
  16. Sep 8, 2012 at 4:44 AM
    #116
    lowcountrytj

    lowcountrytj Third Member

    Joined:
    Jun 25, 2012
    Member:
    #81325
    Messages:
    1,585
    Gender:
    Male
    First Name:
    Phillip
    Probably at Work
    Vehicle:
    2012 DCLB TRD SPORT "BLACKOUT"
    Thanks for this...I have an oil change due and light on!
     
  17. Sep 24, 2012 at 5:22 AM
    #117
    Nemo1

    Nemo1 Member

    Joined:
    Aug 7, 2012
    Member:
    #84260
    Messages:
    12
    Gender:
    Male
    First Name:
    Neil
    Huntland, TN
    Vehicle:
    08 Prerunner TRD Sport SR5
    Ghetto grill.
    Just changed my oil last weekend. My light came on coming back from Atlanta yesterday. I was quite nervous because I didn't know was it was lol. I found this thread thank god. I am not used to these nanny lights holding my hand to tell me to change the oil lol.
     
  18. Oct 11, 2012 at 8:56 PM
    #118
    thebottomline

    thebottomline Well-Known Member

    Joined:
    Nov 15, 2010
    Member:
    #46203
    Messages:
    663
    Gender:
    Male
    Pac NW
    Vehicle:
    11 sport
    My 2011 was only successful ON ODO

    so it may be related to the new cluster using TRIP A?

    I would say if someone has a 2011 tacoma, try either one.
     
  19. Dec 7, 2012 at 12:29 PM
    #119
    Skootter14

    Skootter14 Upon my signal, unleash Hell

    Joined:
    Jan 1, 2011
    Member:
    #48576
    Messages:
    2,847
    Gender:
    Male
    First Name:
    Jeremy
    WA
    Vehicle:
    '11 TRD Sport 4D LB 4x4 Metallic Grey
    "a lot of stupid stuff" -Wife
    I have a 2011 TRD Sport and i had my first oil change/etc outside of the toyotacare plan, so i took it to the garage on post where i work. They had no clue how to reset and I read something about the ODO, pushing it down, turn off vehicle then crank back to where the ODO lights up but truck isnt on. Tried exactly that from memory, had a couple dashes kinda "count down" where the ODO numbers are and it reset the light, first try no issues. Just FYI
     
  20. Dec 17, 2012 at 7:34 AM
    #120
    Badass Tacoma

    Badass Tacoma New Member

    Joined:
    Dec 17, 2012
    Member:
    #93230
    Messages:
    3
    Gender:
    Male
    First Name:
    Sergio
    San Antonio Tx
    Vehicle:
    2012 Sr5 4x4
    Black bull bar, black Nfabs
To Top