1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

LED dome light stays on

Discussion in '2nd Gen. Tacomas (2005-2015)' started by TACONORM, Jan 11, 2010.

  1. Jan 11, 2010 at 7:50 AM
    #1
    TACONORM

    TACONORM [OP] Member

    Joined:
    Jan 5, 2010
    Member:
    #28826
    Messages:
    21
    Gender:
    Male
    First Name:
    NORM
    FL
    Vehicle:
    2010 TRD OR 4X4
    Hello, Does anyone have the same problem as I do with the dome light staying on after changing out to an LED bulb. The LED bulb goes on bright when a door opens, but then stays illuminated only not as bright when the door closes. Don't know why, need help please.
    Thanks
     
  2. Jan 11, 2010 at 7:53 AM
    #2
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    does it go out after about 30 sec or so? if you put the old bulb in does it work right?
     
  3. Jan 11, 2010 at 8:25 AM
    #3
    BlackRig

    BlackRig Well-Known Member

    Joined:
    Feb 21, 2009
    Member:
    #13900
    Messages:
    222
    Gender:
    Male
    First Name:
    Craig
    Riverside, IL
    Vehicle:
    09 TRD O/R AT
    Is the switch on? Is the nap light pushed in? Just checking the obvious stuff 1st.
     
  4. Jan 11, 2010 at 8:51 AM
    #4
    PreRunnerSeth

    PreRunnerSeth Well-Known Member

    Joined:
    Aug 12, 2009
    Member:
    #21110
    Messages:
    4,274
    Gender:
    Male
    Apex, NC
    Vehicle:
    15 Black DC OR Prerunner
    Its just some leakage current. LEDs use much less current to light. So a small amount of leakage current can cause the LEDs to light a little. My wife's Altima does this too. there really isn't anything you can do about it without redesigning the entire circuit.
     
  5. Jan 11, 2010 at 9:04 AM
    #5
    Kyouto42

    Kyouto42 Iron Beard

    Joined:
    Aug 18, 2008
    Member:
    #8614
    Messages:
    9,243
    Gender:
    Male
    First Name:
    Jake
    Ahwatukee, AZ
    Vehicle:
    BSP '10 4x4 TRD Off-Road DC
    See build thread in signature
    Eh, my led dome light works perfectly... I'd mess around with the switch...
     
  6. Jan 11, 2010 at 11:32 AM
    #6
    PreRunnerSeth

    PreRunnerSeth Well-Known Member

    Joined:
    Aug 12, 2009
    Member:
    #21110
    Messages:
    4,274
    Gender:
    Male
    Apex, NC
    Vehicle:
    15 Black DC OR Prerunner
    Its most likely a reverse current flow. if youre using a LED bulb with a rectifier on it then the reverse current will light the bulb. A bulb without a rectifier will not light with reverse current.
     
  7. Jan 12, 2010 at 5:35 AM
    #7
    TACONORM

    TACONORM [OP] Member

    Joined:
    Jan 5, 2010
    Member:
    #28826
    Messages:
    21
    Gender:
    Male
    First Name:
    NORM
    FL
    Vehicle:
    2010 TRD OR 4X4
    I thank all of you for your replies. The dome light thats the problem is the one in the middle of the seats. It does stay on all the time. I noticed the problem one morning when the light was on all night. The front map lights I've replaced with LED's and they work fine. If it is some reverse electricity, I'm not sure what a rectifier is. If that will take care of the problem can it be purchased?
     
  8. Dec 19, 2012 at 1:27 PM
    #8
    OhYeah

    OhYeah Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78989
    Messages:
    109
    Gender:
    Male
    reviving this thread... have you fixed this OP? has anyone else had this problem?

    like the OP, my dome light stays on. all switch functions work fine except the "door" switch. when a door is open, the light will come on, when all doors are closed, the light will dim, but stay on. thought it would turn off after a while but it doesnt unless i turn the switch to "off"

    I also replaced the map lights but those work fine.

    any idea?
     
  9. Dec 19, 2012 at 6:44 PM
    #9
    OhYeah

    OhYeah Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78989
    Messages:
    109
    Gender:
    Male
    Is it the led? I got it from ddm tuning..
     
To Top