1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Loud clank during hard braking & speed bumps

Discussion in '2nd Gen. Tacomas (2005-2015)' started by CruJones33, Jun 21, 2011.

  1. Jun 21, 2011 at 4:27 PM
    #1
    CruJones33

    CruJones33 [OP] Member

    Joined:
    Aug 5, 2009
    Member:
    #20709
    Messages:
    11
    Gender:
    Male
    Pretty loud metal clanking sound coming from under the truck during hard braking and speed bumps. Any idea's? (No tow hitch)
     
  2. Jun 21, 2011 at 5:12 PM
    #2
    Tacomanator

    Tacomanator Boiling denim and bangin whores

    Joined:
    Jul 25, 2010
    Member:
    #40746
    Messages:
    4,634
    Gender:
    Male
    First Name:
    Clam Slammer
    Southern Cali
    King 2.5" extended travel coilovers with compression adjusters, Camburg UCA's, King 2.5" rear shocks, TRD 1st gen CAI.
    Front or rear? Have you recently done any mods?
     
  3. Jun 21, 2011 at 5:14 PM
    #3
    Seabass

    Seabass Chrome won't get you home

    Joined:
    Apr 2, 2010
    Member:
    #34455
    Messages:
    6,443
    Gender:
    Male
    First Name:
    Adam
    AZ
    Vehicle:
    '06 Sport 4x4
    You don't really care, do you.
    Someone swipe your spare tire and the little thingie is hanging from the cable and banging into things?

    Seriously though, maybe u-bolts loose in the rear?
     
  4. Jun 21, 2011 at 5:52 PM
    #4
    06RadiantRed

    06RadiantRed Well-Known Member

    Joined:
    Dec 18, 2010
    Member:
    #47907
    Messages:
    412
    Gender:
    Male
    First Name:
    Ryan
    CA-Bay Area
    Vehicle:
    2006 Tacoma 4x4 TRD Off Road - RadRed!!
    ICON ext. Travel Coilovers, TC UCAs, Fox 2.0 FJ Rear Shox + 2"AAL rear
    I had this, with the exact same symptoms you are describing. Way too loud to be the "brake pads floating".. not that every one has the same issue BUT.. mine ended up being the Lower Control Arm bolts were not tight enough. Had someone reverse, brake hard, drive forward , brake hard and voila.. saw the bolt head on the back side of the passenger side LCA pop up and down on the alignment cam. Fucking Wheel-works :bananadead:. Thanks for not checking the bolts after my last alignment.
     
To Top