1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Loud Hum or whistle from Windshield at Highway Speeds

Discussion in '2nd Gen. Tacomas (2005-2015)' started by JEA86, Jul 27, 2010.

  1. Jul 27, 2010 at 5:35 AM
    #1
    JEA86

    JEA86 [OP] Well-Known Member

    Joined:
    Jul 3, 2010
    Member:
    #39744
    Messages:
    340
    Gender:
    Male
    First Name:
    Jeremy
    WV
    Vehicle:
    2016 TRD Off-Road
    Guys dont know if anyone else is experiencing this problem but i am getting a loud whistle or hum noise when i get in speeds in excess of 65 MPH, it too me forever to pinpoint the location but it seams as if i press on the windshield right behind my review mirror that the noise gets lower.

    Does anyone know what causes this? i got an appointment at the dealer next week, and my rear leaf springs are EXTREMELY squeaky
     
  2. Jul 27, 2010 at 5:41 AM
    #2
    Simon's Mom

    Simon's Mom Wag More Bark Less

    Joined:
    Apr 12, 2007
    Member:
    #1297
    Messages:
    9,320
    Gender:
    Female
    First Name:
    Judy or Jude :)
    SBurl Vermont
    Vehicle:
    13 TRD OR DC MGM
    Stock for now
    Ohters have reported the same thing.
    There was a TSB
    NV006-07 AUG 07 Body - Windshield Wind Noise at Highway Speeds
    If you look in the TSB database sticky maybe that will help?
     
  3. Jul 27, 2010 at 6:06 AM
    #3
    JEA86

    JEA86 [OP] Well-Known Member

    Joined:
    Jul 3, 2010
    Member:
    #39744
    Messages:
    340
    Gender:
    Male
    First Name:
    Jeremy
    WV
    Vehicle:
    2016 TRD Off-Road
    it would for sure help, do you know a link to where i can get to that section of the forum?
     
  4. Jul 27, 2010 at 7:14 AM
    #4
    Simon's Mom

    Simon's Mom Wag More Bark Less

    Joined:
    Apr 12, 2007
    Member:
    #1297
    Messages:
    9,320
    Gender:
    Female
    First Name:
    Judy or Jude :)
    SBurl Vermont
    Vehicle:
    13 TRD OR DC MGM
    Stock for now
  5. Jul 27, 2010 at 7:25 AM
    #5
    JEA86

    JEA86 [OP] Well-Known Member

    Joined:
    Jul 3, 2010
    Member:
    #39744
    Messages:
    340
    Gender:
    Male
    First Name:
    Jeremy
    WV
    Vehicle:
    2016 TRD Off-Road
    that TSB sounds exactly like the problem i am having thank you so much!
     
  6. Jul 27, 2010 at 9:53 AM
    #6
    Lurkin

    Lurkin Well-Known Member

    Joined:
    May 21, 2009
    Member:
    #17497
    Messages:
    10,871
    First Name:
    Rod
    Pearland, TX
    Vehicle:
    09 PreRunner SR5 DC
    Update this post if you get it fixed, or if the dealer gives you any grief. My 09 has done this since new, but I haven't taken the time to get it in and see if they'll fix it (TSB isn't written to apply to 09+'s).
     
  7. Jul 27, 2010 at 6:30 PM
    #7
    greeny2022

    greeny2022 New Member

    Joined:
    Jul 27, 2010
    Member:
    #40856
    Messages:
    3
    Gender:
    Male
    Vancouver
    Vehicle:
    06 TRD Off Road
    32" tires, Sliders
    I had this problem, i hear the dealer replaces the moulding on the top of your front window but i remedied this using black silicone caulking in the groove along that moulding, just taped off what i didn't want to seal and away you go haven't had the noise since. good luck
     
  8. Jul 27, 2010 at 6:36 PM
    #8
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,572
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    Their is also that search pull down menu as well..............just sayin.....:rolleyes:
     
  9. Nov 16, 2011 at 6:33 PM
    #9
    Old Vaughn

    Old Vaughn New Member

    Joined:
    Oct 7, 2011
    Member:
    #64781
    Messages:
    3
    Gender:
    Male
    First Name:
    Vaughn
    Eastern Ontario
    Vehicle:
    2.7 engine, 3 speed transmission, 6 ft box
    No mods but a hitch and box cover
    Yes, I have a partial fix. Above the windshield, full width of the cab, is a deep channel. Fill that channel with a length of rope, full width. If the rope is the right size it will stay in there.
    It cancelled the loud whistle for me.
    Just found this a few days ago. 2011 Access Cab.
     
  10. Nov 16, 2011 at 6:46 PM
    #10
    05RedTaco

    05RedTaco Nom Nom Nom

    Joined:
    Sep 20, 2010
    Member:
    #43521
    Messages:
    1,672
    Gender:
    Male
    First Name:
    Tony
    Scottsdale
    Vehicle:
    2000 Tacoma XtraCab 2.7L 4x4
    1, have glass coverage on your insurance policy

    2, drive a lot, get several rock chips or get lucky enough to break the windshield

    3, get windshield replaced with $0 deductible

    4, bam noise is gone...

    Did this in wife's camry no issues since replacement!
     
  11. Nov 16, 2011 at 7:01 PM
    #11
    OffroadToy

    OffroadToy This ain't Dodge City, and you ain't Bill Hickok

    Joined:
    Sep 12, 2009
    Member:
    #22680
    Messages:
    5,256
    Gender:
    Male
    Vehicle:
    07 TRD OFFROAD 4x4 VSC/TRAC/DAC/HAC
    snugtop, piaa, weathertech, westin, oem bed mat, trd seat covers, avs inchannel vent visors, 2" suspension lift, front diff drop, rear differential breather extension, oil filter drain hose, a/c drain hose extention & reroute, front window tint, cat theft protection plate, tailgate clamp mod, xpel headlight/foglight protecters, oem block heater, bfg 265/75R/16 a/t k/o's, cabin air rodent protection screen, rcbs illuminated 4X4 switch mod
  12. Nov 16, 2011 at 10:48 PM
    #12
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    If you're under 30K miles, you fall under the grace period of the TSB. Otherwise you're on your own to fix it.... not hard though.
     
  13. Nov 16, 2011 at 10:50 PM
    #13
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    Blast your leaf springs with a hose when you clean your truck. Its dirt :) Most of the time that fixes it. If not, squirt it with some spray lube of some sort, really doesn't matter, it will stop it though.
     
To Top