1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

loud, strange noise coming from somewhere under the hood

Discussion in '1st Gen. Tacomas (1995-2004)' started by bstar, Dec 10, 2009.

  1. Dec 10, 2009 at 2:29 PM
    #1
    bstar

    bstar [OP] New Member

    Joined:
    Dec 10, 2009
    Member:
    #27339
    Messages:
    1
    Gender:
    Male
    Vehicle:
    01 PreRunner SR5
    Truck: '01 Tacoma, automatic, 4x4, 6 cylinder Prerunner ext. cab, 130,000 miles

    Problem: when in overdrive, the truck will makes a loud, deep, "wind like" sound (almost whirring) when accelerating. the sound occurs when the truck is between 15000 and 25000 RPMs (occurs when going 35MPHs and 45MPHs and above). The sound goes away when i take the truck out of overdrive. i have no check engine lights on and my gas mileage is sucking badly. i'm losing about 4MPG.

    what hasn't worked to fix the problem: my best friend who works on cars says he's never heard a sound like that before and has no idea what it is. a reliable toyota mechanic couldn't figure out what the sound was and/or where it was coming from. he said it sounds like it's coming from the transmission. he quoted me for a new transmission and said that if it were his truck he'd keep driving it and take it to a transmission specialist. i have just recently changed my air filter, spark plugs, throttle control, and cleaned the mass air flow sensor. nothing has helped.

    Does anyone have the same problem or know what is going on with my truck?
     
  2. Dec 10, 2009 at 4:35 PM
    #2
    matthew5olson

    matthew5olson Well-Known Member

    Joined:
    Dec 21, 2008
    Member:
    #11782
    Messages:
    483
    Gender:
    Male
    First Name:
    matthew
    pittsburgh, PA
    Vehicle:
    04 ext cab 3.4L 5spd 4x4 sr5
    K&N cold air intake, doug thorley headers, rear sensor simulator, flowmaster 40 series, magnecor plug wires, Royal Purple synthetic gear lube, airaid throttle body spacer, Hyperground system, flex-a-lite elec fan.
    don't take your rpms to 15k and you'll be ok.

    change your tranny fluid. Look for any metal pieces. Also what color is your tranny fluid (red, brown, or black). Ever had it changed before. A flush would be better but a service station has to do that and its usually at least $100 (it was when I had a car)

    Do you do a lot of towing. And how is your driving style.
     
  3. Dec 10, 2009 at 7:36 PM
    #3
    MowTaco

    MowTaco Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22530
    Messages:
    3,820
    Gender:
    Male
    First Name:
    Matt
    South Dakota
    Vehicle:
    03 GMC Sierra
    Lol yeah you got a used F1 engine in that or what?
     
To Top