1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

LT KIT! Not Mine*

Discussion in '1st Gen Tacoma Marketplace' started by rcfreak201, Apr 8, 2011.

  1. Apr 8, 2011 at 8:38 AM
    #1
    rcfreak201

    rcfreak201 [OP] Well-Known Member

    Joined:
    Jul 24, 2010
    Member:
    #40660
    Messages:
    6,651
    Gender:
    Male
    .
     
    Last edited: Oct 21, 2013
  2. Apr 8, 2011 at 8:43 AM
    #2
    jblaze805

    jblaze805 Well-Known Member

    Joined:
    Nov 20, 2009
    Member:
    #26253
    Messages:
    1,135
    Gender:
    Male
    Ventura/Fresno, CA
    Vehicle:
    04 trd pre-runner
    2.5" king coilovers, caburg uca, magnaflow exhaust, aem intake
    I think this was mentioned somewhere already maybe in the Long Travel BS thread it is the Engage Kit that busted on him which crashed his truck. Looks like he got the kit repaired though.
     
  3. Apr 8, 2011 at 8:47 AM
    #3
    jblaze805

    jblaze805 Well-Known Member

    Joined:
    Nov 20, 2009
    Member:
    #26253
    Messages:
    1,135
    Gender:
    Male
    Ventura/Fresno, CA
    Vehicle:
    04 trd pre-runner
    2.5" king coilovers, caburg uca, magnaflow exhaust, aem intake
    I wish I had the money for that kit though thats one bad ass looking kit
     
To Top