1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

"Maint Reqd" light was on.......

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 230g Hydra-Shok, Jun 7, 2010.

  1. Jun 7, 2010 at 12:32 PM
    #1
    230g Hydra-Shok

    230g Hydra-Shok [OP] Active Member

    Joined:
    Jan 6, 2008
    Member:
    #4121
    Messages:
    32
    Vehicle:
    2008 V6 blue access cab TRD with 6-speed
    I was driving home on Saturday and it came on. I was like.....:eek:. Truck was, is, and always has run fine.

    I know that the light comes on when a certain number of miles have been put on the odometer and it thinks you need an oil change but up until this time, the light has blinked a few times when I first started it. It didn't do that this time. I was just driving down the highway and it popped on.

    It might be the oil change/odometer thing because I had just turned 19,000 miles but it's worrying nonetheless. The dealership is an hour away and I don't want to waste a trip there if it's for nothing.

    Anyway, I remembered the procedure that I read here to reset the Maint Reqd light and did that. It shut off right away and hasn't come back on since.

    If there were actually a problem with the truck, the light would come back on, wouldn't it???

    Thanks as always! :)
     
  2. Jun 7, 2010 at 12:34 PM
    #2
    tacobell007

    tacobell007 Does that have the v6?

    Joined:
    Jun 11, 2009
    Member:
    #18327
    Messages:
    1,529
    Gender:
    Male
    First Name:
    Drew
    Westfield, MA
    Vehicle:
    06 Regular Cab Lifted
    Eibach springs, OME Dakars, adjustable Bilstien 5100's up front, Icon ext travel rear shocks, Kenwood in-dash nav receiver, Kicker 10 inch sub in a ported truck box, Kenwood 350 watt amp, stickers, Better Built toolbox, LED tool box lights, 35% tint, Flowmaster Super 44 muffler, 33x12.5x17 General Grabber AT2, Fuel Off-Road Trophy d551 in 17x8.5, BHLM, white corner marker bulbs, color matched front grille, custom satoshi grille mod with matching Toyota badge, aFe Pro Dry-S drop in filter, diff breather mod, new frame from recall
    Possibly means that you need an oil change. My dad's came on before he had his oil changed. Now the light does not come on.
     
  3. Jun 7, 2010 at 12:34 PM
    #3
    toyotadude5

    toyotadude5 Breazeale- Pronounced Brazil

    Joined:
    Oct 23, 2009
    Member:
    #24812
    Messages:
    1,992
    Gender:
    Male
    First Name:
    chris
    Flagstaff, az
    Vehicle:
    2006 Subaru wrx sti (white)
    no thats just to remind you of oil change. If there was a problem the check engine light would come on
     
  4. Jun 7, 2010 at 12:40 PM
    #4
    230g Hydra-Shok

    230g Hydra-Shok [OP] Active Member

    Joined:
    Jan 6, 2008
    Member:
    #4121
    Messages:
    32
    Vehicle:
    2008 V6 blue access cab TRD with 6-speed
    Thanks, guys.

    Yeah, I changed my oil and filter just about 1,500 miles ago but I think the light coming on is based solely on the odometer, not like some fancy oil-sensing apparatus, right?
     
  5. Jun 7, 2010 at 12:42 PM
    #5
    RainDodger

    RainDodger YGWYPF

    Joined:
    Nov 23, 2009
    Member:
    #26412
    Messages:
    363
    Gender:
    Male
    Great Northwest
    Vehicle:
    '09 Black, TRD Sport
    None yet! It's new!
  6. Jun 7, 2010 at 12:44 PM
    #6
    Surf805

    Surf805 New Member

    Joined:
    Jun 7, 2010
    Member:
    #38522
    Messages:
    3
    Gender:
    Male
    First Name:
    Dan
    San Luis Obispo, CA
    Vehicle:
    05 2.7L
    I change my oil regularly but my light is still on. ive pretty much ignored it at this point...
     
  7. Jun 7, 2010 at 12:45 PM
    #7
    borderbrat

    borderbrat Watching Chris4x4 o.O

    Joined:
    Nov 15, 2007
    Member:
    #3480
    Messages:
    2,487
    Gender:
    Male
    First Name:
    Jeremy
    Victoria BC, Canada
    Vehicle:
    2008, Black sand pearl, SR5, 4X4
    PIAA fogs, led "puddle" lights, bed lights, in cab 115V, Toyota Devil emblem, Randy Ellis light bar with Hella Black Magics, OME 885 and Dakar leaf springs OME shock all round, 2.5 Gal OBA system with air horns, iPod adapter, scangauge on blend mount, magnaflow catback, bike fork mounts, tinted 2009 tails.
    I've never had this light come on. It would be nice to see a list of what will turn it on. Is it based on milage or is there more to it than that?
     
  8. Jun 7, 2010 at 12:51 PM
    #8
    Ecapvegas

    Ecapvegas Active Member

    Joined:
    Aug 26, 2009
    Member:
    #21812
    Messages:
    28
    Gender:
    Male
    Sin City
    Vehicle:
    2010 Silver 4x4
    +1^ anyone know if there is such a list or anyone know for sure that it's only related to oil changes?
     
  9. Jun 7, 2010 at 12:51 PM
    #9
    230g Hydra-Shok

    230g Hydra-Shok [OP] Active Member

    Joined:
    Jan 6, 2008
    Member:
    #4121
    Messages:
    32
    Vehicle:
    2008 V6 blue access cab TRD with 6-speed
    Here's how to reset that light:


    To reset you Maintenance Required light:
    1. Turn the ignition key to the "OFF" position.

    2. Turn the ignition key to the "ON" position while holding down the trip meter reset knob.

    Hold down the knob for at least 5 second. The odometer indicates "000000" and the light goes off.
    NOTE: (You will see a series of dashes that count down while the system resets itself)

    If the system fails to reset, the light will continue to flash and you must re-perform the procedure.
     
  10. Jun 7, 2010 at 12:54 PM
    #10
    lookylookitzadam

    lookylookitzadam Retrofit Club!

    Joined:
    Jul 16, 2009
    Member:
    #19777
    Messages:
    714
    Gender:
    Male
    First Name:
    Adam
    San Diego
    Vehicle:
    07 DC OffRoad
    Maint Req light is based on mileage intervals between resets.

    Check engine light is based on error codes being registered by the OBD2 module.




    Is this stuff stickied yet?
     
  11. Jun 7, 2010 at 12:54 PM
    #11
    Surf805

    Surf805 New Member

    Joined:
    Jun 7, 2010
    Member:
    #38522
    Messages:
    3
    Gender:
    Male
    First Name:
    Dan
    San Luis Obispo, CA
    Vehicle:
    05 2.7L
    ahhh thanks! just went down to the garage and did it!
     
  12. Jun 7, 2010 at 12:57 PM
    #12
    Brunes

    Brunes abides. Staff Member

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,727
    Gender:
    Male
    First Name:
    Rotorhead
    Big Easy, USA
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit Upcoming: ATO Gas Tank Skid and Sliders w/ kickout. ATO Shackle Flip Kit. Down the line: Front/Rear ARB Lockers w/ OBA. 4.56 Gears


    IIRC-
    4500 miles it will flash like 6 times (so 10-12 seconds) on start up until
    5000 miles when it will come on solid and stay on until it is reset. There is no magic sensor that turns it off. If you or the mech who does your work doesn't reset it-It'll go off on mileage, no matter when you swap oil out.

    13th item on the "Mods and Tutorials" Drop down at the top of the site. People just tend to post instead of searching because they do not know what it means and are concerned for their rig.
     
  13. Jun 7, 2010 at 12:57 PM
    #13
    lepedog23

    lepedog23 Taco Rookie

    Joined:
    Mar 29, 2010
    Member:
    #34221
    Messages:
    932
    Gender:
    Male
    First Name:
    Frank
    Huntington Park
    Vehicle:
    2001 DC Tacoma. Stock. Salvage Title MOD.
    Salvage Title MOD.
    my maint req light blinks "six" times when i turn on my truck. i noticed it yesterday so i changed out the oil/filter this morning. it only has 4,890 miles on it. and its worrying my since its new. possible problem? runs perfect checked all fluids and all is good. going to try the reset. :confused:
     
  14. Jun 7, 2010 at 12:58 PM
    #14
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    I think they stopped issuing them with the trucks, part of that "going green" hype.
     
  15. Jun 7, 2010 at 1:00 PM
    #15
    calaniz0312

    calaniz0312 Well-Known Member

    Joined:
    Apr 22, 2010
    Member:
    #35772
    Messages:
    369
    Gender:
    Male
    First Name:
    Carlos
    Mission, TX
    Vehicle:
    05 PreRunner SR5
    Pop a Lock tail gate lock, Dee Zee Heavy Duty bed mat, Viper alarm system, Blacked out headlights, Blacked out tailights.
    The same thing happened to me a couple of months ago. It's my first Toyota and I didn't know what the light meant until I asked here. Change your oil bro. That's all you need.
     
  16. Jun 7, 2010 at 1:57 PM
    #16
    aficianado

    aficianado Well-Known Member

    Joined:
    Oct 27, 2009
    Member:
    #25015
    Messages:
    5,105
    Gender:
    Male
    bay area, california
    Vehicle:
    2006 access cab. 4x4, TRD-OR
    OME lift. 884 coils, 1.5" AAL's installed on nonTSB leafs. front diff drop kit.
    this light messes with my OCD mind. i cant let it flash for 500 miles..i end up doing mine right away which is around the 4500 mile mark..this was yesterday.
     
  17. Jun 7, 2010 at 2:08 PM
    #17
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    4,251
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    :thumbsup: Most likely, judging by the number of threads with maint. light issue...
    Toyota should make recall on that.
     
  18. Jun 7, 2010 at 5:32 PM
    #18
    NWtacoma

    NWtacoma Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18142
    Messages:
    1,689
    Gender:
    Male
    Kent,WA
    Vehicle:
    2011 TRD Sport 4x4
    265/70/17 bfg AT
    f'n seriously
     
  19. Jun 8, 2010 at 12:10 AM
    #19
    lepedog23

    lepedog23 Taco Rookie

    Joined:
    Mar 29, 2010
    Member:
    #34221
    Messages:
    932
    Gender:
    Male
    First Name:
    Frank
    Huntington Park
    Vehicle:
    2001 DC Tacoma. Stock. Salvage Title MOD.
    Salvage Title MOD.
    does this work on all tacoma 05-present? tried doing this earlier a few times and didnt work. had to come back and read it a few times to make sure i was doing it right. and still keeps blinking?
     
  20. Dec 19, 2010 at 4:56 PM
    #20
    SOSHeloPilot

    SOSHeloPilot Well-Known Member

    Joined:
    Mar 31, 2009
    Member:
    #15422
    Messages:
    2,673
    Gender:
    Male
    Atlanta
    Vehicle:
    2012 DCSB, TRD-OR - Traded In on a Ridgeline
    Finally, got my "first 4x4" in a Tacoma. Barcelona Red w/ JBL & Entune - Then traded it in on a Ridgeline.
    .

    I found this thread in "search mode" and need to turn off my "maintenance light" tomorrow.

    Thanks for the DIY post ... :D

    .
     
To Top