1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Maint required just came on....

Discussion in 'Technical Chat' started by miketyler, Dec 23, 2008.

  1. Dec 23, 2008 at 1:03 PM
    #1
    miketyler

    miketyler [OP] Well-Known Member

    Joined:
    Jul 27, 2007
    Member:
    #2232
    Messages:
    89
    ...in my 2007 DBL cab V6 TRD Sport. Checked gas cap for tight and was ok. No noticeable difference in performance. Truck just turned over 16k miles. Maybe meaningless but my TPS light has been on for a few days now.

    I know it's a shot in the dark but what do you think? Any ideas? Am going to take it to Autozone and let them pull the codes.
     
  2. Dec 23, 2008 at 1:05 PM
    #2
    TRD4x4858

    TRD4x4858 Taco Traitor!

    Joined:
    Oct 20, 2008
    Member:
    #10117
    Messages:
    3,056
    Gender:
    Male
    San Diego
    Vehicle:
    95 Jeep XJ
    BONE STOCK! lol
    It means you need an oil change, check your tire pressure for the TPS light including your spare
     
  3. Dec 23, 2008 at 1:06 PM
    #3
    Delmarva

    Delmarva Mayor of TW

    Joined:
    Oct 22, 2008
    Member:
    #10148
    Messages:
    35,854
    Gender:
    Male
    First Name:
    Mike
    Tucson, AZ
    Vehicle:
    12 Tundra TRDRW
    Nada, Zip, Zilch, Nothing
    To reset:

     
  4. Dec 23, 2008 at 1:06 PM
    #4
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,839
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    ........and read the manual :thumbsup:
     
  5. Dec 23, 2008 at 4:33 PM
    #5
    miketyler

    miketyler [OP] Well-Known Member

    Joined:
    Jul 27, 2007
    Member:
    #2232
    Messages:
    89
    ok, thanks. :D

    You know I read the manual and if I remember correctly the oil change reminder starts coming on at startup for 30 seconds and the length of time increases as you get closer to the 5000mi mark. The light extinguished as expected just after startup then came back on while I was driving it.

    I'd would be relieved to know it is nothing more than the oil change reminder but I didnt think it was designed to behave that way.
     
  6. Dec 23, 2008 at 5:11 PM
    #6
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,839
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Did you change the oil yourself? Could it be low?
     
  7. Dec 23, 2008 at 5:13 PM
    #7
    miketyler

    miketyler [OP] Well-Known Member

    Joined:
    Jul 27, 2007
    Member:
    #2232
    Messages:
    89
    yes, Mobil1. Will have to check. So the oil reminder shouldnt come on while driving, it comes on at startup and stays on if you are at 5k miles since last reset?
     
  8. Dec 24, 2008 at 12:28 AM
    #8
    ForeRunner

    ForeRunner Scotch before noon. Moderator

    Joined:
    Sep 9, 2006
    Member:
    #7
    Messages:
    12,108
    Gender:
    Male
    First Name:
    Drunken Sailor
    Somewhere between Maine and Florida
    Vehicle:
    2016 Subaru WRX STI Limited (no wing)
    Extra PSI
  9. Dec 24, 2008 at 3:19 AM
    #9
    miketyler

    miketyler [OP] Well-Known Member

    Joined:
    Jul 27, 2007
    Member:
    #2232
    Messages:
    89
    Sweet !

    cool sig btw :)
     
  10. Dec 24, 2008 at 3:38 AM
    #10
    Delmarva

    Delmarva Mayor of TW

    Joined:
    Oct 22, 2008
    Member:
    #10148
    Messages:
    35,854
    Gender:
    Male
    First Name:
    Mike
    Tucson, AZ
    Vehicle:
    12 Tundra TRDRW
    Nada, Zip, Zilch, Nothing
    :rofl:
     
  11. Dec 24, 2008 at 2:41 PM
    #11
    miketyler

    miketyler [OP] Well-Known Member

    Joined:
    Jul 27, 2007
    Member:
    #2232
    Messages:
    89
    Both issues fixed now. All four tires were at 25psi. Correcting that still didn't put out the light. I had to correct the spare tire pressure as well before the light would go out.

    Too cool.
     
To Top