1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

maintenance light blinking

Discussion in '2nd Gen. Tacomas (2005-2015)' started by rberumen2, Jan 26, 2010.

  1. Jan 26, 2010 at 8:19 AM
    #1
    rberumen2

    rberumen2 [OP] Well-Known Member

    Joined:
    Oct 28, 2009
    Member:
    #25084
    Messages:
    284
    Gender:
    Male
    First Name:
    Ralph
    California
    Vehicle:
    2017 White Tacoma TRD Sport 4x4 DCSB
    i went mudding the other day but eversince i went i notice that when i turn my truck on the maintenance light blinks about 4-5 times then it stops. i never noticed this before, is it trying to tell me something. or should i check some things out like the intake filter?
     
  2. Jan 26, 2010 at 8:21 AM
    #2
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Moderator

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    28,093
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    means u are within 500 miles of needing an oil change......

    RTFM!!! :D

    EDIT: w/i 500 miles of the scheduled 5k mile change....if u normally do urs at say 3k and it gets reset, u wouldnt have seen it.....until someone forgot to reset it and it's coming around on the next change
     
  3. Jan 26, 2010 at 8:30 AM
    #3
    mws4ua

    mws4ua I'll try being nicer if you try being smarter.

    Joined:
    May 14, 2008
    Member:
    #6624
    Messages:
    7,073
    Gender:
    Male
    First Name:
    Matt
    Birmingham
    Vehicle:
    Sold my truck Jan '13... Still hang around.
  4. Jan 26, 2010 at 8:31 AM
    #4
    memario1214

    memario1214 Vivid Illumination Vendor

    Joined:
    Oct 1, 2009
    Member:
    #23628
    Messages:
    13,773
    Gender:
    Male
    First Name:
    Colton
    Gillette, WY
    Vehicle:
    05 Dub Cab TRD Sport 4x4
    Yeah, I gots boost
    Oil Change! But make sure to reset the computer too!
     
  5. Jan 26, 2010 at 8:52 AM
    #5
    05Moose

    05Moose Middle-Aged Member

    Joined:
    Jan 18, 2010
    Member:
    #29613
    Messages:
    2,535
    Gender:
    Male
    First Name:
    Jim
    In the snow (NorCal)
    Vehicle:
    '05 4x4 DC LB SR5 #8 (LSD, Tow Pkg)
    '05 4x4 DC LB SR5 (LSD & Tow Pkg), Timbrens, AAL, 5100s (.85), Owned: 12/3/04 Mods: Fog, Map/Dome Light, Illuminated 4wd Switch, Washable Cabin Air Filter
    Sounds like you got mud between the ears. That's a common problem with mudding. Clean it out and you should be able to figure the rest from there (with all the helpful suggestions above, of course:D).
     
  6. Jan 26, 2010 at 8:52 AM
    #6
    Zombie Runner

    Zombie Runner Are these black helicopters for me?

    Joined:
    Mar 13, 2008
    Member:
    #5246
    Messages:
    15,036
    Gender:
    Male
    First Name:
    Kevin
    Wichita Falls, TX
    Vehicle:
    Tundra, double cab.
    LED interior lights, stubby antenna, Pioneer in dash screen, good driver mod.
    self destruct.
     
To Top