1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Mass air flow sensor??

Discussion in '1st Gen. Tacomas (1995-2004)' started by antf42080, Jul 15, 2011.

  1. Jul 15, 2011 at 8:26 PM
    #1
    antf42080

    antf42080 [OP] Member

    Joined:
    Jul 15, 2011
    Member:
    #59958
    Messages:
    6
    Gender:
    Male
    northeast
    Vehicle:
    1995 taco 2.7 4wd
    Just purchased my first taco, and i've been doing some major work to it. it was in a car accident about 8 years ago, hit real hard in the front passenger side. (no frame damage tho) and ive repaired most of the body. i tried to fire her up but had no luck so i changed filters and what not but it still wont run. then after looking at the truck i noticed i had no MAF sensor on the intake. I'm assuming these trucks have one right?? (1995 2.7 4wd) if so theres none on ebay, would rather buy one used bc im on a budget. the link was the only one on ebay but it says for 6cylinder. any thoughts??

    http://cgi.ebay.com/ebaymotors/MASS...ptZMotorsQ5fCarQ5fTruckQ5fPartsQ5fAccessories
     
  2. Jul 17, 2011 at 1:14 PM
    #2
    antf42080

    antf42080 [OP] Member

    Joined:
    Jul 15, 2011
    Member:
    #59958
    Messages:
    6
    Gender:
    Male
    northeast
    Vehicle:
    1995 taco 2.7 4wd
    really nobody knows this? anyone own a 2.7 just look under your hood and find out. thanks
     
  3. Jul 17, 2011 at 1:23 PM
    #3
    UndefinedTaco

    UndefinedTaco I'll eat all your food.

    Joined:
    Jul 4, 2011
    Member:
    #59313
    Messages:
    2,026
    Gender:
    Male
    First Name:
    Justin
    Tracy, CA
    Vehicle:
    Toyota
    It's an 89 Toyota Pickup. I got some stuff done to it.. FJ axles going under it soon.
    Definetely won't fire up without it..100%


    1998 onward they used a 5 wire MAF sensor, that dropped into your intake tube..it had intake air temp sensor (heating element) inside the sensor itself actually.


    I know the 95.5-97s used a 3 wire MAF sensor...so the 1998 + will not work.


    Far as your ebay link, I'm not sure the 95.5-97s sensors are a velometer type sensor..so I couldn't tell you if it'd work.
     
  4. Jul 17, 2011 at 1:49 PM
    #4
    TMW

    TMW Well-Known Member

    Joined:
    Apr 21, 2011
    Member:
    #55300
    Messages:
    317
    Gender:
    Male
    First Name:
    Tom
    Bakersfield, CA
    Vehicle:
    04 Tacoma 4x4 SR5
    Light bar and bumper guard, 3/16 steel skid plates for engine, tranny and transfer box, OME 881 springs with 5100 shocks at mid clip. AAL in rear. Positraction rear diff.
    My Haynes manual says a 3 terminal and a 5 terminal was used on 94 4 cylinders and all 95 and later models (OBDll). Which ever connector in the area for the sensor will tell you which one you need.
     
  5. Jul 18, 2011 at 4:26 PM
    #5
    antf42080

    antf42080 [OP] Member

    Joined:
    Jul 15, 2011
    Member:
    #59958
    Messages:
    6
    Gender:
    Male
    northeast
    Vehicle:
    1995 taco 2.7 4wd
    i got it to start without maf sensor, but one popped up on ebay so im gonna buy it. its a 3 wire sensor. i'll put that on after the grill, bumper, fender, hood, valance, and lights are on. which should be by the end of this week. i'll let you guys know if its running any smoother with the new maf and post some before and after pics. Thanks for the help
     
To Top