1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

MESO Puddle Light build

Discussion in '3rd Gen. Tacomas (2016+)' started by MESO, Jan 12, 2019.

  1. Aug 24, 2019 at 4:49 PM
    #4041
    Georgeee28

    Georgeee28 Well-Known Member

    Joined:
    Mar 26, 2017
    Member:
    #214446
    Messages:
    112
    Gender:
    Male
    First Name:
    George
    Central Cal
    Vehicle:
    2017 White TRD Off-road 4x4
    Let me know if you find anything
     
  2. Aug 24, 2019 at 5:28 PM
    #4042
    birdieking33

    birdieking33 Well-Known Member

    Joined:
    Feb 16, 2019
    Member:
    #283291
    Messages:
    81
    Gender:
    Male
    First Name:
    Jon
    Lexington, SC
    Vehicle:
    2017 Toyota Tacoma Limited
    Have you double checked all of the connections?
     
  3. Aug 24, 2019 at 5:47 PM
    #4043
    Georgeee28

    Georgeee28 Well-Known Member

    Joined:
    Mar 26, 2017
    Member:
    #214446
    Messages:
    112
    Gender:
    Male
    First Name:
    George
    Central Cal
    Vehicle:
    2017 White TRD Off-road 4x4
    Yea, I checked everything and it all looked good. Does it matter which side the Y a pillar plug goes into? Does the driver side have to go on a certain side and vise versa? Unfortunately, I had to leave so couldn’t mess with it anymore, but hey one side looks good :thumbsup:
     
  4. Aug 24, 2019 at 6:00 PM
    #4044
    birdieking33

    birdieking33 Well-Known Member

    Joined:
    Feb 16, 2019
    Member:
    #283291
    Messages:
    81
    Gender:
    Male
    First Name:
    Jon
    Lexington, SC
    Vehicle:
    2017 Toyota Tacoma Limited
    I'm not 100% sure but I don't think it matters. Maybe I got lucky but I just plugged them in and the worked. On some of my connections I really had to add a little force to make sure they were connected. Especially the plug coming off the bulb. I also wrapped electrical tape around all connections where I could. Outside of that maybe a wire got damaged somewhere along the way. Good luck with it.
     
  5. Aug 24, 2019 at 6:24 PM
    #4045
    Georgeee28

    Georgeee28 Well-Known Member

    Joined:
    Mar 26, 2017
    Member:
    #214446
    Messages:
    112
    Gender:
    Male
    First Name:
    George
    Central Cal
    Vehicle:
    2017 White TRD Off-road 4x4
    Thanks hopefully I get it figured out tomorrow
     
    birdieking33 likes this.
  6. Aug 25, 2019 at 6:31 AM
    #4046
    Mountain2018

    Mountain2018 Well-Known Member

    Joined:
    May 13, 2018
    Member:
    #253346
    Messages:
    236
    Gender:
    Male
    Harpers Ferry/Leesburg VA
    Vehicle:
    2018 4x4 SB gray
    Sounds like one leg of your Y connector may be bad. He will get a new one out asap if he is aware. Mine will be in when i return from vacation.
     
    Georgeee28 and birdieking33 like this.
  7. Aug 25, 2019 at 7:16 AM
    #4047
    Rainer415

    Rainer415 Well-Known Member

    Joined:
    Jan 31, 2017
    Member:
    #209273
    Messages:
    67
    Gender:
    Male
    First Name:
    Rainer
    California
    Vehicle:
    2017 Tacoma TRD Sport Barcelona Red
    Camera mount
    Hey there, I’m here how may i help you?
     
  8. Aug 25, 2019 at 8:30 AM
    #4048
    Georgeee28

    Georgeee28 Well-Known Member

    Joined:
    Mar 26, 2017
    Member:
    #214446
    Messages:
    112
    Gender:
    Male
    First Name:
    George
    Central Cal
    Vehicle:
    2017 White TRD Off-road 4x4
    I’m going to switch them around today and see if that’s the problem. I probably should’ve done that when I had everything off:facepalm:
     
    Mountain2018 likes this.
  9. Aug 25, 2019 at 9:22 AM
    #4049
    Rainoffire

    Rainoffire Well-Known Member

    Joined:
    May 31, 2018
    Member:
    #255034
    Messages:
    1,199
    Gender:
    Male
    Vehicle:
    2017 QS DCLB TRD Sport

    Just finish installing Puddle lights equipped Power Folding Mirrors. With Ultimate LE Turn Signals!

    Sorry for the vertical vid...
     
  10. Aug 25, 2019 at 9:26 AM
    #4050
    Tacospike

    Tacospike Go Away

    Joined:
    Nov 19, 2018
    Member:
    #273198
    Messages:
    2,100
    Gender:
    Male
    Austin, TX
    Vehicle:
    2016 BLK TRD Sport DCSB
    Spiked hood
    That’s pretty sweet
     
    El Chivo Norteño and Rainoffire like this.
  11. Aug 25, 2019 at 9:32 AM
    #4051
    hdang

    hdang Active Member

    Joined:
    Feb 3, 2017
    Member:
    #209532
    Messages:
    25
    Gender:
    Male
    Vehicle:
    2017 White DCLB OR
    Tested everything and it looks like my driver side cable is the culprit.
     
    shakerhood and FishnTx like this.
  12. Aug 25, 2019 at 9:34 AM
    #4052
    Brostjoe

    Brostjoe Well-Known Member

    Joined:
    Oct 18, 2015
    Member:
    #166939
    Messages:
    517
    Gender:
    Male
    British Columbia
    Vehicle:
    2017 Limited DCLB
    I need to read up on the power mirror thread..
     
    El Chivo Norteño and Rainoffire like this.
  13. Aug 25, 2019 at 11:04 AM
    #4053
    Georgeee28

    Georgeee28 Well-Known Member

    Joined:
    Mar 26, 2017
    Member:
    #214446
    Messages:
    112
    Gender:
    Male
    First Name:
    George
    Central Cal
    Vehicle:
    2017 White TRD Off-road 4x4
    Thanks for letting me know. I’m about to check everything right now and I’m thinking mine might be the same
     
  14. Aug 25, 2019 at 11:48 AM
    #4054
    GrayTaco88

    GrayTaco88 New Member

    Joined:
    Feb 9, 2019
    Member:
    #282420
    Messages:
    4
    First Name:
    Josh
    Michigan
    Vehicle:
    2018 Tacoma TRD Sport
    I installed everything according to instructions and couldn't get the lights to work.

    Went back through and checked all connections and found that the driver's side had a loose connection so I fixed it and taped it. Now the driver's side works, but the passenger side still does not work.

    Also, now my dome light thinks the door is always open. It wont turn off unless I turn the dome light switch to the off position, even with all doors closed.

    Does anyone have any ideas or suggestions? I am pulling my hair out over here...

    Any help is greatly appreciated!
     
    Last edited: Aug 25, 2019
  15. Aug 25, 2019 at 12:00 PM
    #4055
    hdang

    hdang Active Member

    Joined:
    Feb 3, 2017
    Member:
    #209532
    Messages:
    25
    Gender:
    Male
    Vehicle:
    2017 White DCLB OR
    I had enough slack to connect the 10inch extension directly to the y connected on the harness and bypass the driver side cable. No need to pull the driver side cable or remove mirror to test.
     
  16. Aug 25, 2019 at 12:20 PM
    #4056
    Georgeee28

    Georgeee28 Well-Known Member

    Joined:
    Mar 26, 2017
    Member:
    #214446
    Messages:
    112
    Gender:
    Male
    First Name:
    George
    Central Cal
    Vehicle:
    2017 White TRD Off-road 4x4
    I just tested that way and it still doesn’t work, maybe it’s the light :notsure:
     
  17. Aug 25, 2019 at 1:10 PM
    #4057
    tac0will

    tac0will Active Member

    Joined:
    Mar 22, 2019
    Member:
    #287610
    Messages:
    44
    Gender:
    Male
    First Name:
    Will
    California
    Vehicle:
    Super White 19’ TRD Pro
    So last night , I was heading out for the night, forgot something from my house , so when I was coming out I couldn’t help it and snapped a pic, and admire it’s beauty ! This mod is so clean. Thanks again meso ! Just my two thoughts lol

    0949661E-E57F-4AB8-910E-D5B51305A087.jpg
     
  18. Aug 25, 2019 at 1:20 PM
    #4058
    tac0will

    tac0will Active Member

    Joined:
    Mar 22, 2019
    Member:
    #287610
    Messages:
    44
    Gender:
    Male
    First Name:
    Will
    California
    Vehicle:
    Super White 19’ TRD Pro
    Digging those folding mirrors
     
  19. Aug 25, 2019 at 1:59 PM
    #4059
    bmmjr

    bmmjr Well-Known Member

    Joined:
    Nov 3, 2018
    Member:
    #271480
    Messages:
    62
    First Name:
    Bryan
    NC
    Vehicle:
    2017 White DCSB TRDOR
    Got done with the install yesterday and everything was fine. Went for a drive today and my driver’s side switch won’t roll down the front passenger window. Any ideas?
     
  20. Aug 25, 2019 at 2:25 PM
    #4060
    Rainoffire

    Rainoffire Well-Known Member

    Joined:
    May 31, 2018
    Member:
    #255034
    Messages:
    1,199
    Gender:
    Male
    Vehicle:
    2017 QS DCLB TRD Sport
    Did you seat all connections in properly?
    I would try going around and see if anything is loose.
     
To Top