1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

miss fire P0301, HELP

Discussion in '4 Cylinder' started by silver tacoma, Dec 9, 2008.

  1. Dec 9, 2008 at 10:40 AM
    #1
    silver tacoma

    silver tacoma [OP] Member

    Joined:
    Dec 9, 2008
    Member:
    #11407
    Messages:
    13
    Gender:
    Male
    AZ
    Vehicle:
    dbl cab 2wheel drive prerunner
    I keep getting miss fire code changed the plugs comes back every 100miles the coil is good truck has 140k on it. anyone have this problem?
     
  2. Dec 9, 2008 at 4:06 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Welcome to Tacoma WOrld!
    Causes of misfire codes are as follows.
    1-bad spark plug, coil, or coil boot (carbon tracking around outside of spark plug, you can see this on the out side of the plug, replace the plug and coil boot if any tacking at all) also check that you have power to the coil, and that the ECU is grounding it.
    2-vacuum leak (look for any hoses or possible problems on the intake runner to the cyl. that is misfiring)
    3-injector (check that the injector is firing, you can use a stethoscope, if it is not clicking, you will need to check that you have power to the injector and that the ECU is grounding it)
    4-compression (perform a compression test on both cyls. on the side that has the misfire, if both are around the same, do a running compression test, remove the check valve from the compression gauge and install it and start the engine, you need to do it on another cyl. to compare readings if low you may have a sticking valve, broken valve spring, or such. I have started doing this test on most misfire problems)
    5- last is when it starts to get hard, I would recommend taking it to a pro at this point. They start looking at O2 readings, fuel trims and the like. flow testing injectors, and possible head gasket issues. carbon on the intake valves. I am sure I have missed a few things, but this is the way to go about troubleshooting misfires
     
  3. Dec 9, 2008 at 4:46 PM
    #3
    silver tacoma

    silver tacoma [OP] Member

    Joined:
    Dec 9, 2008
    Member:
    #11407
    Messages:
    13
    Gender:
    Male
    AZ
    Vehicle:
    dbl cab 2wheel drive prerunner
    thanks for the help I think I will try to replace just that one injector and see what happens
     
  4. Dec 23, 2008 at 9:55 AM
    #4
    piratesvarsity22

    piratesvarsity22 SickTacoFoSho

    Joined:
    Sep 10, 2008
    Member:
    #9136
    Messages:
    59
    Gender:
    Male
    florida
    Vehicle:
    1995 Tacoma
    smoked taillights, thrush glasspack muffler, hollowed out cat. K&n intake,2 12' infinity subwoofers. sony xplod cd player
    sounds like a 2nd ignition problem for sure... did u get it fixed yet ? if so let me know


    *ed
     
  5. Dec 29, 2008 at 6:56 PM
    #5
    silver tacoma

    silver tacoma [OP] Member

    Joined:
    Dec 9, 2008
    Member:
    #11407
    Messages:
    13
    Gender:
    Male
    AZ
    Vehicle:
    dbl cab 2wheel drive prerunner
    still not fixed got a 300 code, it only runs bad when it is cold at idel and when it is warm at idel at 1500 rpm very smooth when warm. When I come to a stop runs good for about 7 to 10 secunds then the idel will drop about 200 rpm then run rough???
     
To Top