1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

MK III issues

Discussion in 'Guns & Hunting' started by airsoft_warrior, Apr 21, 2010.

  1. Apr 21, 2010 at 3:29 PM
    #1
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    My Mk III is having feeding and ejection issues even after I cleaned it thoroughly. Any Ideas?
     
  2. Apr 21, 2010 at 4:55 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,192
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Check for a build up of crap under the extractor.
     
  3. Apr 22, 2010 at 9:31 AM
    #3
    Packman73

    Packman73 ^^^^ 3%er ^^^^

    Joined:
    Aug 24, 2008
    Member:
    #8741
    Messages:
    8,372
    Gender:
    Male
    First Name:
    Matt
    The free state of Arizona
    Vehicle:
    2007 TRD Off Road
    Bilstein 5100's (front set @ .85"), OME 885's, chris4x4 anti-Taco-lean spacer on driver's side, Total Chaos UCAs, Rear Leaf Spring TSB, Toytec AALs, Black FJ TT Wheels, BFG 285/75R 16 AT Tires, TRD Exhaust, Viper Alarm, Fog Light Mod, De-badged, Blue LED Dome Light, EZ Clamped Tailgate, Wet Okoles, Satoshi Grill, 5% Tint, Engine Tick Fix, Black Rear Bumper, Black Center Valence, Exhaust Cut At Axle, Thanks for all the help chris4x4!
    x2

    Also check your magazines for feeding issues. If it's not the magazine(s), send it to back to Ruger.
     
  4. Apr 22, 2010 at 9:32 AM
    #4
    JESSMAN

    JESSMAN Well-Known Member

    Joined:
    Mar 22, 2010
    Member:
    #33760
    Messages:
    190
    Gender:
    Male
    First Name:
    Jesse
    Reno Nv
    Vehicle:
    08 tacoma
    ARB BUMPER WARN M 8000 LIGHT FORCE LIGHTS Bill 5100 DOWNY FRONT LIFT RANCHO OLD MAN E REAR and JERRY CAN IN THE BED
    :cool:Call Ruger or go see a gun smith!! I love my MK III but it's a pain in the ass to work on!!!!
     
  5. Apr 22, 2010 at 9:34 AM
    #5
    bigburrito

    bigburrito Local Man

    Joined:
    Mar 13, 2009
    Member:
    #14660
    Messages:
    557
    Gender:
    Male
    DuPage County
    Vehicle:
    '09 TRD OR
    Demello sliders, fog lights anytime, 265/75R16 Duratracs, 60" HiLift, VIAIR OBA 2.5 gallon tank, FM Super 44, TSB springs, 5100s at .85, bent tailgate
    what kind of ammo are you using? my mk3 will fte when im using the cheap-o ammo. some rounds dont get as much powder as the others, and they dont have enough umph to cycle the action properly. try some good quality ammo and see if it improves.
     
  6. Apr 22, 2010 at 9:36 AM
    #6
    bigburrito

    bigburrito Local Man

    Joined:
    Mar 13, 2009
    Member:
    #14660
    Messages:
    557
    Gender:
    Male
    DuPage County
    Vehicle:
    '09 TRD OR
    Demello sliders, fog lights anytime, 265/75R16 Duratracs, 60" HiLift, VIAIR OBA 2.5 gallon tank, FM Super 44, TSB springs, 5100s at .85, bent tailgate
    amen to that. its one of the most difficult guns to disassemble/ reassemble.

    but it shoots great!
     
  7. Apr 22, 2010 at 2:59 PM
    #7
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    I have tried every kind of ammo. All of it does it. Even the expensive hunting CCI

    Called ruger said that I would have to ship it out and they would bill me for it when its finished. they couldnt even give me a ballpark.

    The Magazines (all three of them) apparently dont hold the bullet at a high enough angle and it hits the loading ramp when chambering causing the gun to jam. As for ejection. It does work a little better now that it is cleaned and heavily oiled.
     
  8. Apr 23, 2010 at 9:24 AM
    #8
    thinkingman

    thinkingman Well-Known Member

    Joined:
    Apr 14, 2008
    Member:
    #5971
    Messages:
    1,091
    redmond WA
    Vehicle:
    2006 dbl cab 4wd 6sp
    Foglights are for fog, not oncoming traffic!
    Was there feed issues before you cleaned it?

    Did you take the upper receiver off when you cleaned it?
    Getting the upper positioned properly for feeding is a long and frustrating process.
    The sharp feed ramp has to be distanced just perfectly from the magazine.
    Also, my Rugers didn't like hollowpoints...the flat profile of the bullet caught the feed ramp at just the wrong angle.
    I don't think a trip back to Ruger is necessary.
    Just didddle with it and adjust the spacing of the upper and lower.
     
  9. Apr 23, 2010 at 6:41 PM
    #9
    ImthePrez

    ImthePrez Well-Known Member

    Joined:
    Apr 16, 2010
    Member:
    #35390
    Messages:
    203
    Gender:
    Male
    TN
    Vehicle:
    06 Prerunner TRD
    Try different mags
     
  10. Apr 23, 2010 at 7:13 PM
    #10
    Incognito

    Incognito μολὼν λαβέ

    Joined:
    May 25, 2009
    Member:
    #17626
    Messages:
    13,625
    Gender:
    Male
    First Name:
    Colton
    VA
    Vehicle:
    2012 Pyrite AC TRD OR
    See Build thread
    This is what happened with my MKII... One would jam every magazine, it was ridiculous. I started using better ammo and the problem resolved itself.
     
  11. Apr 25, 2010 at 7:08 PM
    #11
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    I did try this. It got better but didnt resolve it.

    Bought a couple. Didnt workr

    Yes it did feed poorly before cleaning. But I will take a look at it and see what may be able to be done with it. BTW. I LOVE MY XD. none of these problems
     
  12. Jul 27, 2010 at 8:58 AM
    #12
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    Took it to the gunsmith. He worked with it and said that the feeding ramp was too short. so that after the first bullet went in the second never sits as high as the first one. Causing it to jam up. Even split bullets. He tried everything. He sent it back and they replaced the ramp, ejector, bolt catch, safety, trigger, a bunch of stuff. Fired a couple hundred rounds through it and sent it back. Works perfectly now! Love it!
     
To Top