1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

My 4bander makes an annoying rattleing sound.

Discussion in '4 Cylinder' started by Grant!, Sep 12, 2010.

  1. Sep 12, 2010 at 5:04 PM
    #1
    Grant!

    Grant! [OP] Member

    Joined:
    Aug 20, 2010
    Member:
    #41996
    Messages:
    8
    Gender:
    Male
    First Name:
    Grant
    Folsom California
    Vehicle:
    04 PreRuner SR5 2.74cill
    As the title says my 4banger makes an annoying rattleing sound when its stalling. Anyone have any idea what it could be?
     
  2. Sep 12, 2010 at 5:13 PM
    #2
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,059
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    Let me guess it only does it when the a/c is on and your not on the clutch?
     
  3. Sep 12, 2010 at 5:27 PM
    #3
    Yota1

    Yota1 Well-Known Member

    Joined:
    May 29, 2009
    Member:
    #17777
    Messages:
    291
    Gender:
    Male
    mine does that to, any ideas what it could be, almost sounds like a heat shield
     
  4. Sep 12, 2010 at 6:39 PM
    #4
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,059
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    well for the 05+ it might be a throw out bearing...im not sure though. Everytime I have gone to the dealer to ask they "dont" hear it when its blatant as hell
     
  5. Sep 12, 2010 at 6:50 PM
    #5
    tacoma92

    tacoma92 Black Hole Sun

    Joined:
    Jul 15, 2010
    Member:
    #40240
    Messages:
    370
    Gender:
    Male
    First Name:
    Forrest
    Gulf Shores, Alabama
    Vehicle:
    09 SR5 Toyota Tacoma
    Well after I changed out my timing belt I don't hear the noise anymore so idk tht mite b it
     
  6. Sep 12, 2010 at 6:58 PM
    #6
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,059
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    hmm for you that makes sense but I have had this since I drove off the lot brand new :(
     
  7. Sep 13, 2010 at 4:24 PM
    #7
    old dad

    old dad Well-Known Member

    Joined:
    May 9, 2010
    Member:
    #36809
    Messages:
    85
    Gender:
    Male
    First Name:
    mark
    sc
    Vehicle:
    tacoma pickup
    n/a
    there is a thread going on it on the 2nd gen side,, same issue

    mark
     
  8. Sep 13, 2010 at 4:59 PM
    #8
    Grant!

    Grant! [OP] Member

    Joined:
    Aug 20, 2010
    Member:
    #41996
    Messages:
    8
    Gender:
    Male
    First Name:
    Grant
    Folsom California
    Vehicle:
    04 PreRuner SR5 2.74cill
    mines an 04... I just went out and started it and it's not makeing the noise. I turned the AC on and still didnt make the noise. And mine's an automatic.
     
  9. Sep 13, 2010 at 5:09 PM
    #9
    AlexXx

    AlexXx Well-Known Member

    Joined:
    Aug 10, 2010
    Member:
    #41524
    Messages:
    65
    Gender:
    Male
    Louisiana
    Vehicle:
    99 taco
    All-Pro 3" Rear kit, Camburg Coilovers, 1" RB BL, 285/75/16's, and rear Lock Right locker Collecting 4wd parts to convert.
    Check to see if the clap for the tail pipe, right above the pass. A-arm came loose. Mine came loose and it just sits on the pipe and rattles at stalling.
     
  10. Sep 16, 2010 at 11:43 AM
    #10
    brelandt

    brelandt Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    Mine did the same thing. It was the clamp. The bolt backed out and the clamp slides down to the O2 and just vibrates and rattles against the pipe. Just reinstall it to the black bracket that's bolted to the trans bell housing and tighten it good and keep checking it. mine did this before just 2 months after I bought it but the dealer repaired it. Then it happened again last month.
     
  11. Sep 17, 2010 at 4:14 AM
    #11
    Kelson

    Kelson My Truck is Cuter than Yours

    Joined:
    May 13, 2008
    Member:
    #6597
    Messages:
    4,505
    Gender:
    Male
    First Name:
    Kelson
    Honolulu, Hawaii
    Vehicle:
    08 5-Lug Reg. Cab SR5
    SR5 Exterior/Interior (Color matched Front Bumper, Chrome Grille Surround and Chrome Rear Bumper/Silver Scoshe Dash Kit, A/C Bezel, A/C Vent Surround) LED license plate and white interior lights, Wet Okole Seat Covers, iPad in-Dash, JL CL-RLC, JL 13TW5 sub, JL 500/1 Slash V1 amp, JL XR 6.5 Components, Rockford Fosgate 6X9s in Boxes Front XRunner Coils, DJM Control Arms and Rear 4X4 Leafs, Custom 2" Angled Streetacos.com Blocks Front XR Bilstien Struts and Rear XR Bilstien Shocks, CravenSpeen Antennae, RX-8 Rims w/ Fronts:235/40-R18 Sumitomo HTR Rears:245/40-R18 Goodyear Eagle GT, 35% Tint front windows, OEM Sliding Privacy Glass w/ 5% Ceramic Tint, Flowmaster Super 44 dumped before the axle, URD Short Throw Shifter, Door Sill Protectors, Door Edge Guards, OEM Sport Pedals,The Retrofit Source Morimoto Mini D2S Stage III 35W 5K HID Headlights, OEM Fog Lights w/ piss yellow bulbs, OEM Cruise Control, Porsche 944 Bucket Seats, BeefedTaco Skid Plate, Whale
    you have a v6....
     
  12. Sep 18, 2010 at 4:01 PM
    #12
    chriss

    chriss Well-Known Member

    Joined:
    Jun 1, 2010
    Member:
    #38206
    Messages:
    100
    Gender:
    Male
    First Name:
    chris
    What do you mean by "stalling"? Like heavely loaded at a low RPM and just about to die? Maybe valves.
     
To Top