1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

My AAL broke!!

Discussion in 'Southern California' started by 4X4_TRD, Sep 23, 2010.

  1. Sep 23, 2010 at 5:45 PM
    #1
    4X4_TRD

    4X4_TRD [OP] Well-Known Member

    Joined:
    Jun 17, 2009
    Member:
    #18577
    Messages:
    322
    Gender:
    Male
    First Name:
    Justin
    San Diego, CA
    Vehicle:
    '03 Jeep RUBICON
    No front sway bar (does that count?)
    :eek: Yep, just as the title says. Was driving yesterday and when I went through a slight dip in the road I heard the snap. Wasn't going more than 15 MPH. Anyone else have this problem? I honestly haven't ever seen or heard of this before. I PM'd Toytec and I'll keep you posted on the outcome.
     
  2. Sep 23, 2010 at 6:07 PM
    #2
    battlescars

    battlescars Professionull1

    Joined:
    Jan 5, 2009
    Member:
    #12256
    Messages:
    2,890
    Gender:
    Male
    First Name:
    Alex
    Escondido, CA
    Vehicle:
    2003 5-lug Prerunner
    Couple shocks, some old tires, and a bad paint job
    It'll happen but quite rarely. Every once in a while there is a manufacturer error. Just a question though, do you have lift blocks?
     
  3. Sep 23, 2010 at 6:11 PM
    #3
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,566
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    OP how long have you had the AAL installed?
     
  4. Sep 23, 2010 at 6:23 PM
    #4
    4X4_TRD

    4X4_TRD [OP] Well-Known Member

    Joined:
    Jun 17, 2009
    Member:
    #18577
    Messages:
    322
    Gender:
    Male
    First Name:
    Justin
    San Diego, CA
    Vehicle:
    '03 Jeep RUBICON
    No front sway bar (does that count?)
    No I don't have lift blocks. Only installed the AAL and wedge for the drive shaft angle.

    Slightly over a year. I installed it around May/June '09.
     
  5. Sep 23, 2010 at 6:25 PM
    #5
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,566
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    Hope they have a warranty for it. If not then time to upgrade to new leaf packs right?:D
     
  6. Sep 24, 2010 at 9:46 PM
    #6
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    23,950
    Gender:
    Male
    First Name:
    Doug
    Lakeside, Ca / Gardnerville, Nevada
    Vehicle:
    No Truck..well, maybe
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now


    Nice Justin, I just now replaced my front axles & you break the rear

    How we gonna trail now ?? :D
     
  7. Sep 25, 2010 at 7:37 AM
    #7
    4X4_TRD

    4X4_TRD [OP] Well-Known Member

    Joined:
    Jun 17, 2009
    Member:
    #18577
    Messages:
    322
    Gender:
    Male
    First Name:
    Justin
    San Diego, CA
    Vehicle:
    '03 Jeep RUBICON
    No front sway bar (does that count?)

    Right! :D Haha I still have the Jeep. I'll take that out if I have to. What? No trail run this weekend?
     
  8. Sep 25, 2010 at 10:51 AM
    #8
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    23,950
    Gender:
    Male
    First Name:
    Doug
    Lakeside, Ca / Gardnerville, Nevada
    Vehicle:
    No Truck..well, maybe
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now

    There was a short thread on a run but I don't feel like bouncing around in the heat today or tomorrow (sunday supposed to be hotter) I'll cool my jets & work on the bumper thing..


    [​IMG]
     
  9. Sep 25, 2010 at 11:04 AM
    #9
    4X4_TRD

    4X4_TRD [OP] Well-Known Member

    Joined:
    Jun 17, 2009
    Member:
    #18577
    Messages:
    322
    Gender:
    Male
    First Name:
    Justin
    San Diego, CA
    Vehicle:
    '03 Jeep RUBICON
    No front sway bar (does that count?)
    That thing is looking pretty sick. I like it. Oh, and I'm going to give you rep for having black wheels finally. :D
     
  10. Sep 25, 2010 at 11:48 AM
    #10
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    23,950
    Gender:
    Male
    First Name:
    Doug
    Lakeside, Ca / Gardnerville, Nevada
    Vehicle:
    No Truck..well, maybe
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    Thanks buddy ....:D
     
To Top