1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

My Transmission Feels Terrible

Discussion in '1st Gen. Tacomas' started by CarlosinFL, May 14, 2013.

  1. May 14, 2013 at 11:12 AM
    #1
    CarlosinFL

    CarlosinFL [OP] Mildly-Attractive

    Joined:
    May 30, 2010
    Member:
    #38046
    Messages:
    29
    Gender:
    Male
    First Name:
    Carlos
    Orlando, FL
    Vehicle:
    02 PreRunner SR5
    My 2002 Tacoma single cab truck for some time now has had a weird jolting when you give it some gas on the highway. It's gotten way worse in the past month and now I have a check engine light showing on my instrument gauges. I really notice my MPG is totally hideous and when I give my truck gas from a stop or if I need to get some torque, it's very very laggy and jumpy.

    Does anyone know what could be causing this based on my description above? I have not taken the truck in yet to have the CEL code read but in my experience, they're generally very generic anyways. Anyone know or have any suggestions?

    I'm just over 150.5K miles on everything.
     
  2. May 14, 2013 at 12:01 PM
    #2
    127.0.0.1

    127.0.0.1 AKA ::1

    Joined:
    Dec 24, 2012
    Member:
    #93641
    Messages:
    1,572
    Gender:
    Male
    /etc/hosts
    Vehicle:
    2013 NBM AC 4.0 4x4 Auto OR
    nope, get the code. that is the starting point
     
  3. May 14, 2013 at 12:05 PM
    #3
    Germ

    Germ Master Navigator/Zipper Operator

    Joined:
    Feb 7, 2013
    Member:
    #97026
    Messages:
    1,046
    Gender:
    Male
    Arizona
    Vehicle:
    2013 TRD OR DCSB
    20" OKLED Light Bar mounted to BAMF behind grill mount, KM Fab ifs and belly skid, exhaust relocate, Removed mud flaps, Added bed d-rings. More to come.
    torque converter? ^x2 though.
     
  4. May 14, 2013 at 2:04 PM
    #4
    127.0.0.1

    127.0.0.1 AKA ::1

    Joined:
    Dec 24, 2012
    Member:
    #93641
    Messages:
    1,572
    Gender:
    Male
    /etc/hosts
    Vehicle:
    2013 NBM AC 4.0 4x4 Auto OR
    with no code, may as well ask this:

    (this is the cheapest, easiest, and very likely solvable problem that can cause the
    described symptoms)

    when is the last time you got a can of maf cleaner
    and blasted the maf sparkling clean, reset ecu, and put maf back in ?

    ---
    anyhow, your truck blew a code and despite your experiences, all OBDII codes matter a LOT
     
To Top