1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

My truck and all its problems....

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Khaos, Feb 17, 2010.

  1. Feb 17, 2010 at 2:12 PM
    #1
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    I bought my truck in Dec. 2007 with 27K miles on it. I am the third owner, the second owner bought my truck as a certified pre-owned and then sold it it a few months later.

    As of late my truck just seems to be full of weird noises and issues and I'm quite honestly getting pretty damn fed up. Thinking about just trading it for another Tacoma. I'm taking it to Toyota this weekend (had to secure a car to take me to work before this) and I'm gonna have them check it out.

    These are the problems I'm having:


    • Rattle/Grind noise when cruising/decelerating. This is my newest noise and just started today after my truck was parked for 3 hours at school. It's coming from the front right wheel well and it's pretty damn loud.
    • The loud squeel/squeek I posted in video earlier this month. It went away for a week or two, but now it's back yet slightyl different
      • goes away with no pressure on gas pedal
      • doesn't make sound when rev'd in park or neutral
      • usually makes this sound from 1200-1800RPM
      • above 25mph
      • doesn't always do it, however I can't find any circumstances to force it to make the noise
      • can be barely audible to extremely loud, with no reason I can figure to cause it
    • vibration from 10-20MPH
    • Occasionally I hear a thud when letting off the gas when going under roughly 40MPH
    Those are the things I can't explain. I know it needs an alignment and regular service, but these other things I simply just think WTF. It of course has other odd rattles in the interior but I've attributed that to the mass of random crap that has accumulated in my backseat.

    I'm not interested in starting a bash on Toyota thread. I've grown up with Toyota's and even if I got rid of this truck, I'd probably end up buying another Tacoma or a Tundra. I'm hoping someone has an idea as to WTF is going on with my truck. I don't have a place to work on it, nor do I have the tools or general knowledge to try and fix it myself.
     
  2. Feb 17, 2010 at 2:19 PM
    #2
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    Alex....sounds like you got bad wheel bearing up front......and maybe the torque converter isnt working properly.

    anyway.........since you've brought it up before.......get rid of it....trade it for another tacoma.
     
  3. Feb 17, 2010 at 2:26 PM
    #3
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    Nostalgia and taxes keep me from wanting to get rid of it. If I can get my truck fixed up and running how I think it should, I want to keep it. I love the truck but sometimes I get frustrated with it.
     
  4. Feb 17, 2010 at 2:30 PM
    #4
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    it can be fixed........its just a matter of them finding out what the hell it is. everything is frustrating once in a while. im frustrated with my truck for now myself........but it'll get squared away and be good to go.
     
  5. Feb 17, 2010 at 2:49 PM
    #5
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    Check your U-joints - driveshaft thats what you would get with U-joint or driveshaft slip Its TRD truck so expect somebody went mudding with it
    Not a big deal needs grease or new ujoint. :D
     
  6. Feb 17, 2010 at 2:53 PM
    #6
    Asgard

    Asgard Well-Known Member

    Joined:
    Apr 19, 2008
    Member:
    #6078
    Messages:
    1,093
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    06 PreRunner DC SR5 w/LSD
    X2
    What problems ? Seems to me you just have one, a bad u-joint. Should be an easy fix. Also check your rear transmission seal, the PreRunner's tend to leak but there is a TSB. The PreRunner's u-joints cannot be greased, they are sealed so replacement is the only option. I replaced my front u-joint at 50k miles. Good Luck and hope everything works out.
     
  7. Feb 17, 2010 at 3:05 PM
    #7
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    Yep U-joints are like hot girl... both needs to be greased often and with plenty :D
     
  8. Feb 17, 2010 at 3:10 PM
    #8
    Asgard

    Asgard Well-Known Member

    Joined:
    Apr 19, 2008
    Member:
    #6078
    Messages:
    1,093
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    06 PreRunner DC SR5 w/LSD
    BTW the u-joint can fail and your driveshaft will end up on the pavement, so get it fixed ASAP. Sounds to me like you've been driving around with a bad u-joint for quite some time.
     
  9. Feb 17, 2010 at 3:17 PM
    #9
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    It's been making that sound on and off for roughly 800 miles. If its really just the U joint then thats damn good news.
     
  10. Feb 17, 2010 at 3:21 PM
    #10
    MyToyTaco

    MyToyTaco ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    x2 on the wheel bearing, oh, and umm...




    Maybe take better care of her, and she'll take better care of you :p
     
  11. Feb 17, 2010 at 3:31 PM
    #11
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    The sad thing is, I haven't even taken it off road in maybe a year.

    Towing package was done by previous owner, dented bedside by a less than careless driver at Walmart (found more scrapes today on the opposite side, guessing someone scarped into me when I was at work last night), and the hood and whatnot happened somehow when my truck was parked at Jax beach for the 4th of July. This trucks luck is pretty rough.
     
  12. Feb 17, 2010 at 3:41 PM
    #12
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    When was the last time you greased u-joints ?

    EDIT: One of them may be u-joint other could be wheel bearing (two separate issues)
     
  13. Feb 17, 2010 at 4:28 PM
    #13
    Fortech

    Fortech Well-Known Member

    Joined:
    Mar 31, 2008
    Member:
    #5636
    Messages:
    878
    Gender:
    Male
    CANADA
    Vehicle:
    2005 Toyota Tacoma TRD OR
    Bilstein 5100's, rear TSB, Firestone bags
    Its a Pre Runner - as stated above, the u joints don't have zerks for greasing. Only 4x4 Tacomas have zerks.
     
  14. Feb 17, 2010 at 5:37 PM
    #14
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    Just drove it again to Walmart (needed razors and food), sounds where half as loud as they where on the way home from class. it's a surprise everytime I drive the truck!
     
  15. Feb 17, 2010 at 6:01 PM
    #15
    cjh

    cjh Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30772
    Messages:
    65
    Gender:
    Male
    Vehicle:
    10 doublecab
    Have no idea if this is relavent, but on my old 01 I had a squeaking noise that was intermittant. Would come and go with no reason at all. Ended up being the slip yoke on the rear drive shaft needed grease. After a liberal amount of grease, no more squeaking. Not sure if this helps, but worth a shot. Just re-read your post and saw you said it is coming from front end. I guess that would rule out the rear drive shaft. Sorry.
     
  16. Feb 25, 2010 at 10:34 AM
    #16
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    Well guys, dropped the truck off at 11:45 @ Toyota this morning.

    Within an hour my service adviser (worked with for years, with 3 different vehicles, I know he's a good guy), he called back about 20 minutes ago and said that all three of my U Joints are trashed. They're saying its from my tire size.
     
  17. Feb 25, 2010 at 10:36 AM
    #17
    MyToyTaco

    MyToyTaco ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
  18. Feb 25, 2010 at 10:46 AM
    #18
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    No way in hell, asked them if they can replace them with ones that have grease zerks so you can lube them
     
  19. Feb 25, 2010 at 2:30 PM
    #19
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    Well, my truck has gotten its 60K service, new U Joints and they say the rattle I was hearing as a loose intake bolt, which was something I had suspected. That's all they found wrong with the truck...

    Waiting for my Dad to get off work so I can hitch a ride up to Toyota and pick the Taco up...

    A day without my Taco sucked.
     
  20. Feb 25, 2010 at 5:20 PM
    #20
    Khaos

    Khaos [OP] Big Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,495
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    Got the truck back.... Fucking happy as all hell right now. Not only is it running perfectly, its clean.

    Also may be getting a job @ Toyota.... :D
     
To Top