1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Nate's build

Discussion in '2nd Gen. Builds (2005-2015)' started by Nate87, Oct 2, 2014.

  1. Jan 8, 2019 at 7:12 AM
    #601
    Ras61

    Ras61 Well-Known Member

    Joined:
    Nov 18, 2014
    Member:
    #142609
    Messages:
    382
    Gender:
    Male
    Arlington VA
    Vehicle:
    '12 4wd TRD Sport Dbl Cab
    Icons front, Bilstiens 5125 rear, 35/12.5/17 MT/Rs and some trimming
    Hi Nate,

    Amazing build - both of them. Would you mind sharing a pic of your cab mount?

    I've been running 35s for a while now, and keep chopping it back, but keep getting a bit of rubbing at lock and flex. I'm down to shaving bits off the bolt/plate the mount sits on. I'm running 3-ish caster, and can't get any more out of my JBAs. Do you have the same problem? I'm thinking of doing the relocate.

    Thanks!
     
  2. Feb 4, 2020 at 9:44 AM
    #602
    Nate87

    Nate87 [OP] Well-Known Member

    Joined:
    May 7, 2013
    Member:
    #103748
    Messages:
    751
    Gender:
    Male
    First Name:
    Nate
    CONUS
    Vehicle:
    2013 AC TRD OR
    I know this is a REALLY late response, but what is the back spacing of your wheels? That could be a major factor. I will post up a photo soon so you can reference.
     
To Top