1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need CEL gone

Discussion in 'Performance and Tuning' started by wannatoy570, Jan 20, 2013.

  1. Jan 20, 2013 at 6:16 AM
    #1
    wannatoy570

    wannatoy570 [OP] Well-Known Member

    Joined:
    Mar 29, 2011
    Member:
    #53956
    Messages:
    251
    Gender:
    Male
    First Name:
    Dave
    Lock Haven, PA
    Vehicle:
    05 Toyota Tacoma SR5
    I installed the doug thorley y pipe a few months ago and my check engine light has been on since. I'm going to be trading my truck in soon and would like to get it turned off before then. Any Ideas?
     
  2. Jan 22, 2013 at 1:48 AM
    #2
    Mr. Biscuits

    Mr. Biscuits Salesman by trade, Gentleman by habit

    Joined:
    May 6, 2012
    Member:
    #78316
    Messages:
    1,572
    Gender:
    Male
    First Name:
    Brennen J
    Bakersfield
    Vehicle:
    2000 PreRunner TRD V6
    -Bilstein 5100/ Eibach 3" lift -Custom 2" lift rear leaf pack -Crystal clear headlight housings -updated (01-04) rear tail lights -custom front tube bumper -custom rear tube bumper -Deckplate mod -Kenwood Headunit -Pioneer Speakers -black door handles -Debadged, rebadged black -Ultraguage
    clear the system by disconnecting the battery and see if it reappears. if it continues to light up then take it to a shop that has a code reader and see what code the CEL is throwing...or buy one. comes in handy in times like this
     
  3. Jan 22, 2013 at 4:54 AM
    #3
    ToyotaTacoma4Ever

    ToyotaTacoma4Ever Get Boosted

    Joined:
    Sep 26, 2012
    Member:
    #87783
    Messages:
    428
    Gender:
    Male
    First Name:
    Eric
    Alberta
    Vehicle:
    Supercharged Tacoma Sport
    Check Out The S/C Build
    Did you put back in the rear O2 sensors? If you didn't that would be a reason why your having a CEL since you've put them on.

    I don't have Doug Thorley y-pipe, instead I have URD's y-pipe, you'll need the O2 simulator (from URD) since the y-pipe gets rid of your cats

    Another option would be if you still have the stock y-pipe just switch it back and the CEL should dissapear
     
To Top