1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need help fast!

Discussion in 'Performance and Tuning' started by ProForce, Mar 17, 2011.

  1. Mar 17, 2011 at 5:07 PM
    #1
    ProForce

    ProForce [OP] IG @proforce1

    Joined:
    Oct 12, 2009
    Member:
    #24205
    Messages:
    6,053
    Gender:
    Male
    First Name:
    Anthony
    SoCal-Ontario
    Vehicle:
    09 MGM TRD Sport DCSB 4.0 Auto 2wd
    Too many to list. See build page. Link in signature
    I know that people are constantly opening threads about their mpg and it gets annoying because there are so many factors but situation is different. Please help me. I have an 09' double cab trd sport and just broke 20k miles last week. I have been running mobile 1 synthetic since day 1, I have all stock tires/rims, no engine mods other than my aftermarket muffler but that has also been there since the beginning. My driving habits have not changed and I still maintain about 70% highway 30% city driving. Never punch it hard, always doing the speed limit, and always running 87 octane. Nothing has changed in over a year of driving. I just did my oil change less than 1k miles ago. Tire pressure looks good but I haven't actually checked it. I used to average 16-20mpg depending on driving habits... All of a sudden I'm lucky to get 12 and NOTHING HAS CHANGED! I just threw a can of seafoam in the tank and some in the crankcase to maybe clean the injectors but I won't know for a few days the results. Any ideas please help. Still under full warranty do you think the dealer will help? Thanks guys
     
  2. Mar 22, 2011 at 6:17 AM
    #2
    KevLot17

    KevLot17 Well-Known Member

    Joined:
    Jun 30, 2010
    Member:
    #39621
    Messages:
    694
    Gender:
    Male
    First Name:
    Kevin
    Pennsylvania
    Vehicle:
    '10 Blacked Out TRD Sport
    Debadged, Toytec Ultimate Lift, Banks Monster Exhaust, AFE Pro Dry filter, Black Grillecraft grille, Flat Black background headlights, Red Blinkers and markers with alternating turn signal mod, Krypton Bulbs 6000K Headlights and Fogs, Fog Light anytime Mod, LED interior lights with map light mod, AVS Black Taillight Covers, Tinted Windows, WeatherTech Digital floor liners.
    Has anything changed?
    (EDIT) Since you posted.
     
  3. Mar 22, 2011 at 6:31 AM
    #3
    TexAggie

    TexAggie Well-Known Member

    Joined:
    Dec 16, 2010
    Member:
    #47773
    Messages:
    1,428
    Gender:
    Male
    First Name:
    Eric
    Odessa, TX
    Vehicle:
    17
    OME Lift
    Bad gas? I would try going to get gas from different places or higher octane to see if that makes a difference.
     
  4. Mar 22, 2011 at 6:43 AM
    #4
    KevLot17

    KevLot17 Well-Known Member

    Joined:
    Jun 30, 2010
    Member:
    #39621
    Messages:
    694
    Gender:
    Male
    First Name:
    Kevin
    Pennsylvania
    Vehicle:
    '10 Blacked Out TRD Sport
    Debadged, Toytec Ultimate Lift, Banks Monster Exhaust, AFE Pro Dry filter, Black Grillecraft grille, Flat Black background headlights, Red Blinkers and markers with alternating turn signal mod, Krypton Bulbs 6000K Headlights and Fogs, Fog Light anytime Mod, LED interior lights with map light mod, AVS Black Taillight Covers, Tinted Windows, WeatherTech Digital floor liners.
    I have switched to 91 octane.. i now get approx 1.5 mpg better, and save 1 cent per mile:D.. which is alot if you add it up overtime..(im also the guy that picks up pennies on the ground wherever i see them ... haha jk.. but seriously.....)
     
To Top