1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

need help with 96 grand Cherokee

Discussion in 'General Automotive' started by mntbiker2008, Dec 30, 2010.

  1. Dec 30, 2010 at 1:46 PM
    #1
    mntbiker2008

    mntbiker2008 [OP] First I derp.. then I herp

    Joined:
    Dec 18, 2008
    Member:
    #11718
    Messages:
    8,172
    Gender:
    Male
    First Name:
    Aaron
    Cincinnati, OH
    Vehicle:
    93 Pick up 4x4 (sold), 10' Mazda 3
    My friend has a 96 Grand Cherokee Laredo 6 cyl. that is having trouble (surprise surprise). He has to give it some gas to start up and has to hold the throttle open when it does start otherwise the engine will die. We just cleaned the IAC today (have heard that sometimes helps) but it was a no go. Anybody know what it could possibly be? I am going to try to run my scanguage on it tomorrow to see if it picks up any codes.
    He said the Jeep sat for a while so he put fresh gas in it and put one of those bottles of injector cleaner in as well. He said on his way back home (he lives in S.C.) he put another bottle of the cleaner in also with another fill up.

    my only guess is fuel pump, or some sensor. :confused:

    hope this helps. any ideas would help!
     
  2. Dec 30, 2010 at 1:49 PM
    #2
    tanzak88

    tanzak88 Well-Known Member

    Joined:
    Oct 3, 2010
    Member:
    #44180
    Messages:
    796
    Gender:
    Male
    First Name:
    Tanner
    BC, C-eh-N-eh-D-eh
    Mass Air Flow sensor?
     
  3. Dec 30, 2010 at 1:52 PM
    #3
    Surfinpig

    Surfinpig Well-Known Member

    Joined:
    Apr 6, 2010
    Member:
    #34700
    Messages:
    141
    Gender:
    Male
    First Name:
    Eric
    Philadelphia, PA
    Vehicle:
    10 2.7 4x4 SR5
    Avid Offroad light bar, trd skid plate, are cap, billy 5100's
    is it the inline 6? my buddy had a bad alternator and it did the same thing.. not enough juice to idle.
     
  4. Dec 31, 2010 at 5:52 AM
    #4
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,255
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
  5. Dec 31, 2010 at 6:24 AM
    #5
    mntbiker2008

    mntbiker2008 [OP] First I derp.. then I herp

    Joined:
    Dec 18, 2008
    Member:
    #11718
    Messages:
    8,172
    Gender:
    Male
    First Name:
    Aaron
    Cincinnati, OH
    Vehicle:
    93 Pick up 4x4 (sold), 10' Mazda 3
    not sure, that is another possibility
    yeah. It is the inline 6. hm... Maybe we will pull that and get it checked.
    thanks!
     
To Top