1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need help with audio/battery issue

Discussion in 'Audio & Video' started by Sproulesxrunner, Dec 1, 2010.

  1. Dec 1, 2010 at 3:41 PM
    #1
    Sproulesxrunner

    Sproulesxrunner [OP] Well-Known Member

    Joined:
    Oct 27, 2010
    Member:
    #45328
    Messages:
    530
    Gender:
    Male
    Canada
    Vehicle:
    08 Xrunner
    Too much for TW to know
  2. Dec 1, 2010 at 3:42 PM
    #2
    707tothe907

    707tothe907 Superior Member

    Joined:
    Oct 28, 2010
    Member:
    #45372
    Messages:
    2,694
    Gender:
    Male
    First Name:
    Jake
    Chico NorCal
    Vehicle:
    05 DCSB Off Road
    I don't think it will be enough...
     
  3. Dec 1, 2010 at 3:51 PM
    #3
    Sproulesxrunner

    Sproulesxrunner [OP] Well-Known Member

    Joined:
    Oct 27, 2010
    Member:
    #45328
    Messages:
    530
    Gender:
    Male
    Canada
    Vehicle:
    08 Xrunner
    Too much for TW to know
    I honestly don't think it will be enough either. I don't understand what's the difference between a deep cycle batter (yellow top) and "high cranking" battery is. All I know is that every car person recommends and installs yellow tops...
     
To Top