1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need More POWER

Discussion in 'Audio & Video' started by bowhuntingaddict, Jan 13, 2012.

  1. Jan 13, 2012 at 9:42 PM
    #1
    bowhuntingaddict

    bowhuntingaddict [OP] Well-Known Member

    Joined:
    Mar 10, 2010
    Member:
    #32949
    Messages:
    81
    Gender:
    Male
    I have two p3sd412s and I'm running them at 4ohms and combined they're running off 750 watts. They arn't hitting very hard at all. Am I safe running them at 2ohms with 1500 watts? The amp is a hofonics hifi 3000.1
     
  2. Jan 13, 2012 at 11:27 PM
    #2
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    4,865
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    I'm curious to see how you'd accomplish this. :confused:
     
  3. Jan 13, 2012 at 11:29 PM
    #3
    Night

    Night Well-Known Member

    Joined:
    Feb 21, 2011
    Member:
    #51613
    Messages:
    981
    Gender:
    Male
    First Name:
    Mike
    Canada
    Vehicle:
    '11 TRD OR AC MagGrey
    Banks Monster Exhaust, aFe ProGuard 7, 3M Film, UnderCoating, alpine 920 headunit, alpine 6.5 components, 20% tint all around, JL Stealthbox, PDX-V9 Amp, Avid Lightbar, Avid Sliders, Full Metal JackRabbit Tonneau, TRD S/C

    Agreed, I would assume what ever the max output/input on the equipment it would be safe.
     
  4. Jan 14, 2012 at 12:01 AM
    #4
    Tvtech

    Tvtech i void warranties

    Joined:
    Jan 12, 2012
    Member:
    #70522
    Messages:
    26
    Gender:
    Male
    First Name:
    Ryan
    Nebraska
    Vehicle:
    05 4x4 Access cab SR5
    You sure there not out of phase
     
  5. Jan 14, 2012 at 10:52 AM
    #5
    bowhuntingaddict

    bowhuntingaddict [OP] Well-Known Member

    Joined:
    Mar 10, 2010
    Member:
    #32949
    Messages:
    81
    Gender:
    Male
    Yeah I just realized you can't run that on 2ohms. I don't know too much about car audio. I may try a new amp. To me the subs just don't sound like they should. You would think to 12 shallows would at least sound better than one kicker 10 that's not
     
  6. Jan 14, 2012 at 11:12 AM
    #6
    Tvtech

    Tvtech i void warranties

    Joined:
    Jan 12, 2012
    Member:
    #70522
    Messages:
    26
    Gender:
    Male
    First Name:
    Ryan
    Nebraska
    Vehicle:
    05 4x4 Access cab SR5
    What size enclosure do you have them in? Ported/ sealed? If that's the hifonics 3000.1 it looks like its stable down to 1ohm. But it should drive those 12s at 4ohms with no need to drop it down.
     
To Top