1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need New Alternator...

Discussion in 'Technical Chat' started by Schully, May 27, 2010.

  1. May 27, 2010 at 10:56 PM
    #1
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    I drive a 5 speed AC and am in the market for a much stronger alternator. I want one that can generate around 200 amps. Has anyone installed anything similar? Does toyota sell a better alternator? If so, what is the output?

    My headlights dim badly when I start pushing my stereo hard and sometimes causes clipping. It ruined my Alpine X series woofer. :frusty: Today I had a new one installed but the same problem will occur if I don't swap my stock alternator.

    And the biggest question...

    Will a new alternator void my warranty?!

    Thanks in advance guys,
    Schully
     
  2. May 27, 2010 at 11:00 PM
    #2
    schiz94

    schiz94 Thread Jacker

    Joined:
    May 26, 2009
    Member:
    #17674
    Messages:
    4,234
    Gender:
    Male
    First Name:
    Caleb
    Bellingham,WA
    Vehicle:
    08 Tacoma Reg Cab
    Morimoto Projector Retrofit, alpine cda-105,Wheelskins leather wheel cover, wet okoles,5% tint on back and 24% on front two windows,Debadged tailgate,custom sockmonkey centercap decals, xr rims pced gloss black.
    sweet truck. i have no idea. i cant help you haha sorry
     
  3. May 27, 2010 at 11:09 PM
    #3
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    Thanks! I'll get my answers sooner or later...I hope lol
     
  4. May 28, 2010 at 5:50 AM
    #4
    DevL

    DevL Well-Known Member

    Joined:
    Feb 23, 2010
    Member:
    #31952
    Messages:
    1,923
    Gender:
    Male
    Have you already done the big three? Did you already have the high output factory alternator (with the tow package)? What are your current amps?

    I have not heard of of clipping being casued by what you are describing. Seems like your gains are not set correctly on your amplifier.
     
  5. May 28, 2010 at 5:57 AM
    #5
    buddywh1

    buddywh1 Well-Known Member

    Joined:
    Apr 23, 2010
    Member:
    #35825
    Messages:
    1,452
    Gender:
    Male
    Philly PA
    Vehicle:
    07 DC SR5 4x4
    It will not void your 'new car warranty' from Toyota, except for the new alternator itself and whatever gets broken while installing it.

    The new alternator should have a warranty although it might be pretty limited if it's a re-man or used one.
     
  6. May 28, 2010 at 6:18 AM
    #6
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    you want a badass alternator.............here ya go.......

    http://www.mean-green.com/

    a lil expensive.....but i have heard awesome things about them...never any bad.
     
  7. Jun 1, 2010 at 6:38 PM
    #7
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    Bump...

    Has anybody encountered this problem? I'm runnin 2 amplifiers, one @ 450 watts and the other 1,000. I'm just not gettin enough juice to my sub amp.
     
  8. Jun 1, 2010 at 6:39 PM
    #8
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    see post above your last one. trust me.
     
  9. Jun 1, 2010 at 6:48 PM
    #9
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    alright alright lol. Now how about fitment? Is it pretty much plug n play? New belt?
     
  10. Jun 1, 2010 at 6:50 PM
    #10
    Jason'sLawnCare

    Jason'sLawnCare Prepared for Bambi

    Joined:
    Apr 12, 2009
    Member:
    #15878
    Messages:
    12,365
    Gender:
    Male
    First Name:
    Jason
    Jacksonville Florida
    Vehicle:
    08 4x4 Double Cab TRD Rugged Trail
    CBI Moab 2.0, CBI Trail Rider 2.0, CBI sliders w/kickout, Superwinch EPi9.0S, OME sport shocks w/886 coils, OME n182, 1.5" aal, JasonBuilt 3/16th full belly skid, BuiltRight uca, Body Mount Chop, 285/75/16 km2's, Rear cat delete, exhaust crossover rerouted, Fog light anytime, Locker mod, Rear leaf tsb, Debadged, Uws Tool Box, Electric Exhaust Cutout, AFE Pro Dry S, Kiwi Wifi, Diff Breather Relocated, Grom Ipod Adapter, Dual Diehard platinum batteries isolated by BlueSea marine switch
    x2.

    Do you guys think a dual battery setup will help him out with this?
     
  11. Jun 1, 2010 at 6:55 PM
    #11
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    I just checked the site, doesn't look like they offer an alternator that fits 2.7 05+ Tacomas. Any other suggestions regarding products?
     
  12. Jun 1, 2010 at 7:02 PM
    #12
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    i would email them and see.....some things may not be listed on their site. other than that......dual battery wouldnt be a good idea yet, since your wanting a bigger alternator for more charging power.

    may wanna find a place that does it and have your stock alt rewound for more amps.
     
  13. Jun 1, 2010 at 7:04 PM
    #13
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    Hmm rewound huh? How many amps is my current output and what is a ballpark figure of how much more I could get out of it?
     
  14. Jun 1, 2010 at 7:06 PM
    #14
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    if you have the towing package.......im thinking its at 130 amp. dont quote me on that tho. you could prolly get one rewound to push 200 amps or more.
     
  15. Jun 1, 2010 at 7:11 PM
    #15
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    I have the standard alt. and apparently the output is only 80 amps...

    Seriously though, thanks for all the help guys. I really appreciate it being that I'm not the biggest gear head in the world. :D
     
  16. Jun 1, 2010 at 7:13 PM
    #16
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    no worries man. let us know what you decide to do.
     
  17. Jun 1, 2010 at 7:13 PM
    #17
    Jason'sLawnCare

    Jason'sLawnCare Prepared for Bambi

    Joined:
    Apr 12, 2009
    Member:
    #15878
    Messages:
    12,365
    Gender:
    Male
    First Name:
    Jason
    Jacksonville Florida
    Vehicle:
    08 4x4 Double Cab TRD Rugged Trail
    CBI Moab 2.0, CBI Trail Rider 2.0, CBI sliders w/kickout, Superwinch EPi9.0S, OME sport shocks w/886 coils, OME n182, 1.5" aal, JasonBuilt 3/16th full belly skid, BuiltRight uca, Body Mount Chop, 285/75/16 km2's, Rear cat delete, exhaust crossover rerouted, Fog light anytime, Locker mod, Rear leaf tsb, Debadged, Uws Tool Box, Electric Exhaust Cutout, AFE Pro Dry S, Kiwi Wifi, Diff Breather Relocated, Grom Ipod Adapter, Dual Diehard platinum batteries isolated by BlueSea marine switch
    I was thinking that his current alt could charge up both the batteries and then when he wants to jam out he would have 2 charged batteries to run off of but I guess that would only work for so long.
     
  18. Jun 1, 2010 at 7:24 PM
    #18
    Schully

    Schully [OP] Well-Known Member

    Joined:
    Oct 31, 2009
    Member:
    #25233
    Messages:
    280
    Gender:
    Male
    First Name:
    Aaron
    Seaside
    Vehicle:
    Black 09 2.7 AC 4x4
    Leather Arm Rests, Alpine Stereo, Pro Comp Wheels, Wet Okoles, Front mud flap delete, Debadged, Rear TSB
    I don't really like the idea of having a secondary battery if I can't help it. I emailed mean green and ohiogen.com. I'll copy paste when I get a reply.
     
  19. Jun 27, 2010 at 8:47 AM
    #19
    craigFLA

    craigFLA Well-Known Member

    Joined:
    Oct 6, 2007
    Member:
    #2944
    Messages:
    420
    Gender:
    Male
    Ft. Lauderdale, Florida
    Vehicle:
    Tacoma TRD Sport Pkg.#1, XSP Package
    Leather, 20" rims, Borla cat-back exhaust, running boards, back up camera/3" screen in rear view mirror, carbon fiber interior trim. Tow Package. MODS: URD intake BHLM. Tinted tails & 3rd brake light Fog Light mod. 5pc Grill Craft (High Gloss Black powder-coat) T-Rex eye-lids AVS Wind Deflectors 3M Window Tint 15 front/30 rear OBX Sports Pedals Viper 5901 / remote start Pioneer AVIC F90BT-NAV Hybrid L8's in doors, L4's and Dynaudio MD102 tweets in custom kicks, morel rear-fill, JL TW5-13" sub, JBL MS-8, 2@Tru B475, Tru 4.65, PPI a600.2, PPI 456 X-over, Raamat BX2 and ensolite. relocated rear seats 3/4" Retrax cover electric dual "dead-bolt-lock" electric tailgate lock. electric Dynalock for Retrax Cover/custom fabricated case. kinetik second battery/power-gate isolation. Powerslot Cryogenic rotors, Hawks HPS Pads, SS lines,painted calipers&drums FULL trans flush mod OE Denso plugs
    Im in the same boat... adding a second battery and HO alternator for my audio system...

    http://www.tacomaworld.com/forum/2n...o-alternator-alternator-fuse.html#post1911027


    might want to check out DCpower alternators (link inside the link above..lol) Suppose to be a plug and play fit..and they produce high amps at idle...a bit expensive...but havent heard or read 1 single bad review on them.

    Looking for advice on my install as far as whether to bypass the fusebox entirely or upgrade the OEM alternator fuse.
     
  20. Jun 27, 2010 at 5:32 PM
    #20
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    4,866
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    You guys who are running into power issues with the Tacoma stock alt are doing something wrong. They should have plenty of juice for your stereo needs.

    And to the OP, if you're clipping your sub you should reset your gains appropriately.
     
To Top