1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Never mess with a streak.

Discussion in 'Technical Chat' started by crownm, Jan 22, 2014.

  1. Jan 22, 2014 at 7:46 PM
    #1
    crownm

    crownm [OP] New Member

    Joined:
    Jan 22, 2014
    Member:
    #121251
    Messages:
    4
    Gender:
    Male
    illinois
    Vehicle:
    05 Tacoma
    Finally after 90k miles I took my 2005 truck to the dealer to get recalls taken care of.(air bag light, pedal trimming and seat belt).
    And lo and behold when I drive home the radio is not working. Today it worked until I turned the truck off and now dead again.
    The dealer checked it out, saw it was dead gave me the "I didn't do it " that I've grown accustomed to from my 5 year old.
    Sooo. Coincidence after 90k miles it just goes bad the only time ive taken it to the dealer. This truck has been flawless. Just normal maintenance.
    Until now.
    Whadya think?
     
  2. Jan 22, 2014 at 9:01 PM
    #2
    KenLyns

    KenLyns 8-in. Third Member

    Joined:
    May 23, 2010
    Member:
    #37674
    Messages:
    26,399
    Gender:
    Male
    Belly of the Beast
    Vehicle:
    4x4 TRD Off Road Full-Auto
    All-Pro Bumper, CBI Sliders, Icon Coilovers, BudBuilt Skids, aFe Intake, Icon VS Rear Shocks, Timbren Bumpstops, All-Pro UCAs, JDM Steering Wheel, ViAir Compressor, Klearz LED 3rd Brake Light, Pop-N-Lock Tailgate Handle, Husky Front Flaps
    Was the airbag light recall the one regarding the steering wheel spiral cable?
    Was the seat belt recall the one regarding the loose bolt in the access cab door?

    I wonder if any of the work required unplugging the clock/anti-theft/airbag indicator module below the radio, which would require briefly pulling the radio out. Maybe a wire got pinched or a connector wasn't fully seated.
     
  3. Jan 23, 2014 at 2:49 PM
    #3
    crownm

    crownm [OP] New Member

    Joined:
    Jan 22, 2014
    Member:
    #121251
    Messages:
    4
    Gender:
    Male
    illinois
    Vehicle:
    05 Tacoma
    Thanks for the tip.
    That's what I thought but the dealer said they only messed with the steering column.
     
  4. Jan 23, 2014 at 6:58 PM
    #4
    KenLyns

    KenLyns 8-in. Third Member

    Joined:
    May 23, 2010
    Member:
    #37674
    Messages:
    26,399
    Gender:
    Male
    Belly of the Beast
    Vehicle:
    4x4 TRD Off Road Full-Auto
    All-Pro Bumper, CBI Sliders, Icon Coilovers, BudBuilt Skids, aFe Intake, Icon VS Rear Shocks, Timbren Bumpstops, All-Pro UCAs, JDM Steering Wheel, ViAir Compressor, Klearz LED 3rd Brake Light, Pop-N-Lock Tailgate Handle, Husky Front Flaps
  5. Jan 24, 2014 at 10:48 PM
    #5
    crownm

    crownm [OP] New Member

    Joined:
    Jan 22, 2014
    Member:
    #121251
    Messages:
    4
    Gender:
    Male
    illinois
    Vehicle:
    05 Tacoma
    Thanks.
    It has now decided to work on its own.
    Probably like you said, but hopefully I will never have to see.
    Thanks for the video. :)
     
  6. Jan 25, 2014 at 7:40 AM
    #6
    crownm

    crownm [OP] New Member

    Joined:
    Jan 22, 2014
    Member:
    #121251
    Messages:
    4
    Gender:
    Male
    illinois
    Vehicle:
    05 Tacoma
    The radio wasnt part of the recall. After they did the work it did weird things for about
    15 minutes (no display, buttons not working).
    When I immediately took it back to the dealer you could only hear sound. After they checked it out, it totally died.
    I hope its not haunted.
    Its a 2005 and have had nothing but great luck.
     
To Top