1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

New Lift Shake

Discussion in 'Suspension' started by knabber, Apr 4, 2011.

  1. Apr 4, 2011 at 4:07 PM
    #1
    knabber

    knabber [OP] Member

    Joined:
    Oct 20, 2010
    Member:
    #44983
    Messages:
    16
    Gender:
    Male
    First Name:
    Knabb
    Hampton Roads
    Vehicle:
    Tacoma TRD 4x4 Sport
    6" Fabtech Basic Kit
    Just had a 6" Fabtech kit installed on 07 Tacoma, running 33x12 Nitto Trail Grapplers and 17x9 Fuel Hostage Rims. This is my first lifted vehicle, so I was not sure what to expect ride wise. My only complaint is a bump steer/shimmy in the steering wheel in the 40mph range. The chalk test has put me down to around 28psi in the front tires, and that seemed to help a little bit. I am not sure if this is something that is normal in these lifted trucks, or if I have a balancing/allignment problem. She also seems to pull a little left at times. The top of the front tires seem to point in towards the engine slightly as well. Any advice would be appreciated.

    Also had some issues with the balancing weights not sticking to the rim, thought about trying out the balancing beads. Anybody run those?
     
To Top