1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

New stereo install completed.

Discussion in 'Audio & Video' started by lowcel, Nov 4, 2008.

  1. Nov 4, 2008 at 4:57 AM
    #1
    lowcel

    lowcel [OP] Well-Known Member

    Joined:
    Sep 15, 2008
    Member:
    #9245
    Messages:
    117
    Gender:
    Male
    Charleston, WV
    Vehicle:
    09 TRD Sport Access Cab
    Stereo, d-rings, still pretty new
    Just wanted to take a minute and show some pictures from the installation for my new head unit. I went with a Kenwood DDX712 head unit, Sirius radio for it, PAC PWI-JACK steering wheel control adapter, ipod adapter, and the sirius antenna adaptor that allowed me to use the antenna that is on top of the vehicle.

    The only thing I'm not overly happy with is the Scoshe mounting kit, in my opinion it sucks. The trim piece rattles and moves around a good bit. Getting the double din radio in perfect position before mounting the trim piece is annoying as well.

    Here is the antenna adaptor on the driver side.
    [​IMG]

    Here are the ipod cables coming out of the dash.
    [​IMG]

    Here they are in the glove box, along with the usb cables.
    [​IMG]
    [​IMG]
    [​IMG]

    Here is the sirius radio, it's mounted under the passenger seat.
    [​IMG]
    [​IMG]

    Here is the head unit installed.
    [​IMG]
     
  2. Nov 4, 2008 at 6:17 AM
    #2
    jizzam93

    jizzam93 Well-Known Member

    Joined:
    Mar 26, 2008
    Member:
    #5530
    Messages:
    154
    Gender:
    Male
    First Name:
    Kris
    H-Town, TX
    Vehicle:
    08 DC PreRunner SR5
    YES!!
    Thats sick bro!! Congrats on a job well done!! Hows that PAC steering wheel adapter working out for you? I need one too for my Kenwood.
     
  3. Nov 4, 2008 at 6:35 AM
    #3
    robsatx

    robsatx Well-Known Member

    Joined:
    Oct 24, 2008
    Member:
    #10209
    Messages:
    54
    San Antonio
    Vehicle:
    2005 Tacoma & 2008 Tundra
    Audio, lift
    Nice Job! On the dash kit did you try using the yellow inserts from the old head unit?
     
  4. Nov 4, 2008 at 6:39 AM
    #4
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    good writeup. Thanks.
     
  5. Nov 4, 2008 at 6:43 AM
    #5
    lowcel

    lowcel [OP] Well-Known Member

    Joined:
    Sep 15, 2008
    Member:
    #9245
    Messages:
    117
    Gender:
    Male
    Charleston, WV
    Vehicle:
    09 TRD Sport Access Cab
    Stereo, d-rings, still pretty new
    Yeah, I used the original clips. Kit still doesn't fit perfect, reminds me of why I always used Metra kits in the past.
     
  6. Nov 4, 2008 at 6:45 AM
    #6
    007Tacoma

    007Tacoma I dub thee malicious!

    Joined:
    Jan 4, 2007
    Member:
    #643
    Messages:
    6,664
    Gender:
    Male
    First Name:
    Mark
    San Antonio, TX
    Vehicle:
    2015 4Runner Trail Edition Premium
    Cloaking Device
    I am pretty happy with the Metra kit that I got from Crutchfield. I just wish that I had a head unit like yours! That thing is awesome!

    :thumbsup: :thumbsup:
     
  7. Nov 4, 2008 at 6:45 AM
    #7
    lowcel

    lowcel [OP] Well-Known Member

    Joined:
    Sep 15, 2008
    Member:
    #9245
    Messages:
    117
    Gender:
    Male
    Charleston, WV
    Vehicle:
    09 TRD Sport Access Cab
    Stereo, d-rings, still pretty new
    The adapter is working out pretty well, it was pretty easy to install after downloading the vehicle specific instructions off the net. The instructions that come with it are lacking though.
     
  8. Nov 4, 2008 at 6:55 AM
    #8
    wcm608

    wcm608 Well-Known Member

    Joined:
    May 2, 2008
    Member:
    #6348
    Messages:
    102
    Gender:
    Male
    Pittsburgh, Pa
    Vehicle:
    08 DC LB 4x4 SR5 Impulse Red
    Where did you get the specific instructions?
     
  9. Nov 4, 2008 at 9:30 AM
    #9
    lowcel

    lowcel [OP] Well-Known Member

    Joined:
    Sep 15, 2008
    Member:
    #9245
    Messages:
    117
    Gender:
    Male
    Charleston, WV
    Vehicle:
    09 TRD Sport Access Cab
    Stereo, d-rings, still pretty new
  10. Nov 4, 2008 at 9:44 AM
    #10
    montgomery_30824

    montgomery_30824 Well-Known Member

    Joined:
    Jul 24, 2008
    Member:
    #8111
    Messages:
    797
    Gender:
    Male
    First Name:
    Lee
    Guyton, Ga
    Vehicle:
    '06 prerunner 4dr
    K & N airfilter, custom built 10" sub boxes, pioneer head, mag-lite mod, Blue LED dash lights, custom painted engine cover, mud flap removal mod, alarm/remote start installed,
    looks great. i will ave that same head unit one day when i can convince the wifey that we can aford it.
     
  11. Nov 4, 2008 at 10:15 AM
    #11
    wcm608

    wcm608 Well-Known Member

    Joined:
    May 2, 2008
    Member:
    #6348
    Messages:
    102
    Gender:
    Male
    Pittsburgh, Pa
    Vehicle:
    08 DC LB 4x4 SR5 Impulse Red
    Thanks. I have one on order.
     
  12. Nov 17, 2008 at 1:56 PM
    #12
    drturn90

    drturn90 New Member

    Joined:
    Nov 6, 2008
    Member:
    #10536
    Messages:
    4
    Gender:
    Male
    Tampa FL
    Vehicle:
    09 Tacoma prerunner 2x4
    Off road package
    Where did you get the sirius antenna adapter and do you have a cable name or #? Looks good
     
  13. Nov 18, 2008 at 3:54 AM
    #13
    lowcel

    lowcel [OP] Well-Known Member

    Joined:
    Sep 15, 2008
    Member:
    #9245
    Messages:
    117
    Gender:
    Male
    Charleston, WV
    Vehicle:
    09 TRD Sport Access Cab
    Stereo, d-rings, still pretty new
To Top