1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Newbie Dealership Question

Discussion in '2nd Gen. Tacomas (2005-2015)' started by MGMTACO, Jul 30, 2009.

  1. Jul 30, 2009 at 10:40 AM
    #1
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road
    Hey All, So I purchased an 09 Dbl cab 4x4 off Road last week and the dealership put on the Truxxx (junk I know) level lift, rims and 33"'s. And the tires (as you can probably imagine) are rubbing on the frame when driving into parking lots at an angle, full turn while compressing the suspension.

    Question, isn't the dealership liable for this? Do I have any leverage?

    I'm about to call the dealership but wanted your opinions and suggestions first.

    What are they gonna do/say? Tell me I'm ef'd?....

    As always, thank you for your time.
     
  2. Jul 30, 2009 at 11:18 AM
    #2
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    That'd be badass if they paid to cut your frame and still warranty it!!!!


    I doubt theres much they can do. I strongly doubt they can be 'LIABLE' for it rubbing, thats pretty much assumed with any vehicle. You asked them to install it for you, thats all. Unless your rubbing on EVERY turn, I'd ask them about the cab mounts, but otherwise, I'd just live with it. Mine only hits at half turn on a really big bump, IE chuck holes. I took it out wheeling through the sand pits and mud trails and only hit ONCE, and I wasn't taking it 'easy' on it either.
     
  3. Jul 30, 2009 at 11:20 AM
    #3
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    [​IMG]

    Nice truck! :)
     
  4. Jul 30, 2009 at 11:25 AM
    #4
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road
    Thanks for your reply.
    I didn't ask them to install anything. I would have ended up with a stock unit but they had 3 of these setups on their lot. Definitely not every turn, same as yours I'm guessing. Hits once or twice a day on driveways mostly. Cab mount? Cab Mount huh... Something like this > http://www.eautoworks.com/product-Daystar-189117/Toyota-Tacoma.htm ?



     
  5. Jul 30, 2009 at 11:27 AM
    #5
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road
    Thank you! The rub is killin me though....

     
  6. Jul 30, 2009 at 11:44 AM
    #6
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,255
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    Damn...if you didn't ask for it - tell them to take it OFF!

    How much did they charge you for it?

    You could probably get a better lift, wheels & tires that you actually want, and pay a lot less than what they charged you. Or, better yet..... buy some new stuff anyway and sell the stuff they put on.
     
  7. Jul 30, 2009 at 11:46 AM
    #7
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    No, not cab bushings, if you look directly behind your front tires, you'll see what its rubbing on. Its the actual mount on the frame where you cab attaches. Search the forums for 'cab mount' and you'll see where people are actually cutting into the bottom of the cab mounts and making more clearance.


    Theres nothing you can do to fix the rub otherwise. Even guys with the 6" lift have the problem.
     
  8. Jul 30, 2009 at 11:47 AM
    #8
    JACKEL142

    JACKEL142 Well-Known Member

    Joined:
    Jul 9, 2009
    Member:
    #19480
    Messages:
    86
    Gender:
    Male
    Nashville
    Vehicle:
    2009 Sport LB 4x4 Speedway
    If they sold the vehicle as new, it must operate & be covered by a new car warranty.
    If they intalled the aftermarket acces. It's up to them to fix it.
    If they give you trouble, take it to the next level.
     
  9. Jul 30, 2009 at 2:05 PM
    #9
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road

    Dearlership robbed me for sure but I wouldn't have been able to afford the upgrades for years without them being bundled in the big dollar cost.
     
  10. Jul 30, 2009 at 2:07 PM
    #10
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road
    Right, yeah I've read about the cutting. Not something I ready for quite yet.

    6" lifts are rubbing!! :eek:
     
  11. Jul 30, 2009 at 2:09 PM
    #11
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road

    I'm going to call in the morning and see what they say. They are like 140 miles away from me though.....

    What's the next level? BBB?
     
  12. Jul 31, 2009 at 3:06 AM
    #12
    FoxySandChick

    FoxySandChick Well-Known Member

    Joined:
    Sep 27, 2008
    Member:
    #9505
    Messages:
    2,963
    Gender:
    Female
    First Name:
    Kristin
    Henderson, NV
    Vehicle:
    07 DC 4x4 Base model V6 Impulse Red Pearl
    De-badged, limo tint, black wet okole's, weathertechs, extra d-rings, TSB bilsteins
    Toyota Corporate 800-331-4331
     
  13. Jul 31, 2009 at 7:04 AM
    #13
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road

    Aahhh, Grand Poobah!

    Gracias Senorita!
     
  14. Jul 31, 2009 at 7:09 AM
    #14
    -TRDMAN-

    -TRDMAN- ΜΟΛΩΝ ΛΑΒΕ

    Joined:
    Dec 18, 2006
    Member:
    #514
    Messages:
    2,201
    Gender:
    Male
    First Name:
    Greg
    Clarion Pa
    Vehicle:
    F-150
    Im going to the dealership right know to get my check engine light looked at! later
     
  15. Jul 31, 2009 at 10:41 AM
    #15
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    Keep us posted!
     
  16. Aug 4, 2009 at 7:46 AM
    #16
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road
    Well, I wanted to give an update.

    After much debate and leaving one message with no response......... I'm not even going to deal with calling over the rub. It's soo minor and if others running 33's and 3" have the rub as well I doubt I will like any of the options the dealership gives me. In addition, I read a bunch of reviews about this particular dealership and I'm going to save myself of the stress of dealing with them.


    As always thanks for your replies, suggestions and advise.
     
  17. Aug 4, 2009 at 7:53 AM
    #17
    senor taco

    senor taco ROLLIN ON RUST

    Joined:
    Jan 7, 2009
    Member:
    #12330
    Messages:
    2,335
    Gender:
    Male
    First Name:
    Steve
    Monterey Bay, Ca
    Vehicle:
    O7 Tacoma PreRunner SR5
    17in fj cruiser wheels satoshi grille with devil horns emblem Single in double out 50 series flowmaster with stainless tips Kenwod ddx512 double din touch screen DVD reciver with a single Rockford fosgate 12 in sub with an alpine amp tinted tail and third break light silverstar head and fog lights k&n drop in Billy 5100's on all 4 corners with a 2"AAL
    What was the reason for the "check engine" light ?
     
  18. Aug 4, 2009 at 8:02 AM
    #18
    MGMTACO

    MGMTACO [OP] Member

    Joined:
    Jul 21, 2009
    Member:
    #19947
    Messages:
    22
    Gender:
    Male
    Santa Cruz
    Vehicle:
    09 MGM TRD Off Road
    Waitin on TRDMAN for that one.
     
  19. Aug 4, 2009 at 8:04 AM
    #19
    jonny

    jonny Betty White Edition Heep ZJ

    Joined:
    Jun 21, 2007
    Member:
    #1887
    Messages:
    8,375
    Gender:
    Male
    First Name:
    John
    you should look into getting your cab mounts trimmed and plated. plenty of guys on here have done this and have had 0 problems. I have a 3" lift and 33's and have minor rubbing at full lock on an incline or full lock in reverse. i just learned to live with it. i am not going to cut my mounts...just in case i have to trade in in the near future. :(
     
  20. Aug 4, 2009 at 8:53 AM
    #20
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    Same, I've got probably the meatiest 285's you're going to find and I only rub one in a blue moon.
     
To Top