1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

No Check Engine Light

Discussion in 'Technical Chat' started by koozer22, May 12, 2011.

  1. May 12, 2011 at 5:01 PM
    #1
    koozer22

    koozer22 [OP] Member

    Joined:
    May 12, 2011
    Member:
    #56526
    Messages:
    5
    Gender:
    Male
    Ooltewah, TN
    Vehicle:
    2006 PreRunner SR5 TRD Offroad
    I just got my 2006 Prerunner V6 and took it to get emissions testing. The check engine light does not come on when the key is turned to "on". (Never thought I would actually want it to come on!)
    My first thought was that there was a bad bulb, but I took out the instrument cluster and discovered there are no bulbs, just lights on the board. All other lights are coming on.

    They found to OBD codes - both for the camshaft position sensor. I am going to replace that this weekend, but have no clue where to go for getting the check engine light back on
     
  2. May 12, 2011 at 5:04 PM
    #2
    Grande

    Grande Well-Known Member

    Joined:
    Aug 3, 2010
    Member:
    #41153
    Messages:
    922
    First Name:
    John
    Victorville, CA
    Vehicle:
    Thomas, The little truck that could
    Painted badges. Bedlined grille, wheels and lower valence. Billies 5100 @.85 up front. Dodger Jack Ball Mod. Custom trail damaged rear bumper (for the time being). Lil LED light bar on grill. Hard-wired Radar Det. Custom Projector fog lights, Anytime Fog Mod, HIDS, White LED accent lighting on a Single post double toggle swicht, so they light up wit my door/dome light, or always on, or never on. LED map and dome lights.
    wait, why do u want ur light on? so u can fail ur emissions???



    Edit: never mind i had to re read it, sounded confusing....
     
  3. May 12, 2011 at 6:10 PM
    #3
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    4,091
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    Did you got truck used ?
    It looks like somebody remove the light to mask the sensor problem
     
  4. May 12, 2011 at 6:20 PM
    #4
    koozer22

    koozer22 [OP] Member

    Joined:
    May 12, 2011
    Member:
    #56526
    Messages:
    5
    Gender:
    Male
    Ooltewah, TN
    Vehicle:
    2006 PreRunner SR5 TRD Offroad
    Are the lights soldered in? If so, what's the best way to replace them.
     
  5. May 12, 2011 at 6:24 PM
    #5
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,243
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    Yeah they are soldered. Any good electronics guy should be able to change it.
     
  6. May 14, 2011 at 7:54 AM
    #6
    koozer22

    koozer22 [OP] Member

    Joined:
    May 12, 2011
    Member:
    #56526
    Messages:
    5
    Gender:
    Male
    Ooltewah, TN
    Vehicle:
    2006 PreRunner SR5 TRD Offroad
    Any idea where to buy the replacement bulbs? Just called Toyota dealership, and the only solution they have for me is to replace the whole instrument cluster for $280!
     
To Top