1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

No Idle

Discussion in '1st Gen. Tacomas' started by Shiner 1, Sep 20, 2012.

  1. Shiner 1

    Shiner 1 [OP] New Member

    Joined:
    Sep 17, 2012
    Member:
    #87098
    Messages:
    4
    Gender:
    Male
    First Name:
    Brian
    Texas
    Vehicle:
    2004 Tacoma
    Again on my 2004 Toyota Tacoma 2rz-fe I have no idle. What
    gives. Runs good other wise but will not idle. Any ideas.
    Brian
     
  2. dually

    dually Low and slow

    Joined:
    Jul 29, 2008
    Member:
    #8205
    Messages:
    3,134
    Gender:
    Male
    Interstate underpass
    Vehicle:
    05 Indigo 4wd Longbed
    Not as many as the 98..
    Idle air control valve on the throttle body.
    1. Needs to be cleaned
    2. Needs to be replaced

    2RZ-IAC.jpg
     
  3. dually

    dually Low and slow

    Joined:
    Jul 29, 2008
    Member:
    #8205
    Messages:
    3,134
    Gender:
    Male
    Interstate underpass
    Vehicle:
    05 Indigo 4wd Longbed
    Not as many as the 98..
  4. TacoDell

    TacoDell Truck ~n~ Tow

    Joined:
    Jun 20, 2008
    Member:
    #7448
    Messages:
    978
    Gender:
    Male
    SoCal
    Vehicle:
    '00 Tacoma SR5 4X
    Donahoe CO's, Deaver leaf paks, Lockright Locker, All Pro body armor ( sliders, front and rear bumpers ), All Pro under belly skids, Warn M8K w/Masterpull synthetic line, Dual Optima battery system, 4 ea LightForce Striker 170 offroad lights, 8 ea wired rock lights, and plenty more I'm sure
    Check the FSM... I don't believe the 2rz has an IAC

    thought that was only on the 5vze
     
  5. dually

    dually Low and slow

    Joined:
    Jul 29, 2008
    Member:
    #8205
    Messages:
    3,134
    Gender:
    Male
    Interstate underpass
    Vehicle:
    05 Indigo 4wd Longbed
    Not as many as the 98..
    They do... I have one in my garage..
     
  6. TacoDell

    TacoDell Truck ~n~ Tow

    Joined:
    Jun 20, 2008
    Member:
    #7448
    Messages:
    978
    Gender:
    Male
    SoCal
    Vehicle:
    '00 Tacoma SR5 4X
    Donahoe CO's, Deaver leaf paks, Lockright Locker, All Pro body armor ( sliders, front and rear bumpers ), All Pro under belly skids, Warn M8K w/Masterpull synthetic line, Dual Optima battery system, 4 ea LightForce Striker 170 offroad lights, 8 ea wired rock lights, and plenty more I'm sure
    my mistake... :eek:

    I should have stated, " I thought..."
    ...maybe it was the 3rz that doesn't :notsure:

    oh well... since you know...
    then I would agree that could be suspect.
     
  7. budget76

    budget76 Active Member

    Joined:
    Sep 7, 2012
    Member:
    #86420
    Messages:
    36
    Gender:
    Male
    First Name:
    Mike
    New Jersey
    Vehicle:
    98 xt-cab 4x4 4cl/2.7 stock man
    soon want dual lockers Picture was my 85 dual arb great
    easy to clean.

    carb cleaner to make spotless,

    then lube the moving parts (i use wd40 but other are better)
    must move freely, not bind

    clean electric contacts and use dielectric grease on them when reassembling
    to prevent oxidation.

    Had this problem many times on my classic saabs, but at least
    the saabs stayed in "limp" mode meaning they ran but ran shitty enough to get you home.

    will do on my 98 as i suspect 14 years of use and no cleaning is leading
    me to highway issues. (preventive maintenance)
     
To Top