1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

No power to fuel pump

Discussion in '1st Gen. Tacomas (1995-2004)' started by Butter, Dec 30, 2012.

  1. Dec 30, 2012 at 1:03 PM
    #1
    Butter

    Butter [OP] New Member

    Joined:
    Dec 30, 2012
    Member:
    #94043
    Messages:
    1
    Gender:
    Male
    First Name:
    Brian
    Tn
    Vehicle:
    All
    I have a 2003 3.4 v6 fuel pump went out replaced it now I have no power to it I have checked fuses and relays
     
  2. Dec 31, 2012 at 4:54 AM
    #2
    Millertime187

    Millertime187 I'll be your huckleberry!

    Joined:
    Sep 25, 2012
    Member:
    #87698
    Messages:
    1,922
    Gender:
    Male
    First Name:
    David
    Clay City, KY
    Vehicle:
    1995 Taco
    Just a few little things. It's my DD
    My 2cents. If there is something else wrong the ECM will not send power to the fuel pump. Try and hook your old pump to a battery direct and see if it works.
     
  3. Dec 31, 2012 at 4:15 PM
    #3
    koco

    koco Well-Known Member

    Joined:
    May 25, 2012
    Member:
    #79503
    Messages:
    239
    Gender:
    Male
    Bay Area Ca.
    Vehicle:
    '01 Taco
    Around $26,000 worth of unleaded in the fuel tank.
    Also test the fuel pump circuit to see if it gets power when it's supposed to.
     
To Top